Package Details: firefox-extension-ublock-git r2664.8919ea1-1

Git Clone URL: https://aur.archlinux.org/firefox-extension-ublock-git.git (read-only)
Package Base: firefox-extension-ublock-git
Description: An efficient blocker for modern browsers. Fast and lean. Written from scratch. Development through benchmarking.
Upstream URL: https://github.com/chrisaljoudi/uBlock
Licenses: GPL
Submitter: sxe
Maintainer: sxe
Last Packager: sxe
Votes: 14
Popularity: 0.000000
First Submitted: 2014-12-20 15:15
Last Updated: 2015-06-23 08:52

Latest Comments

sxe commented on 2015-05-17 09:16

thx, done

rtfreedman commented on 2015-05-17 01:35

Please add git to makedepens=()

sxe commented on 2015-04-10 07:17

Switched to the chris repository for now, what a mess. I hope this repo will stay the official one.

ThePierrezou commented on 2015-04-08 16:25

There is a new repo : https://github.com/chrisaljoudi/uBlock
"The uBlock project's main development responsibilities have been transferred to Chris Aljoudi (chrisaljoudi on GitHub)."(https://github.com/chrisaljoudi/uBlock/releases)

ThePierrezou commented on 2015-04-08 16:24

There is a new repo : https://github.com/chrisaljoudi/uBlock

sxe commented on 2015-01-16 19:51

You are right, the git repository changed. The extension is now in beta.

I fixed the PKGBUILD, should work now.

nbvcxz commented on 2015-01-16 17:48

Cloning into 'firefox-extension-ublock-git'...
done.
fatal: Cannot update paths and switch to branch 'makepkg' at the same time.
Did you intend to checkout 'origin/ports/xpi' which can not be resolved as commit?
...
Fails with Firefox 36 - any idea?

sxe commented on 2014-12-23 10:44

Hi mittens2001,
that is correct. The extension is installed to: "/usr/lib/firefox/browser/extensions/" but nightly for example is per default installed to "/opt/firefox-37.0a1", so it cannot work.

You have to alter the extension install path in the PKGBUILD to make it work.

Greetings

mittens2001 commented on 2014-12-23 02:33

doesn't seem to be compatible with firefox-aurora or firefox-nightly (after editing the dependencies)