Package Details: firefox56 56.0.2-2

Git Clone URL: https://aur.archlinux.org/firefox56.git (read-only)
Package Base: firefox56
Description: Old version of the standalone web browser from mozilla.org
Upstream URL: https://www.mozilla.org/firefox/
Licenses: GPL, MPL, LGPL
Conflicts: firefox
Provides: firefox
Submitter: Splith
Maintainer: Splith
Last Packager: Splith
Votes: 2
Popularity: 0.126998
First Submitted: 2017-12-01 20:02
Last Updated: 2018-07-06 00:48

Dependencies (32)

Required by (214)

Sources (12)

Latest Comments

Splith commented on 2018-07-06 00:46

Patch and minor fixes added, thanks andrius4669

andrius4669 commented on 2018-06-07 18:34

https://bugzilla.mozilla.org/show_bug.cgi?id=1435695

andrius4669 commented on 2018-06-07 16:27

when building, got:

==> Starting prepare()...

mkdir: cannot create directory ‘path’: File exists

mkdir should have -p and later ln should have -f

Splith commented on 2018-03-23 06:21

That would be because partial upgrades are not supported per the wiki: https://wiki.archlinux.org/index.php/System_maintenance#Partial_upgrades_are_unsupported

I'm not going to go through and check every library to see what exact minimum versions are required for building, but alas for this one time I shall update it.

kaptoxic commented on 2018-03-23 05:35

I think you missed that I wrote "version constraint". Some systems might have older sqllite3 (like in my case) and on those the compilation will throw an error.

Splith commented on 2018-03-21 08:17

I've just done a test build up to Mach's compile stage and it's working fine. SQLite is already a package requirement so this looks to be a problem with your install or you've edited the package build file to remove this requirement.

kaptoxic commented on 2018-03-21 00:01

I got an error due to a missing version constraint: "configure: error: Library requirements (sqlite3 >= 3.19.3) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." Should be easy to add it.

Splith commented on 2018-01-06 22:48

Package has been fixed up and now compiles and runs. It would probably be possible to get this to run alongside firefox 57 but I'm not going to put any time/effort into that, I want this as a dropin replacement on my systems, firefox 57 screws with and messes up the firefox 56 UI so if you want to have 56 and 57 side-by-side you will need to create your own package and submit it to the AUR.

polarathene commented on 2017-12-30 05:30

rm: cannot remove '/tmp/firefox56/pkg/firefox56/usr/lib/firefox56/dictionaries': No such file or directory

This is from line 188 in the PKGBUILD. The directory does not exist, but '/tmp/firefox56/pkg/firefox56/usr/lib/firefox/dictionaries' does, '/tmp/firefox56/pkg/firefox56/usr/lib/firefox56/' contains two directories, browser and distribution each containing a single file. Those two files/directories are created by PKGBUILD package() function.

It seems that the desired contents are living in ../firefox, rather than ../firefox56 which would be $pkgname

kaptoxic commented on 2017-12-26 12:39

Can this package be installed alongside FF57? If not, is it possible to change it so that it can (e.g. uses firefox56 as name of the executable, etc.)?