Package Details: firestorm-bin 7.1.9.74745-1

Git Clone URL: https://aur.archlinux.org/firestorm-bin.git (read-only, click to copy)
Package Base: firestorm-bin
Description: Firestorm is a feature-packed third-party viewer for Second Life.
Upstream URL: http://www.firestormviewer.org/
Licenses: GPL
Submitter: chungy
Maintainer: chungy
Last Packager: chungy
Votes: 62
Popularity: 0.175610
First Submitted: 2011-06-21 18:27 (UTC)
Last Updated: 2024-06-21 18:52 (UTC)

Dependencies (32)

Required by (0)

Sources (3)

Latest Comments

1 2 3 4 5 6 .. 11 Next › Last »

lavaflyer commented on 2024-03-04 16:57 (UTC) (edited on 2024-03-04 16:59 (UTC) by lavaflyer)

This sounded promising, but I am still getting the same SDL_init() error.

I have removed "sdl12-compat" and installed "sdl" (from AUR). I have also re-installed "firestorm-bin". Not dice. Can anyone thing of a step I might gave skipped or done incorrectly?

Chewie commented on 2024-03-02 06:30 (UTC)

Replacing sdl2-compat with sdl(AUR) fixed it for me.

lavaflyer commented on 2023-12-16 21:25 (UTC)

It still fails the same way :(

mim commented on 2023-12-16 19:37 (UTC)

@lavaflyer You might be missing the multilib repo. Check your pacman.conf.

https://wiki.archlinux.org/title/official_repositories

lavaflyer commented on 2023-12-16 19:09 (UTC)

Hi all, I am getting errors when trying to run firestorm-bin (versions 6.6.14 and (the new) 6.6.17). Note that this is on an older machine I used to use for firestorm (1-2 years ago), but it did work then.

A small window pops up that says, "sdl_init() failure, window creation error".

Also, the console has quite a lot of stuff, but of particular interest I see "sdl_init() failed! dsp: No such audio device"

I've tried many things, including disabling audio via command-line options, but I think audio might be a red herring, especially given the window creation error. I'd appreciate any ideas or info on how to get this working again.

Unrelated note: when making the package ("makepkg -s"), I twice get a security error regarding use of the "find" commands. I commented these out to get the script able to complete:

#find app_settings skins -type f -execdir chmod 644 "{}" +
#find -L . -type l -delete

Again, this may not be related, but adding it here for completeness. And any ideas very welcome!

sysconfig commented on 2023-12-16 01:21 (UTC)

Thanks for the update @chungy!

chungy commented on 2023-12-15 16:51 (UTC)

I'll hopefully have this updated today. Haven't had access to my PC in a few days.

sysconfig commented on 2023-12-15 16:38 (UTC)

@HackThePlanet, 6.6.16 has been pulled by the devs because it had bugs affecting large groups of people: https://www.firestormviewer.org/woops/

Hoping for @chungy to provide the fixed version 6.6.17 soon. It's only been out for a day or so.

HackThePlanet commented on 2023-12-15 15:10 (UTC)

Could help me figure out why i can't actually download the source package? I get this on install, and when i also click the link in the list of files it says page can't be found. Been like that for a few months now-

curl: (22) The requested URL returned error: 404 ==> ERROR: Failure while downloading https://downloads.firestormviewer.org/release/linux/Phoenix-Firestorm-Releasex64-6-6-16-70339.tar.xz Aborting...

johnvranos commented on 2023-12-15 05:57 (UTC)

There is a new, bugfix release, version 6.6.17 (70368).

Please, update the package.

Thank you very much for maintaining the package in AUR.