Package Details: fish-git 2:3.1.2.r2055.gc633ce7e7-1

Git Clone URL: https://aur.archlinux.org/fish-git.git (read-only, click to copy)
Package Base: fish-git
Description: User friendly shell intended mostly for interactive use.
Upstream URL: http://fishshell.com
Keywords: shell
Licenses: GPL2
Conflicts: fish, fish-shell
Provides: fish, fish-shell
Submitter: SanskritFritz
Maintainer: SanskritFritz
Last Packager: SanskritFritz
Votes: 65
Popularity: 0.32
First Submitted: 2010-11-17 22:27
Last Updated: 2021-02-07 15:29

Dependencies (13)

Required by (62)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

SanskritFritz commented on 2018-12-30 10:06

@acomagu Just makepkg and it automagically compiles 3.0. Please read this: https://wiki.archlinux.org/index.php/VCS_package_guidelines

acomagu commented on 2018-12-30 07:38

Why does this package stay at the version for years? I think should be disown.

SanskritFritz commented on 2018-12-29 09:59

@rsheasby Has the build process been changed in any way? If not, there is no need to update this package.

SanskritFritz commented on 2016-11-27 16:49

Done, thanks for the heads-up @terlar.

terlar commented on 2016-11-27 05:54

The build-steps has changed, the diff:

35c35
< autoconf
---
> autoreconf --no-recursive

z3ntu commented on 2016-09-18 10:53

The package doesn't compile for me right now (tested on x86_64 & armv6h) - see https://github.com/fish-shell/fish-shell/issues/3388 for bug report. EDIT: Already fixed.

And can you please add "armv6" to the architectures, as it works building there.

SanskritFritz commented on 2016-04-20 07:23

etu just recompile the package and you got it.

etu commented on 2016-04-20 06:59

2.3b1 is out :)

SanskritFritz commented on 2016-04-17 18:06

Guys, thanks, done.

RaphaelCosta commented on 2016-04-17 00:38

Emergency:
Updated today and all logins were broken complaining about missing libpcre2-32.so.0. Tested with no .config/fish. Using community/fish works without pcre2.

Users afflicted by this issue would have to chroot. I apologize but I'm flagging this out of date. There must be a problem somewhere but for now you need to add community/pcre2 to list of dependencies until it's fixed.