Package Details: fityk 1.3.2-1

Git Clone URL: https://aur.archlinux.org/fityk.git (read-only, click to copy)
Package Base: fityk
Description: A program for nonlinear fitting of analytical functions to data.
Upstream URL: http://fityk.nieto.pl/
Keywords: analysis Data fitting
Licenses: GPL
Submitter: td123
Maintainer: saxonbeta
Last Packager: saxonbeta
Votes: 22
Popularity: 0.000000
First Submitted: 2012-02-17 02:15 (UTC)
Last Updated: 2022-08-06 22:58 (UTC)

Latest Comments

KingElrond commented on 2022-07-15 07:48 (UTC)

After today's wxWidgets 3.2 update, the package is not working anymore.

fityk: error while loading shared libraries: libwx_gtk2u_adv-3.0.so.0: cannot open shared object file: No such file or directory

Any workaround? Thanks!

pcapiod commented on 2021-08-23 14:15 (UTC) (edited on 2021-08-23 14:17 (UTC) by pcapiod)

I could compile fityk with the latest changes by adding

CXXFLAGS="-std=c++14"

to the configure arguments.

The configure syntax should be changed to:

./configure CXXFLAGS="-std=c++14"

Tio commented on 2021-06-18 23:58 (UTC)

I get this error:

make[3]: *** [Makefile:1162: libfityk_la-data.lo] Error 1
make[3]: *** [Makefile:1127: libfityk_la-eparser.lo] Error 1
make[3]: *** [Makefile:1134: libfityk_la-cparser.lo] Error 1
make[3]: *** [Makefile:1106: libfityk_la-logic.lo] Error 1
make[3]: *** [Makefile:1148: libfityk_la-info.lo] Error 1
make[3]: Leaving directory '/var/tmp/pamac-build-tio/fityk/src/fityk-1.3.1/fityk'
make[2]: *** [Makefile:546: all] Error 2
make[2]: Leaving directory '/var/tmp/pamac-build-tio/fityk/src/fityk-1.3.1/fityk'
make[1]: *** [Makefile:1327: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/pamac-build-tio/fityk/src/fityk-1.3.1'
make: *** [Makefile:804: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

saxonbeta commented on 2020-09-04 03:46 (UTC) (edited on 2020-09-04 03:46 (UTC) by saxonbeta)

The package does not compile using the current version of lua (5.4). I managed to get it to compile using lua52 as dependency and changing the configure command to:

./configure LUA_INCLUDE=-I/usr/include/lua5.2 LUA=/usr/bin/lua5.2 --prefix=/usr

a.kudelin commented on 2020-04-02 14:52 (UTC)

Could you please remove python2-sphinx from dependencies? The reason is (1) it isn't needed for the package to build, (2) python2 is deprecated.

agusdallalba commented on 2017-03-14 02:15 (UTC)

This package is out of date and doesn't build. It works if I just change: pkgver=1.3.1 pkgrel=0 md5sums=('41c9a2589e2eac4317a480b364ff493a')

chron commented on 2017-01-24 10:47 (UTC)

fityk-frame.o: In function `FFrame::OnDataQLoad(wxCommandEvent&)': frame.cpp:(.text+0xe06a): undefined reference to `xylib::get_wildcards_string(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' frame.cpp:(.text+0xedbc): undefined reference to `xylib::Cache::load_file(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' frame.cpp:(.text+0xee6b): undefined reference to `xylib::Block::get_name[abi:cxx11]() const' fityk-xybrowser.o: In function `PreviewPlot::load_dataset(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)': xybrowser.cpp:(.text+0xee5): undefined reference to `xylib::Cache::load_file(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' fityk-xybrowser.o: In function `XyFileBrowser::update_block_list()': xybrowser.cpp:(.text+0x1414): undefined reference to `xylib::Block::get_name[abi:cxx11]() const' fityk-xybrowser.o: In function `XyFileBrowser::XyFileBrowser(wxWindow*)': xybrowser.cpp:(.text+0x3bf3): undefined reference to `xylib::get_wildcards_string(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' collect2: error: ld returned 1 exit status make[2]: *** [Makefile:623: fityk] Error 1 make[2]: Leaving directory '/tmp/yaourt-tmp-chron/aur-fityk/src/fityk-1.3.0/wxgui' make[1]: *** [Makefile:1313: all-recursive] Error 1 make[1]: Leaving directory '/tmp/yaourt-tmp-chron/aur-fityk/src/fityk-1.3.0' make: *** [Makefile:789: all] Error 2 I had to recompile xylib before I could build fityk! PS: You don't need the install file, pacman hooks allready take care of 'update-desktop-database -q' and 'update-mime-database usr/share/mime'. https://wiki.archlinux.org/index.php/Pacman#Hooks https://wiki.archlinux.org/index.php/DeveloperWiki:Pacman_Hooks

cluminescence commented on 2016-02-18 14:12 (UTC)

had an error during building today: "Source should be an array" Needed to add brackets around the source(!) url in pckgbuild, worked fine afterwards. (on 4.2.8.1-1-MANJARO)

masutu commented on 2015-05-29 01:16 (UTC)

@saxonbeta: thanks again!

saxonbeta commented on 2015-05-28 16:19 (UTC)

Version 1.3 has been released and it solves the problem with lua version!

saxonbeta commented on 2015-05-21 02:45 (UTC)

I am getting the next error: checking lua.h version is in range 501 <= v < 503... (found Lua 5.3, 503)... no configure: error: in `/tmp/yaourt-tmp-xxx/aur-fityk/src/fityk-1.2.9': configure: error: lua.h version not in desired range Maybe this package can be used [url]https://aur.archlinux.org/packages/lua51-static/[/url] instead the newer version in repos

masutu commented on 2014-04-15 20:55 (UTC)

@saxonbeta: done, thx

saxonbeta commented on 2014-04-13 15:14 (UTC)

Version 1.2.9 has been released, please update the package :) https://github.com/wojdyr/fityk/releases/tag/v1.2.9

masutu commented on 2014-03-11 00:32 (UTC)

@olli: yep, thanks, updated

olli commented on 2014-02-25 16:20 (UTC)

The github link does not work anymore, change to https://github.com/wojdyr/fityk/releases/download/v1.2.1/fityk-1.2.1.tar.bz2

masutu commented on 2014-02-13 15:24 (UTC)

@sirocco: that's right, didn't realize that is was removed, updated PKGBUILD (now depends on wxgtk, which is at v3.0.0), thanks

sirocco commented on 2014-02-07 09:46 (UTC)

wxgtk2.9 does not exist in community or AUR currently.

masutu commented on 2013-05-02 19:25 (UTC)

Switched from pulling source via git to downloading the tarball to make this package different from fityk-git (https://aur.archlinux.org/packages/fityk-git).

masutu commented on 2012-06-22 23:58 (UTC)

@henkm: thanks for testing, added x86_64. i was using wxgtk-2.9 from the aur, didn't realize that wxgtk2.9 is in community @all: new pkgrel, because depends changed from wxgtk-2.9 to wxgtk2.9, no need to update

commented on 2012-06-18 14:48 (UTC)

thanks for updating. As is, I need to add x86_64 arch and change the dependency from wxgtk-2.9 to wxgtk2.9 (no dash), then it works fine.