Package Details: flameshot 0.5.0-3

Git Clone URL: https://aur.archlinux.org/flameshot.git (read-only)
Package Base: flameshot
Description: Powerful yet simple to use screenshot software
Upstream URL: https://github.com/lupoDharkael/flameshot
Licenses: GPL
Provides: flameshot
Submitter: xyzzy
Maintainer: dharkael
Last Packager: xyzzy
Votes: 20
Popularity: 6.854530
First Submitted: 2017-07-02 12:28
Last Updated: 2017-12-20 20:00

Latest Comments

dharkael commented on 2017-12-20 21:16

I see you add the files with the 'install' command. I told you to use 'make install' but there is an alternative way you could use to add the translations: They are generated after the execution of qmake in a folder called "translation". In order to add the translations to the package you could iterate over those files and install them in "${pkgdir}/usr/share/flameshot/translations/".

Sorry to bother and thanks for packaging!

xyzzy commented on 2017-12-20 20:06

@glowingsword: That's weird. I did actually update the checksum before and it built just fine. I checked it again just now and got the same checksum as you. Anyway, I changed it again, so it should work now.

glowingsword commented on 2017-12-20 19:19

Please check the sha256sum, the new sum for v0.5.0.tar.gz is 32d593c14c37286d9f64873c4ef9a07eb084723c92b2280d5c22152547c1e3f0

xyzzy commented on 2017-12-20 16:48

@dharkael: Thanks for the hint! I added qt5-tools to the make dependencies.

dharkael commented on 2017-12-20 15:48

I'm the developer of Flameshot. Just letting you know I've implemented automatic translation generation in builds so the build needs a new dependency (qt5-tools).

It's interesting to point that multiple .qm files will be generated after the qmake execution. "make install" should install everything properly but you have to pass the "packaging" variable and set the BASEDIR if you need to install in a custom directory.

Check it here for more info: https://github.com/lupoDharkael/flameshot#packaging

xyzzy commented on 2017-07-05 11:18

@j1simon: Thanks for pointing that out. I just added the files.

j1simon commented on 2017-07-05 09:46

I have seen the problem. It's in the installation script of the source package. I've opened a issue in github page: https://github.com/lupoDharkael/flameshot/issues/9

j1simon commented on 2017-07-05 09:04

This package is wrong: only it installs the executable. Where is the .desktop file? The icons? The DBUS services?