Package Details: flashpoint-launcher-git 10.0.0.e1b46166-2

Git Clone URL: https://aur.archlinux.org/flashpoint-launcher-git.git (read-only, click to copy)
Package Base: flashpoint-launcher-git
Description: Launcher for BlueMaxima's Flashpoint - Does not include data files! - Launcher software only.
Upstream URL: https://github.com/FlashpointProject/launcher
Keywords: BlueMaxima flash
Licenses: MIT
Conflicts: flashpoint-bin
Submitter: Colin969
Maintainer: LeSnake (Colin969)
Last Packager: LeSnake
Votes: 1
Popularity: 0.002543
First Submitted: 2019-11-09 17:02 (UTC)
Last Updated: 2021-07-24 20:45 (UTC)

Latest Comments

Colin969 commented on 2021-09-26 12:21 (UTC)

@jaap I updated the dependencies with the 10.1 release https://github.com/FlashpointProject/launcher/commit/f878ab84c7afdc781764c254fe5d2d5b5bd0e65f

jaap commented on 2021-09-26 10:14 (UTC)

@LeSnake

For me this is fixed now. This came at the same time FF also started to work propperly again. I made a post in the newbie corner asking if anyone knows what happened, but this seems super weird to me.

https://bbs.archlinux.org/viewtopic.php?pid=1994807#p1994807

Do you happen to also use f2fs?

Colin969 commented on 2021-08-29 13:06 (UTC)

Typeorm updated to cover a vunerability (https://github.com/advisories/GHSA-pf2j-9qmp-jqr2) but introduced breaking changes, you need to rollback to 0.2.22 (npm audit fix will update the package)

LeSnake commented on 2021-08-28 10:33 (UTC)

@jaap getting the same thing on my laptop, but not on my pc (both runnning artix)

I am trying to find a fix (maybe a dependency is missing ?)

Until then use flashpoint-bin, its a bit dated, but works far more reliable

jaap commented on 2021-08-27 21:02 (UTC)

I am getting typeorm sqlite errors, also on the bin version. Do you also get this? Maybe I have some weird system config or smth, but I dont know what it would be.

LeSnake commented on 2021-07-24 17:32 (UTC)

Aplied suggestions from @C0rn3j

C0rn3j commented on 2020-12-28 02:38 (UTC)

The linked .desktop file no longer exists.

release:static does not exist, I believe release:linux is the correct replacement.

/var/opt/flashpoint seems useless, should be /opt/flashpoint, can remove the /opt mkdir then as it is redundant.

This should probably not be installable together with flashpoint-bin.

the .7z archive should not be copied over I guess.

To test:

cd /opt/flashpoint && ./linux-unpacked/flashpoint-launcher

Here's the PKGBUILD I ended up with when testing - https://haste.rys.pw/fezejogowe.bash

flacs commented on 2020-06-14 04:41 (UTC)

Multiple things seem to have changed and this no longer builds.