Package Details: flexget-git 3.1.111-1

Git Clone URL: https://aur.archlinux.org/flexget-git.git (read-only, click to copy)
Package Base: flexget-git
Description: Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
Upstream URL: http://flexget.com/
Licenses: MIT
Conflicts: flexget
Provides: flexget
Submitter: cgirard
Maintainer: redfish
Last Packager: redfish
Votes: 4
Popularity: 0.000000
First Submitted: 2015-08-10 10:05 (UTC)
Last Updated: 2021-04-22 19:50 (UTC)

Pinned Comments

redfish commented on 2021-04-22 19:58 (UTC) (edited on 2021-04-22 20:00 (UTC) by redfish)

MANUAL ACTION REQUIRED to install (due to a bug in another package). Before installing this package, patch and install python-feedparser-dev:

pacaur -S pbget
pbget --aur python-feedparser-dev
cd python-feedparser-dev
curl -LRO https://gist.githubusercontent.com/radfish/8e8844eff7b631ef1f592bd432ae4d5e/raw/fb74e305e25384d8dae2d405377a2252dda74ed3/0001-install-sgmllib3k-via-setuptools.patch
patch -p1 < 0001-install-sgmllib3k-via-setuptools.patch
makepkg -Cfsi

Then, proceed to install this flexget-git package.

The above patch fixes this error:

pkg_resources.DistributionNotFound: The 'sgmllib3k' distribution was not
found and is required by FeedParser

This workaround will remain necessary until the other package is fixed: https://aur.archlinux.org/packages/python-feedparser-dev/#comment-802450

Latest Comments

redfish commented on 2021-04-22 19:58 (UTC) (edited on 2021-04-22 20:00 (UTC) by redfish)

MANUAL ACTION REQUIRED to install (due to a bug in another package). Before installing this package, patch and install python-feedparser-dev:

pacaur -S pbget
pbget --aur python-feedparser-dev
cd python-feedparser-dev
curl -LRO https://gist.githubusercontent.com/radfish/8e8844eff7b631ef1f592bd432ae4d5e/raw/fb74e305e25384d8dae2d405377a2252dda74ed3/0001-install-sgmllib3k-via-setuptools.patch
patch -p1 < 0001-install-sgmllib3k-via-setuptools.patch
makepkg -Cfsi

Then, proceed to install this flexget-git package.

The above patch fixes this error:

pkg_resources.DistributionNotFound: The 'sgmllib3k' distribution was not
found and is required by FeedParser

This workaround will remain necessary until the other package is fixed: https://aur.archlinux.org/packages/python-feedparser-dev/#comment-802450

redfish commented on 2021-04-18 01:38 (UTC)

@daneel: thank you, applied both changes in my working copy. Update is blocked by issue in python-feedparser-dev: https://aur.archlinux.org/packages/python-sgmllib3k/#comment-802450

daneel commented on 2020-06-28 09:12 (UTC)

You can remove python-flask-restplus dependency and replace it by python-flask-restx (https://github.com/Flexget/Flexget/pull/2689).

Also, you can re-enable build function with the command python dev_tools.py bundle-webui.

redfish commented on 2019-02-03 18:46 (UTC)

Patch for 2.18: https://paste.fedoraproject.org/paste/eOTya8V01ru3al9J-fyqbA I already co-maintain flexget pkg, so you could add me here as well and I'll push directly.

chestm007 commented on 2018-12-07 23:31 (UTC)

Adopted :)

cgirard commented on 2018-11-19 10:06 (UTC)

Sorry I just gave up on packaging flexget. They do not make any effort to update the dependency and this is getting more and more complicated to follow as the gap increases. I just switched to running it into a container. Orphaning this.

redfish commented on 2018-11-18 18:35 (UTC)

From comment on flexget package: remove python-pathlib and replace python-path with python-path.py. I also had to manually do this change in requirements.txt. Also, PR 2193 has been merged, so removed that. Also fixed a chmod cmd to wildcard the versions. Also, had to build with --nocheck because test fail.

diff --git a/PKGBUILD b/PKGBUILD
index b631390..de2183c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,9 +29,8 @@ depends=('python'
          'python-requests>=2.16.3'
          'python-dateutil>=2.5.3'
          'python-jsonschema>=2.0'
-         'python-path>=8.1.1'
-         'python-pathlib>=1.0'
-         'python-guessit<=2.1.4'
+         'python-path.py'
+         'python-guessit'
          'python-rebulk=0.9.0'
          'python-apscheduler>=3.2.0'
          'python-terminaltables>=3.1.0'
@@ -39,7 +38,7 @@ depends=('python'
          'python-cherrypy>=3.7.0'
          'python-flask>=0.7'
          'python-flask-restful>=0.3.3'
-         'python-flask-restplus=0.10.1'
+         'python-flask-restplus'
          'python-flask-compress>=1.2.1'
          'python-flask-login>=0.4.0'
          'python-flask-cors>=2.1.2'
@@ -86,7 +85,6 @@ prepare() {
   cd "${_pkgname}"

   patch -p1 < ../2162.diff
-  patch -p1 < ../2193.diff
   #pip-compile --output-file requirements.txt requirements.in
   #pip-compile give too stricts requirements...
   cp requirements.in requirements.txt
@@ -120,7 +118,7 @@ package() {
   install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE

   # Make sure the perms allow reading by all
-  chmod ugo+r ${pkgdir}/usr/lib/python3.7/site-packages/FlexGet-2.14.*.dev0-py3.7.egg-info/*
+  chmod ugo+r ${pkgdir}/usr/lib/python3.*/site-packages/FlexGet-*.*.*.dev0-py3.*.egg-info/*

   # install systemd user unit
   install -Dm644 ../flexget.service "${pkgdir}"/usr/lib/systemd/user/flexget.service

vaski commented on 2018-08-30 17:49 (UTC) (edited on 2018-08-30 17:49 (UTC) by vaski)

Hi, when I try to install flexget-git I get this error; ==> Error: Could not find all required packages: python-guessit<=2.1.4 (Wanted by: flexget-git) python-flask-restplus=0.10.1 (Wanted by: flexget-git) Is this something you can fix? Or should I just edit the PKGBUILD and change <= into >= or will that brake flexget?

cgirard commented on 2018-08-29 13:03 (UTC)

It should work with Python 3.7 now with the added patches. Do not forget to rebuild all your dependencies to make them available to Python 3.7.

Booloki commented on 2018-08-16 16:40 (UTC)

Waiting for an upstream fix: https://github.com/Flexget/Flexget/issues/2189

brando56894 commented on 2018-05-19 15:25 (UTC)

Please update this and remove the explicit version requirements, there is no reason for it. Instead, please use the respective python2 packages if you need it, I had to remove them all from mine to get it to build correctly.

cgirard commented on 2017-12-22 16:01 (UTC)

@zevdg they all are available on the AUR or the Arch Linux Archive.

zevdg commented on 2017-12-20 23:33 (UTC) (edited on 2017-12-20 23:38 (UTC) by zevdg)

Install fails with:

error: target not found: python-cherrypy<12
error: target not found: python-rebulk=0.8.2
error: target not found: python-rpyc=3.3.0
error: target not found: python-guessit<=2.0.4

cgirard commented on 2017-12-11 16:45 (UTC)

I have switched the package to Python3. You may get some errors at first restart with restoring some jobs by apscheduler but it seems to works fine afterward.

If you prefer using python2 version, use previous PKGBUILD from git history, I am not interested in maintaining both.

IamCarbonMan commented on 2017-03-29 15:21 (UTC)

Install fails with: error: target not found: python2-flask-restplus=0.8.6 error: target not found: python2-guessit<=2.0.4

cgirard commented on 2017-03-21 20:24 (UTC)

Sorry forgot to commit. Fixed.

ooxxcc commented on 2017-03-21 02:33 (UTC)

flexget updated to 2.10.* in PKGBUILD ``` # Make sure the perms allow reading by all chmod ugo+r ${pkgdir}/usr/lib/python2.7/site-packages/FlexGet-2.9.*.dev0-py2.7.egg-info/* ``` will fail

cgirard commented on 2016-10-14 13:52 (UTC) (edited on 2016-10-14 13:53 (UTC) by cgirard)

Switched from npm to yarn. It is way faster to build!

cgirard commented on 2016-09-06 11:05 (UTC)

If the npm command hangs, downgrade nodejs to 6.4.0. (see https://github.com/npm/npm/issues/13782 )

cgirard commented on 2015-11-16 09:12 (UTC)

No this are missing deps from python2-pyscss. I have already asked the maintainer to update its PKGBUILD. For python2-beautifulsoup4, as far as I can tell 4.4.1 is not inferior to 4.4. So this is expected.

shelbydz commented on 2015-11-14 23:08 (UTC)

Just installed this package. It seems the latest version from git also needs python2-enum34 python2-pathlib also, i couldn't get it to run with latest python2-beautifulsoup4 from the repo (4.4.1 i think). I had to downgrade that package.

kazuo commented on 2015-09-11 18:06 (UTC)

beautifulsoup 4.4 support: http://flexget.com/ticket/3059 flexget-git works for me (TM) with beautifulsoup 4.4.0 (you need to remove the check for <4.4).

cgirard commented on 2015-09-11 16:11 (UTC)

Yes, I know. And?

ccoffey commented on 2015-09-11 15:14 (UTC)

https://www.archlinux.org/packages/?q=python2-beautifulsoup4 is now at 4.4.0-1.

awh commented on 2015-08-20 14:43 (UTC)

Seems I had previously installed flexget with pip. Removing all pip packages and reinstalling the python2-* packages seems to have fixed up the deps.

cgirard commented on 2015-08-20 08:50 (UTC)

You have outdated packages installed or have managed to broke package dependencies: - python2-apscheduler is a dependency of flexget-git - python2-six is a dependency of python2-apscheduler - python2-six is currently at version 1.9.0 in [community]

awh commented on 2015-08-19 18:02 (UTC)

getting the following upon service start: pkg_resources.DistributionNotFound: The 'six>=1.4.0' distribution was not found and is required by apscheduler

cgirard commented on 2015-08-12 14:19 (UTC)

I switched to python2-dateutil as 2.4 is not blacklisted by flexget and seems to work.

kevku commented on 2015-08-12 14:02 (UTC)

python2-dateutil1 is missing from AUR