Package Details: flexget-git 3.1.31-1

Git Clone URL: (read-only, click to copy)
Package Base: flexget-git
Description: Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
Upstream URL:
Licenses: MIT
Conflicts: flexget
Provides: flexget
Submitter: cgirard
Maintainer: redfish
Last Packager: redfish
Votes: 4
Popularity: 0.000000
First Submitted: 2015-08-10 10:05
Last Updated: 2020-03-01 06:10

Latest Comments

1 2 3 Next › Last »

daneel commented on 2020-06-28 09:12

You can remove python-flask-restplus dependency and replace it by python-flask-restx (

Also, you can re-enable build function with the command python bundle-webui.

redfish commented on 2019-02-03 18:46

Patch for 2.18: I already co-maintain flexget pkg, so you could add me here as well and I'll push directly.

chestm007 commented on 2018-12-07 23:31

Adopted :)

cgirard commented on 2018-11-19 10:06

Sorry I just gave up on packaging flexget. They do not make any effort to update the dependency and this is getting more and more complicated to follow as the gap increases. I just switched to running it into a container. Orphaning this.

redfish commented on 2018-11-18 18:35

From comment on flexget package: remove python-pathlib and replace python-path with I also had to manually do this change in requirements.txt. Also, PR 2193 has been merged, so removed that. Also fixed a chmod cmd to wildcard the versions. Also, had to build with --nocheck because test fail.

diff --git a/PKGBUILD b/PKGBUILD
index b631390..de2183c 100644
@@ -29,9 +29,8 @@ depends=('python'
-         'python-path>=8.1.1'
-         'python-pathlib>=1.0'
-         'python-guessit<=2.1.4'
+         ''
+         'python-guessit'
@@ -39,7 +38,7 @@ depends=('python'
-         'python-flask-restplus=0.10.1'
+         'python-flask-restplus'
@@ -86,7 +85,6 @@ prepare() {
   cd "${_pkgname}"

   patch -p1 < ../2162.diff
-  patch -p1 < ../2193.diff
   #pip-compile --output-file requirements.txt
   #pip-compile give too stricts requirements...
   cp requirements.txt
@@ -120,7 +118,7 @@ package() {
   install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE

   # Make sure the perms allow reading by all
-  chmod ugo+r ${pkgdir}/usr/lib/python3.7/site-packages/FlexGet-2.14.*.dev0-py3.7.egg-info/*
+  chmod ugo+r ${pkgdir}/usr/lib/python3.*/site-packages/FlexGet-*.*.*.dev0-py3.*.egg-info/*

   # install systemd user unit
   install -Dm644 ../flexget.service "${pkgdir}"/usr/lib/systemd/user/flexget.service

vaski commented on 2018-08-30 17:49

Hi, when I try to install flexget-git I get this error; ==> Error: Could not find all required packages: python-guessit<=2.1.4 (Wanted by: flexget-git) python-flask-restplus=0.10.1 (Wanted by: flexget-git) Is this something you can fix? Or should I just edit the PKGBUILD and change <= into >= or will that brake flexget?

cgirard commented on 2018-08-29 13:03

It should work with Python 3.7 now with the added patches. Do not forget to rebuild all your dependencies to make them available to Python 3.7.

Booloki commented on 2018-08-16 16:40

Waiting for an upstream fix:

brando56894 commented on 2018-05-19 15:25

Please update this and remove the explicit version requirements, there is no reason for it. Instead, please use the respective python2 packages if you need it, I had to remove them all from mine to get it to build correctly.

cgirard commented on 2017-12-22 16:01

@zevdg they all are available on the AUR or the Arch Linux Archive.