Package Details: flightgear-data 2020.3.19-1

Git Clone URL: https://aur.archlinux.org/flightgear-data.git (read-only, click to copy)
Package Base: flightgear-data
Description: Base-Data for the opensource flight-simulator.
Upstream URL: http://www.flightgear.org/
Licenses: GPL
Submitter: Barthalion
Maintainer: acxz
Last Packager: acxz
Votes: 22
Popularity: 0.082347
First Submitted: 2018-01-05 16:04 (UTC)
Last Updated: 2023-12-17 05:54 (UTC)

Pinned Comments

acxz commented on 2022-09-07 14:48 (UTC)

Development is on Github: https://github.com/acxz/flightgear-arch Please open issues and PRs there instead of commenting.

Latest Comments

1 2 Next › Last »

dreieck commented on 2024-02-09 13:06 (UTC)

Maybe add perl, python and bash as optional dependencies?
namcap tells me:

flightgear-data E: Dependency bash detected and not included (programs ['bash'] needed in scripts ['usr/share/flightgear/data/Phi/mkthemes.sh'])
flightgear-data E: Dependency python detected and not included (python modules ['sys'] needed in files ['usr/share/flightgear/data/Aircraft/c172p/Models/Interior/Panel/Instruments/asi/asi.py'], programs ['python'] needed in scripts ['usr/share/flightgear/data/Aircraft/c172p/Models/Interior/Panel/Instruments/asi/asi.py', 'usr/share/flightgear/data/Docs/compile_docs.py'])
flightgear-data E: Dependency perl detected and not included (programs ['perl'] needed in scripts ['usr/share/flightgear/data/Aircraft/Instruments-3d/FG1000/Nasal/MFDPages/createpgs.pl', 'usr/share/flightgear/data/Textures/Trees/convert.pl'])

Regards and thanks for maintaining!

acxz commented on 2022-09-07 14:48 (UTC)

Development is on Github: https://github.com/acxz/flightgear-arch Please open issues and PRs there instead of commenting.

<deleted-account> commented on 2021-04-24 21:39 (UTC)

@flatwhatson I found and deleted the corrupted download file, and now the build works. Thank you for your help.

flatwhatson commented on 2021-04-24 10:28 (UTC)

@Karlamon I've re-downloaded the data files and confirmed the checksum in the PKGBUILD is correct. My guess is that you've got a corrupted download, please delete the file and try again.

<deleted-account> commented on 2021-04-24 01:36 (UTC)

Unable to build package for 2020.3.8, as I'm getting a "One or more files did not pass the validity check" error.

Building flightgear-data... ==> Making package: flightgear-data 2020.3.8-1 (Sat 24 Apr 2021 13:33:30) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found FlightGear-2020.3.8-data.txz ==> Validating source files with sha256sums... FlightGear-2020.3.8-data.txz ... FAILED ==> ERROR: One or more files did not pass the validity check! Failed to build flightgear-data

GeBo commented on 2020-12-23 17:18 (UTC) (edited on 2020-12-23 17:19 (UTC) by GeBo)

zstd --test flightgear-data-2020.3.5-1-any.pkg.tar.zst

.5-1-any.pkg.tar.zst : 2427 MB... .5-1-any.pkg.tar.zst : Decoding error (36) : Restored data doesn't match checksum

vgc commented on 2020-10-07 16:22 (UTC)

You are right. Thank you for your time. Regards.

flatwhatson commented on 2020-10-06 23:38 (UTC)

The URL is correct and works for me. Perhaps it was some temporary SourceForge problem.

vgc commented on 2020-10-06 15:27 (UTC) (edited on 2020-10-06 15:28 (UTC) by vgc)

Please update the PKGBUILD, the URL return an http 404 error. Regards

<deleted-account> commented on 2020-09-13 07:33 (UTC)

Sorry I think I accidentally deleted my comment again. What is the best way to maintain user additions such as aircrafts with this package?