Package Details: flite-fpic 1.4-10

Git Clone URL: https://aur.archlinux.org/flite-fpic.git (read-only)
Package Base: flite-fpic
Description: A lighweight version of festival speech synthesis compiled with -fPIC
Upstream URL: http://www.speech.cs.cmu.edu/flite/
Licenses: custom
Provides: flite, flite-fpic
Replaces: flite
Submitter: aggraef
Maintainer: None
Last Packager: aggraef
Votes: 1
Popularity: 0.005176
First Submitted: 2015-09-15 16:16
Last Updated: 2016-05-01 17:28

Dependencies (2)

Required by (11)

Sources (2)

Latest Comments

aggraef commented on 2016-06-11 16:02

I've disowned the package, so that anyone who needs it (mnovick?) can take over. Do with it as you like.

A new package flite1 is now available at https://aur.archlinux.org/packages/flite1/. This is now being used by pd-l2ork.

aggraef commented on 2016-05-01 17:50

mnovick1988, the package refuses to install with yaourt, apparently due to parallel build issues. The flite package (2.0) seems to suffer from the same problem.

I'm not sure what exactly is going on there because the package builds fine with makepkg, and the upstream source also compiles fine even with 'make -j4'. I tried every trick I know to forcibly disable parallel builds in the PKGBUILD, all to no avail.

As a workaround you can download the package with yaourt -G, run makepkg and install the resulting package manually. This works fine for me at least.

mnovick1988 commented on 2016-05-01 16:10

I cant build for some reason. - will attempt a logged build soon, and post results.

aggraef commented on 2016-02-15 11:38

Applied, thanks!

g2oo7fy commented on 2016-02-10 23:26

Removing the u from ar option list makes this build again. Add the following line to the PKGBUILD:

sed -i 's/$(AR) cruv/$(AR) crv/' config/common_make_rules

Best, Bjoern

aggraef commented on 2016-01-17 11:10

mnovick1988, this is a rather old package I took over from someone else, which is mainly provided as a dependency for pd-l2ork. Note that the 2.0 version is already available in the flite package. I'll have to check whether pd-l2ork still requires the older version.

mnovick1988 commented on 2016-01-12 22:45

out-of-date, flite(stable) is at 2.x., this wont build as changes in ar.

also, -fpic is enabled by default with -O3. its not necessary to replace enviorment flags, just add -03 onto the existing env. flags.

CFLAGS="$CFLAGS -O3"