Package Details: fluent-gtk-theme 2022.06.15-1

Git Clone URL: https://aur.archlinux.org/fluent-gtk-theme.git (read-only, click to copy)
Package Base: fluent-gtk-theme
Description: Fluent design GTK theme
Upstream URL: https://github.com/vinceliuice/Fluent-gtk-theme
Licenses: GPL3
Submitter: aperez
Maintainer: aperez
Last Packager: aperez
Votes: 1
Popularity: 0.003816
First Submitted: 2021-12-08 15:47 (UTC)
Last Updated: 2022-06-15 22:00 (UTC)

Latest Comments

yochananmarqos commented on 2022-03-31 14:03 (UTC)

@Roo79x: Actually gnome-shell is no longer needed, Vince changed the install script awhile back. It will still install the newer version of the shell theme if gnome-shell is not found. I've dropped it from my fluent-gtk-theme-git package.

Roo79x commented on 2022-03-31 10:06 (UTC)

is there a way to prevent this from installing alsa-plugins geoclue geocode-glib gjs gnome-autoar gnome-bluetooth gnome-desktop gnome-session gnome-settings-daemon gnome-shell gst-plugin-pipewire gtk4 libgdm libgweather libnma libnma-common mutter nm-connection-editor pulseaudio-alsa pulseaudio-bluetooth startup-notification. At all please? I did read here that it is needed to do the install. But for KDE users it would be a good thing to not have to have to remove these packages after install or every update. Thank you For you time and work

Corax commented on 2022-01-24 20:23 (UTC)

Right, I did notice that, but it's still very inconvenient to have to install all those packages only to remove them. I guess there's no optimal solution with PKGBUILDs, it would have to be a different package :(

aperez commented on 2022-01-24 14:25 (UTC)

@Corax: Note thet gnome-shell is only needed to build the packages. Once built, it can be removed just fine. I cannot remove the build-time dependency because the installation script used to prepare the package contents checks the gnome-shell version to decide what to install.

Corax commented on 2022-01-23 18:07 (UTC)

Requiring gnome-shell is extremely heavy-handed as this package can really be used with any WM (I'm using it with Enlightenment). I suggest having only a makedepend on sassc, and maybe an optdepend on gnome-shell.

yochananmarqos commented on 2021-12-09 02:15 (UTC)

fluent-gtk-theme-git already provides and conflicts with fluent-gtk-theme, no need for a conflicts() array here. See Package relations.