Package Details: flutter-engine-common-google-bin 3.22.1-1

Git Clone URL: https://aur.archlinux.org/flutter-artifacts-google-bin.git (read-only, click to copy)
Package Base: flutter-artifacts-google-bin
Description: Flutter SDK artifacts (binary from Google) - common engine files
Upstream URL: https://flutter.dev
Keywords: engine flutter
Licenses: custom, BSD, CCPL
Groups: flutter
Conflicts: flutter-engine-common
Provides: flutter-engine-common
Submitter: WithTheBraid
Maintainer: WithTheBraid
Last Packager: WithTheBraid
Votes: 4
Popularity: 2.01
First Submitted: 2024-03-26 14:57 (UTC)
Last Updated: 2024-05-28 08:55 (UTC)

Required by (3)

Sources (35)

Latest Comments

WithTheBraid commented on 2024-05-10 19:53 (UTC)

To be clear, @markg85 : the aur/flutter-bin package is compltely unrelated to this package. It claims to provide dependencies required by this package but in fact does not. I reported this as behavior not allowed in the community but unless the report is accepted, I cannot change anything about this.

Consider checking what dependencies you are being dropped in by your AUR helper before installing random packages please.

markg85 commented on 2024-04-28 01:01 (UTC) (edited on 2024-04-28 01:02 (UTC) by markg85)

This package gives:

looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: flutter-bin-3.19.6-5 and flutter-engine-android-google-bin-3.19.6-1 are in conflict
 -> Failed to install layer, rolling up to next layer.error:error installing: [/home/mark/.cache/yay/flutter/flutter-gradle-3.19.6-1-x86_64.pkg.tar.zst /home/mark/.cache/yay/flutter-bin/flutter-bin-3.19.6-5-x86_64.pkg.tar.zst /home/mark/.cache/yay/flutter-artifacts-google-bin/flutter-engine-linux-google-bin-3.19.6-1-x86_64.pkg.tar.zst /home/mark/.cache/yay/flutter-artifacts-google-bin/flutter-engine-android-google-bin-3.19.6-1-x86_64.pkg.tar.zst] - exit status 1

Which then tries to some magic (never seen the rolling up to next layer, no clue what that is about) just to fail again with:

loading packages...
resolving dependencies...
warning: cannot resolve "flutter-tool=3.19.6", a dependency of "flutter-target-linux"
warning: cannot resolve "flutter-tool=3.19.6", a dependency of "flutter-target-android"
warning: cannot resolve "flutter-tool=3.19.6", a dependency of "flutter-devel"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      flutter-target-linux  flutter-target-android  flutter-devel

:: Do you want to skip the above packages for this upgrade? [y/N] 

Trying to continue will make it fail at a later point.