Package Details: fofix-git 1:v4.0.0alpha2.r324.g0f69173-2

Git Clone URL: https://aur.archlinux.org/fofix-git.git (read-only)
Package Base: fofix-git
Description: Frets on Fire X (FoFiX). Highly improved version of Frets on Fire (Git Version)
Upstream URL: https://github.com/fofix/fofix
Keywords: fofix fretsonfire game
Licenses: GPL
Groups: games
Submitter: doorknob60
Maintainer: Linkid
Last Packager: Linkid
Votes: 19
Popularity: 0.137533
First Submitted: 2010-07-11 08:37
Last Updated: 2016-09-01 20:38

Latest Comments

Linkid commented on 2016-09-01 20:41

The dependency 'python2-fretwork-git' was added and some dependencies updated:
- use Pillow instead of PIL
- remove pyogg and pyvorbis
- rename pyaudio to python2-pyaudio
- add python2-opengl and gettext (optional).
So, the package should build.

Salamandar commented on 2015-10-12 14:18

Please add
python2-fretwork-git
To the dependencies, as some shared code has been moved to this git repo :)

Linkid commented on 2015-08-28 08:10

Done

mixedCase commented on 2015-08-27 13:10

This depends on python2-cerealizer. Could you add it to the dependencies?

Linkid commented on 2015-07-12 15:28

Looks good to me.

Linkid commented on 2015-07-11 19:12

Looks good to me.

Serra commented on 2014-12-29 14:38

The package does not build anymore. The directory src does not exists in the git repo anymore

mid-kid commented on 2014-01-11 13:02

This package also needs extra/glu to be able to build.

doorknob60 commented on 2013-11-17 22:26

I think I fixed it :D Pyxml apparently isn't required anymore, and it seems to work without it. I was able to build and run it.

doorknob60 commented on 2013-11-17 21:39

I might have a fix, but I need to test it and the git server is downloading very slow. I'll get back as soon as I can.

doorknob60 commented on 2013-11-17 21:15

I'm not sure if the pyxml package exists anymore. Apperantly, it was old, unmaintained code, and I didn't find any articles about Arch, but I think Fedora dropped it: https://fedoraproject.org/wiki/Features/RemovePyXML . I assume Arch must have done the same. You can try building it without the package, but that will probably fail. Unless they updated the Fofix code to run with a different library, it probably won't build unless someone makes a pyxml package (which I don't have time to mess with).

olejorgenb commented on 2013-11-17 21:01

pyxml package doesn't exist :(

Anonymous comment on 2013-07-11 21:47

You should add 'ffmpeg' to depends. Build fails without it

McDoenerKing commented on 2013-05-14 08:16

missing dependency: soundtouch

It doesn't compile for me without it. Starting it gives me just a black background.

doorknob60 commented on 2012-10-20 21:37

Fixed. Also fixed non -git fofix package.

nickl commented on 2012-10-19 08:47

A number of changes should be made to the PKGBUILD.

Most important, the _gitroot should be:
_gitroot="http://github.com/fofix/fofix.git"

as they've moved the main git url.

also, should depend on:
- python2-opengl
- python2-pysqlite
- python2-pygame
- python2-imaging

doorknob60 commented on 2011-12-21 19:17

Yep, fixed.

rndstr commented on 2011-12-21 09:47

Shouldn't this depend on cython2 instead of cython? At least it no longer complained about missing Cython.Distutils as soon as I installed cython2.

Anonymous comment on 2011-01-02 14:41

And pil is now python-imaging

Anonymous comment on 2011-01-02 14:36

Since the switch to python3: python-numpy is now python2-numpy

doorknob60 commented on 2010-09-13 02:11

This package is now not architecture independent, as they added a couple C/C++ modules to improve performance (hence the requirement of cython). Just letting you guys know why it changed.

doorknob60 commented on 2010-07-11 08:41

This should be able to peacefully coexist with the fretsonfire-alarian-mod package, though your fofix.ini file in your home folder is used by both, so your settings might get messed up. This is a replacement of the out of date fofix-svn package (they switched to git a while back).