Package Details: folly-git 0.57.0.r288.gc79d034-1

Git Clone URL: (read-only)
Package Base: folly-git
Description: Folly is an open-source C++ library developed and used at Facebook
Upstream URL:
Licenses: Apache
Conflicts: folly
Provides: folly
Replaces: folly
Submitter: onny
Maintainer: anatolik
Last Packager: anatolik
Votes: 4
Popularity: 0.035645
First Submitted: 2013-05-01 19:43
Last Updated: 2016-01-13 22:31

Latest Comments

renanbs commented on 2015-11-24 01:18

Please add
conflicts=('folly') and


anatolik commented on 2014-05-29 21:33

It is upstream bug. I filed it here

allie_o commented on 2014-05-29 21:17

fails to build for me:
/usr/bin/install -c -m 644 ApplyTuple.h Arena.h Arena-inl.h AtomicBitSet.h AtomicHashArray.h AtomicHashArray-inl.h AtomicHashMap.h AtomicHashMap-inl.h AtomicStruct.h Baton.h Benchmark.h Bits.h Checksum.h Chrono.h ConcurrentSkipList.h ConcurrentSkipList-inl.h Conv.h CpuId.h CPortability.h Demangle.h DiscriminatedPtr.h DynamicConverter.h dynamic.h dynamic-inl.h Exception.h FBString.h FBVector.h File.h FileUtil.h Fingerprint.h folly-config.h Exception.h ExceptionWrapper.h Foreach.h FormatArg.h Format.h Format-inl.h GroupVarint.h Hash.h IPAddress.h '/home/allie/aur/folly-git/pkg/folly-git/usr/include/folly/.'
/usr/bin/install: will not overwrite just-created ‘/home/allie/aur/folly-git/pkg/folly-git/usr/include/folly/./Exception.h’ with ‘Exception.h’
Makefile:922: recipe for target 'install-nobase_follyincludeHEADERS' failed

anatolik commented on 2014-03-25 13:20

Thanks for the report. FIxed.

mtorromeo commented on 2014-03-25 10:02

Please add python2 to makedepends and this prepare function to fix python3 > python2, otherwise the build/generate_*.py scripts will fail.

prepare() {
cd folly
find -name '*.py' -exec sed -i 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' {} \;