Package Details: forklift-git r36.da760ae-1

Git Clone URL: https://aur.archlinux.org/forklift-git.git (read-only, click to copy)
Package Base: forklift-git
Description: Simple GUI for youtube-dl using PyGObject
Upstream URL: https://github.com/Johnn3y/Forklift
Licenses: GPL3
Submitter: City-busz
Maintainer: None
Last Packager: City-busz
Votes: 0
Popularity: 0.000000
First Submitted: 2020-06-25 19:47
Last Updated: 2021-06-24 22:21

Latest Comments

City-busz commented on 2021-06-24 22:22

Now it's fixed.

langfingaz commented on 2021-06-24 14:55

Does not build for me:

==> Starting build()...
+ exec meson setup --prefix /usr --libexecdir lib --sbindir bin --buildtype plain --auto-features enabled --wrap-mode nodownload -D b_lto=true -D b_pie=true Forklift build
The Meson build system
Version: 0.58.1
Source dir: /tmp/pkg/src/Forklift
Build dir: /tmp/pkg/src/build
Build type: native build
Project name: Forklift
Project version: 1.0.0
Host machine cpu family: x86_64
Host machine cpu: x86_64
Program desktop-file-validate found: YES (/usr/sbin/desktop-file-validate)
Program appstream-util found: NO
Program glib-compile-schemas found: YES (/usr/sbin/glib-compile-schemas)
Found pkg-config: /usr/sbin/pkg-config (1.7.3)
Program glib-compile-resources found: YES (/usr/sbin/glib-compile-resources)
WARNING: Project targeting '>= 0.40.0' but tried to use feature introduced in '0.46.0': Python Module.
Program python3 found: YES (/usr/sbin/python3)
WARNING: Project targeting '>= 0.40.0' but tried to use feature introduced in '0.50.0': Python module path method.
Found pkg-config: /usr/sbin/pkg-config (1.7.3)
Run-time dependency gtk+-3.0 found: YES 3.24.29
Did not find CMake 'cmake'
Found CMake: NO
Run-time dependency libhandy-0.0 found: NO (tried pkgconfig)

Forklift/src/meson.build:21:0: ERROR: Dependency "libhandy-0.0" not found, tried pkgconfig

A full log can be found at /tmp/pkg/src/build/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...
Error during build of package /pkg/forklift-git!
ERROR: 4

It's a bit strange that libhandy-0.0 is not found even if libhandy is a dependency in the PKGBUILD.

It looks like cmake is now required as build dependency. But I'm unsure about the other errors.

Tio commented on 2020-07-20 01:08

Error:

The output from the failed tests:

2/3 Validate appstream file FAIL           2.33s (exit status 1)

--- command ---
01:08:01 /usr/bin/appstream-util validate data/com.github.Johnn3y.Forklift.appdata.xml
--- stdout ---
data/com.github.Johnn3y.Forklift.appdata.xml: FAILED:
• attribute-invalid     : <screenshot> width (540) too small [https://raw.githubusercontent.com/Johnn3y/Forklift/master/data/screenshots/4.png] minimum is 624px
• attribute-invalid     : <screenshot> height too large [https://raw.githubusercontent.com/Johnn3y/Forklift/master/data/screenshots/4.png] maximum is 900px
• duplicate-data        : <screenshot> has duplicated data
--- stderr ---
Validation of files failed
-------

Full log written to /var/tmp/pamac-build-tio/forklift-git/src/build/meson-logs/testlog.txt
==> ERROR: A failure occurred in check().
    Aborting...