Package Details: foxitreader 2.4.1.0609-10

Git Clone URL: https://aur.archlinux.org/foxitreader.git (read-only)
Package Base: foxitreader
Description: A fast, secure and complete PDF viewer
Upstream URL: https://www.foxitsoftware.com/products/pdf-reader/
Licenses: custom:eula
Submitter: tdy
Maintainer: Muflone
Last Packager: Muflone
Votes: 432
Popularity: 0.940883
First Submitted: 2009-01-21 18:59
Last Updated: 2018-02-04 17:57

Latest Comments

1 2 3 4 5 6 ... Next › Last »

jsamr commented on 2018-06-23 14:54

Thanks for your work! As previously asked, please remove application/octet-stream mime type, which is irrelevant.

nerrons commented on 2018-04-24 10:23

Experiencing the same problem mentioned by @birthstalker : UI fonts is monospaced.

birthstalker commented on 2018-03-20 12:43

The foxit reader UI font is somehow falling back to monospace font. How can I fix this issue? Screenshot: https://imgur.com/a/cf8id

Skycoder42 commented on 2018-02-14 12:59

After the update using the packaged Qt again, opening URLs embedded in the PDF is broken.

Here a shortened log from the open operation:

CReader_AppEx::OpenURL---url: "http://de.slideshare.net/aweyenberg/realistic-user-interface-design/9"
CReader_AppEx::CheckTrustySites--m_nSiteAccessRight: 3
CReader_AppEx::CheckTrustySites--m_csSitesDataManage: ""
kde-open5: /usr/lib/foxitreader/lib/libQt5Widgets.so.5: no version information available (required by kde-open5)
...
 >>> is repeated very often for many different combinations of libraries
...
kde-open5: /usr/lib/foxitreader/lib/libQt5Core.so.5: no version information available (required by /usr/lib/libKF5GuiAddons.so.5)
kde-open5: relocation error: /usr/lib/libQt5X11Extras.so.5: symbol _ZN15QGuiApplication16platformFunctionERK10QByteArray, version Qt_5 not defined in file libQt5Gui.so.5 with link time reference

EDIT: Apparently, this is because libQt5X11Extras.so.5 is not packaged so it will load the one provided by arch - which crashes because of the internal private APIs

Odusseus3215 commented on 2018-02-04 21:07

Printing now works with the latest build. Thanks

Muflone commented on 2018-02-04 17:05

@RemoteAdmin the libqgtk2.so plugin is not required to run foxitreader. It's only used to apply GTK+ appearance if gtk2 is available. If you lack the gtk2 package then you'll get the QT file chooser even if you use a GTK+ base desktop environment. If you have gtk2 installed then you'll have the GTK+ file chooser.

By the way I've found more missing dependencies, I'll add gtk2 to optdepends

RemoteAdmin commented on 2018-02-04 16:08

@Muflone Sorry for bothering again but is there a reason for not including gtk2? It is required by libqgtk2.so or am I missing something?

/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libgtk-x11-2.0.so.0
/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libgdk-x11-2.0.so.0

Muflone commented on 2018-02-04 13:34

fixed, thank you

RemoteAdmin commented on 2018-02-04 05:11

@gourdcaptain is right. There are a few dependencies missing.

I have run readelf -d against the elf files in this package and it turns out that the following dependencies are missing:

'qt5-xmlpatterns' 'libxslt' 'gstreamer0.10-base' 'fcitx-qt5' 'gtk2'

You can verify this list by using the following:

/usr/lib/foxitreader/FoxitReader needs libGL.so.1
/usr/lib/foxitreader/fxplugins/librms.so needs libQt5XmlPatterns.so.5
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libXrender.so.1
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libXcomposite.so.1
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libX11.so.6
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libxslt.so.1
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libxml2.so.2
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstreamer-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstapp-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstbase-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstinterfaces-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstpbutils-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstvideo-0.10.so.0
/usr/lib/foxitreader/platforminputcontexts/libcomposeplatforminputcontextplugin.so needs libxkbcommon.so.0
/usr/lib/foxitreader/platforminputcontexts/libfcitxplatforminputcontextplugin.so needs libFcitxQt5DBusAddons.so.1
/usr/lib/foxitreader/platforms/libqeglfs.so needs libfontconfig.so.1
/usr/lib/foxitreader/platforms/libqeglfs.so needs libfreetype.so.6
/usr/lib/foxitreader/platforms/libqeglfs.so needs libEGL.so.1
/usr/lib/foxitreader/platforms/libqxcb.so needs libX11-xcb.so.1
/usr/lib/foxitreader/platforms/libqxcb.so needs libXi.so.6
/usr/lib/foxitreader/platforms/libqxcb.so needs libSM.so.6
/usr/lib/foxitreader/platforms/libqxcb.so needs libICE.so.6
/usr/lib/foxitreader/platforms/libqxcb.so needs libxcb.so.1
/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libgtk-x11-2.0.so.0
/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libgdk-x11-2.0.so.0
/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libpango-1.0.so.0
/usr/lib/foxitreader/printsupport/libcupsprintersupport.so needs libcups.so.2

gourdcaptain commented on 2018-02-04 04:31

Running foxitreader with the 2.4.1.0609-8 package causes the error "/usr/lib/foxitreader/FoxitReader: error while loading shared libraries: libgstreamer-0.10.so.0: cannot open shared object file: No such file or directory", so it's missing a library dependency.