Package Details: foxitreader 2.4.4.0911-4

Git Clone URL: https://aur.archlinux.org/foxitreader.git (read-only)
Package Base: foxitreader
Description: A fast, secure and complete PDF viewer
Upstream URL: https://www.foxitsoftware.com/products/pdf-reader/
Licenses: custom:eula
Submitter: tdy
Maintainer: Muflone
Last Packager: Muflone
Votes: 442
Popularity: 1.71
First Submitted: 2009-01-21 18:59
Last Updated: 2019-12-03 01:20

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

vstuart commented on 2018-10-29 14:50

@DearVolt: I was getting the exact same issue (since yesterday or so), using my regular pacaur -Syu update command. Try running (once) yaourt -S foxitreader and accept defaults at prompts. This resolved the issue, for me.

DearVolt commented on 2018-10-25 08:49

Validation of the EULA is failing. Has it changed?

:: Parsing SRCINFO (1/1): foxitreader
==> Making package: foxitreader 2.4.1.0609-10 (Thu 25 Oct 2018 10:48:02 SAST)
==> Retrieving sources...
  -> Found FoxitReader2.4.1.0609_Server_x64_enu_Setup.run.tar.gz
  -> Found eula.html
  -> Found foxitreader.patch
  -> Found foxitreader-excluded_files
==> Validating source files with sha256sums...
    FoxitReader2.4.1.0609_Server_x64_enu_Setup.run.tar.gz ... Passed
    eula.html ... FAILED
    foxitreader.patch ... Passed
    foxitreader-excluded_files ... Passed
==> ERROR: One or more files did not pass the validity check!
Error downloading sources: foxitreader

Sheykhnur commented on 2018-09-30 17:20

I fixed the PKGBUILD for myself, maybe someone will be useful. https://pastebin.com/kjGhqpxu To update the .SRCINFO just run "makepkg --printsrcinfo > .SRCINFO"

UPD: I also changed the foxitreader.patch for consistency with the original https://pastebin.com/tZNaLSr4

dpell1991 commented on 2018-09-21 16:27

Package is out of date. also as it stands, this foxitreader 2.4.1.0609-10 package fails during checksum validation for the eula.html file.

jalencar commented on 2018-09-09 07:01

Replace the second sha256 checksum in the PKGBUILD with

7814e03ea944f5ee5ff791e97c13446a5274989a1679758a92af0405d0fc7dce

if your eula.html is failing during build process.

jsamr commented on 2018-06-23 14:54

Thanks for your work! As previously asked, please remove application/octet-stream mime type, which is irrelevant.

nerrons commented on 2018-04-24 10:23

Experiencing the same problem mentioned by @birthstalker : UI fonts is monospaced.

birthstalker commented on 2018-03-20 12:43

The foxit reader UI font is somehow falling back to monospace font. How can I fix this issue? Screenshot: https://imgur.com/a/cf8id

Skycoder42 commented on 2018-02-14 12:59

After the update using the packaged Qt again, opening URLs embedded in the PDF is broken.

Here a shortened log from the open operation:

CReader_AppEx::OpenURL---url: "http://de.slideshare.net/aweyenberg/realistic-user-interface-design/9"
CReader_AppEx::CheckTrustySites--m_nSiteAccessRight: 3
CReader_AppEx::CheckTrustySites--m_csSitesDataManage: ""
kde-open5: /usr/lib/foxitreader/lib/libQt5Widgets.so.5: no version information available (required by kde-open5)
...
 >>> is repeated very often for many different combinations of libraries
...
kde-open5: /usr/lib/foxitreader/lib/libQt5Core.so.5: no version information available (required by /usr/lib/libKF5GuiAddons.so.5)
kde-open5: relocation error: /usr/lib/libQt5X11Extras.so.5: symbol _ZN15QGuiApplication16platformFunctionERK10QByteArray, version Qt_5 not defined in file libQt5Gui.so.5 with link time reference

EDIT: Apparently, this is because libQt5X11Extras.so.5 is not packaged so it will load the one provided by arch - which crashes because of the internal private APIs

Odusseus3215 commented on 2018-02-04 21:07

Printing now works with the latest build. Thanks