Package Details: foxitreader 2.4.4.0911-4

Git Clone URL: https://aur.archlinux.org/foxitreader.git (read-only)
Package Base: foxitreader
Description: A fast, secure and complete PDF viewer
Upstream URL: https://www.foxitsoftware.com/products/pdf-reader/
Licenses: custom:eula
Submitter: tdy
Maintainer: Muflone
Last Packager: Muflone
Votes: 442
Popularity: 1.71
First Submitted: 2009-01-21 18:59
Last Updated: 2019-12-03 01:20

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

Muflone commented on 2018-02-04 17:05

@RemoteAdmin the libqgtk2.so plugin is not required to run foxitreader. It's only used to apply GTK+ appearance if gtk2 is available. If you lack the gtk2 package then you'll get the QT file chooser even if you use a GTK+ base desktop environment. If you have gtk2 installed then you'll have the GTK+ file chooser.

By the way I've found more missing dependencies, I'll add gtk2 to optdepends

RemoteAdmin commented on 2018-02-04 16:08

@Muflone Sorry for bothering again but is there a reason for not including gtk2? It is required by libqgtk2.so or am I missing something?

/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libgtk-x11-2.0.so.0
/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libgdk-x11-2.0.so.0

Muflone commented on 2018-02-04 13:34

fixed, thank you

RemoteAdmin commented on 2018-02-04 05:11

@gourdcaptain is right. There are a few dependencies missing.

I have run readelf -d against the elf files in this package and it turns out that the following dependencies are missing:

'qt5-xmlpatterns' 'libxslt' 'gstreamer0.10-base' 'fcitx-qt5' 'gtk2'

You can verify this list by using the following:

/usr/lib/foxitreader/FoxitReader needs libGL.so.1
/usr/lib/foxitreader/fxplugins/librms.so needs libQt5XmlPatterns.so.5
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libXrender.so.1
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libXcomposite.so.1
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libX11.so.6
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libxslt.so.1
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libxml2.so.2
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstreamer-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstapp-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstbase-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstinterfaces-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstpbutils-0.10.so.0
/usr/lib/foxitreader/lib/libQt5WebKit.so.5.3.2 needs libgstvideo-0.10.so.0
/usr/lib/foxitreader/platforminputcontexts/libcomposeplatforminputcontextplugin.so needs libxkbcommon.so.0
/usr/lib/foxitreader/platforminputcontexts/libfcitxplatforminputcontextplugin.so needs libFcitxQt5DBusAddons.so.1
/usr/lib/foxitreader/platforms/libqeglfs.so needs libfontconfig.so.1
/usr/lib/foxitreader/platforms/libqeglfs.so needs libfreetype.so.6
/usr/lib/foxitreader/platforms/libqeglfs.so needs libEGL.so.1
/usr/lib/foxitreader/platforms/libqxcb.so needs libX11-xcb.so.1
/usr/lib/foxitreader/platforms/libqxcb.so needs libXi.so.6
/usr/lib/foxitreader/platforms/libqxcb.so needs libSM.so.6
/usr/lib/foxitreader/platforms/libqxcb.so needs libICE.so.6
/usr/lib/foxitreader/platforms/libqxcb.so needs libxcb.so.1
/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libgtk-x11-2.0.so.0
/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libgdk-x11-2.0.so.0
/usr/lib/foxitreader/platformthemes/libqgtk2.so needs libpango-1.0.so.0
/usr/lib/foxitreader/printsupport/libcupsprintersupport.so needs libcups.so.2

gourdcaptain commented on 2018-02-04 04:31

Running foxitreader with the 2.4.1.0609-8 package causes the error "/usr/lib/foxitreader/FoxitReader: error while loading shared libraries: libgstreamer-0.10.so.0: cannot open shared object file: No such file or directory", so it's missing a library dependency.

Muflone commented on 2018-02-03 22:56

I've replaced the qt-installer script with a beautiful hack from @phiresky Removed the qt5 dependency as it uses the shipped version (again)

Muflone commented on 2018-01-14 19:37

@Skycoder42 fixed, thank you

t0m5k1 commented on 2018-01-14 17:53

@Skycoder42 Seeing as pacaur is now unmaintained I would suggest you choose a different method. To help the maintainer could you uninstall this package built with pacaur and construct it manually by downloading the pkgbuild into a folder on desktop or home folder and manually build it to see if you get the same error?

Skycoder42 commented on 2018-01-14 12:20

The current version (rev 5) has an invalid path in the system desktop file:

[Desktop Entry]
Name=Foxit Reader
...
Exec=foxitreader %F
Exec=/tmp/pkg-build/foxitreader/src/foxitreader-installer/FoxitReader.sh %F

The second Exec statement causes the problem. /tmp/pkg-build is the folder where the package was packaged by in my case pacaur. Please fix that part of the desktop file. For rev. 4, the second line was simply not there, I guess it's simply a missed leftover from the installer script.

Muflone commented on 2018-01-14 03:08

It took me a lot of time to fix this package.

Finally dropped the qt-installer-framework dependency (broken?) and replaced with a qt-installer custom script

There're actually two issues:

  1. if you build this package using your user (no chroot) then you'll have a duplicate desktop file in your ~/.local/share/applications folder
  2. print doesn't work for me, crashing application. This is somehow related to the QT version