Package Details: fpc-svn 3.1.1.r38855-1

Git Clone URL: https://aur.archlinux.org/fpc-svn.git (read-only, click to copy)
Package Base: fpc-svn
Description: The Free Pascal Compiler is a Turbo Pascal 7.0 and Delphi compatible Pascal Compiler. It comes with fully TP 7.0 compatible run-time library.
Upstream URL: http://www.freepascal.org/
Keywords: compiler pascal
Licenses: GPL, custom, LGPL
Conflicts: fpc
Provides: fpc
Submitter: None
Maintainer: None
Last Packager: alaviss
Votes: 4
Popularity: 0.000000
First Submitted: 2008-09-26 10:19 (UTC)
Last Updated: 2018-04-27 14:42 (UTC)

Required by (57)

Sources (1)

Latest Comments

norse commented on 2022-04-30 07:47 (UTC)

Has this package been abandoned, since there is no answer to the out of date flagging since December last year?

Anyway, the package cannot be built, as apparently, the address svn.freepascal.org is not reachable at all ... (while the host freepascal.org is reachable at 178.33.235.90). Can it be that the svn repository does not exist anymore?

$ ping svn.freepascal.org PING svn.freepascal.org (85.222.228.11) 56(84) bytes of data. From eth42.eq3-iec-rtr-002.cloudvps.nl (176.74.228.8) icmp_seq=1 Destination Host Unreachable From eth42.eq3-iec-rtr-002.cloudvps.nl (176.74.228.8) icmp_seq=2 Destination Host Unreachable From eth42.eq3-iec-rtr-002.cloudvps.nl (176.74.228.8) icmp_seq=3 Destination Host Unreachable

qlixes commented on 2018-04-28 12:06 (UTC)

Dear @alaviss I'm glad and thank you for quick help. If you don't mind, could you teach me how to build these PKGBUILD with give any comment on it. so I could learn and try to fix if found any bugs while build new fpc svn. Thanks a lot

alaviss commented on 2018-04-27 14:46 (UTC)

@qlixes

I've fixed the bug that causes build failures. Please try to build again.

note : while yaourt -S fpc-src-svn, it asking for installing fpc-3.0.4, did it okay ?

It's fine. The fpc compiler is written in Free Pascal, so you would still need fpc to build it first.

qlixes commented on 2018-04-27 12:11 (UTC)

Dear @alaviss today I was try installing fpc-src-svn using yaourt and manual download snapshot. All methods was failed without knowning what's cause. May I know how to install it ? note : while yaourt -S fpc-src-svn, it asking for installing fpc-3.0.4, did it okay ? thanks a lot

alaviss commented on 2018-01-13 06:17 (UTC) (edited on 2018-01-13 06:23 (UTC) by alaviss)

@ezacaria

I forgot to remove the quotes, that's why. But looks like make fetch the contents of $MAKEFLAGS automatically, so I could left it out.

Regarding stable fpc makedep, the devs enforced this for quite some time now. Of course you could override this check, but that has generated broken compiler for me, so I recommend against doing so.

I never have much success making docs, if you dig back the commit history, you would found some hacks I left. Guess it's time to turn them off again.

ezacaria commented on 2018-01-12 10:59 (UTC)

Thanks for this package.

I think that the "${MAKEFLAGS}" can be removed, since compilation will not work with an empty value. Regarding the stable fpc make requirement, it seems a bit odd that the newer version has to be partially built by the old one :P

The docs package does not seem to compile, I got an error "msg2inc.pp(835,1) Error: Error while linking". After leaving out the docs compilation, I was able to compile the package fpc-svn-3.1.1.r37946-1-x86_64.pkg.tar.xz

My main interest was to generate a .chm file from a doxygen html bundle via chmcmd. With this package I could finally do it (had to generate the files without subdirectories), whereas the current repo version (fpc 3.0.4-1) fails with a memory error.

juanfra commented on 2018-01-08 02:31 (UTC)

build() fails when you don't add something to MAKEFLAGS. The error is "make: empty string invalid as file name. Stop."

alaviss commented on 2017-01-06 12:07 (UTC)

It's works perfectly here. Maybe try to clone it and build it with makepkg? The provides and conflict was to make sure that you can't use fpc-svn to build fpc-svn. FPC Trunk only support being built by the latest stable compiler (It won't build with fpc-svn)

ProfessorKaos64 commented on 2017-01-03 03:17 (UTC)

What the heck is this? Provides: fpc=9999 My AUR upgrade notes: error: package 'fpc<9999' not found

ProfessorKaos64 commented on 2016-12-23 20:48 (UTC)

Will do Alavis, you can then delete my orphan request. I wasn't sure if you were still here. I don't mind co-maintaining if you want help.

alaviss commented on 2016-12-23 12:44 (UTC)

The symlinks were ugly hacks that was inserted when I'm half asleep. They should not be there in the first place. Please test if your modifications are still necessary

ProfessorKaos64 commented on 2016-12-21 00:43 (UTC)

Fixed package build: https://github.com/mdeguzis/arch-aur-packages/blob/master/fpc-svn/PKGBULID

ProfessorKaos64 commented on 2016-12-20 22:32 (UTC)

You also cannot compile fpc-src-svn... Writing Makefile ~/.cache/pacaur/fpc-svn/src/fpcbuild Makefile:2517: *** No libgdb.a found, supply NOGDB=1 to disable debugger support. Stop.

ProfessorKaos64 commented on 2016-12-18 03:43 (UTC) (edited on 2016-12-18 03:44 (UTC) by ProfessorKaos64)

find <DIR> -type l -exec rm -v '{}' \; should work in the prepare section before the symlinks are made. Did for me. I had to try installing this a few times to get the whole thing to install, but it did. If you add me as a co-maintainer, I can help. This hasn't been updated in a long time it seems.

ProfessorKaos64 commented on 2016-12-18 03:19 (UTC) (edited on 2016-12-18 03:30 (UTC) by ProfessorKaos64)

This won't build for me cp ref.kwd ref touch ref.chk ==> ERROR: A failure occurred in build(). Aborting... :: failed to build fpc-svn package(s) On retry things fail hard. Desperately needs a cleanup section. If you run again without clearing folders, it will complain symlink rtl already exists among any other errors if you make it further.

alaviss commented on 2015-04-20 16:24 (UTC)

Oops! It was a walkaround while testing and I forgot to remove it. I will fix it later (soon) when I got the time. For now, change the makedep to 'fpc'

the-k commented on 2015-04-20 16:14 (UTC)

Why is this package in its make dependencies ? It causes dependency hell.

foggybrain commented on 2011-03-17 20:45 (UTC)

This change is needed in your pkgbuild to stop it bombing out if the directory is not there. rm -r -f "$srcdir/$_svnmod-build"