Package Details: fpp-git 0.9.2.r130.ge0d5cfc-1

Git Clone URL: https://aur.archlinux.org/fpp-git.git (read-only, click to copy)
Package Base: fpp-git
Description: TUI that lets you pick paths out of its stdin and run arbitrary commands on them
Upstream URL: https://facebook.github.io/PathPicker
Keywords: menu shell TUI
Licenses: MIT
Conflicts: fpp
Provides: fpp
Submitter: guotsuan
Maintainer: thiagowfx
Last Packager: thiagowfx
Votes: 9
Popularity: 0.102831
First Submitted: 2015-10-05 16:31
Last Updated: 2021-05-30 21:07

Required by (0)

Sources (1)

Latest Comments

fczuardi commented on 2018-11-20 21:10

[Update 21/Nov/2018]: this got fixed on https://github.com/facebook/PathPicker/pull/293

the -c option wont work with Python3, it will fail with the following Traceback:

Traceback (most recent call last):
  File "/opt/PathPicker/src/choose.py", line 104, in <module>
    curses.wrapper(lambda x: doProgram(x, flags))
  File "/usr/lib/python3.7/curses/__init__.py", line 94, in wrapper
    return func(stdscr, *args, **kwds)
  File "/opt/PathPicker/src/choose.py", line 104, in <lambda>
    curses.wrapper(lambda x: doProgram(x, flags))
  File "/opt/PathPicker/src/choose.py", line 46, in doProgram
    screen.control()
  File "/opt/PathPicker/src/screenControl.py", line 366, in control
    self.processInput(inKey)
  File "/opt/PathPicker/src/screenControl.py", line 462, in processInput
    self.onEnter()
  File "/opt/PathPicker/src/screenControl.py", line 607, in onEnter
    output.execComposedCommand(presetCommand, lineObjs)
  File "/opt/PathPicker/src/output.py", line 42, in execComposedCommand
    command = composeCommand(command, lineObjs)
  File "/opt/PathPicker/src/output.py", line 145, in composeCommand
    return composeFileCommand(command, lineObjs)
  File "/opt/PathPicker/src/output.py", line 149, in composeFileCommand
    command = command.decode('utf-8')
AttributeError: 'str' object has no attribute 'decode'

haoliang commented on 2018-10-18 09:50

does fpp realy require ruby ?

according to readme of upstream repo, ruby is not required.

Chinggis6 commented on 2017-11-24 22:57

please add a postinstall script to:

ln -s /opt/PathPicker/debian/usr/share/man/man1/fpp.1 /usr/share/man/man1/

for manpage availability.