Package Details: fractalnow 0.8.1-2

Git Clone URL: https://aur.archlinux.org/fractalnow.git (read-only)
Package Base: fractalnow
Description: Provides users with tools to generate pictures of various types of fractals quickly and easily.
Upstream URL: http://sourceforge.net/projects/fractalnow
Licenses: LGPL3
Submitter: prurigro
Maintainer: prurigro
Last Packager: prurigro
Votes: 2
Popularity: 0.001041
First Submitted: 2013-03-27 00:08
Last Updated: 2015-06-10 04:39

Latest Comments

prurigro commented on 2013-09-28 05:36

Army: I was updating my older packages to the new PKGBUILD standards and noticed your message from way back had fallen through the cracks-- I'm not sure why my qmake had worked when yours didn't at the time, but it's the same as yours had been now, and I updated qmake to qmake-qt4 as well as fixing all the issues mentioned by namcap as you suggested. Sorry about the wait and thanks for the help!

Anonymous comment on 2013-03-27 09:13

Please add a sed line in the build function, that changes "qmake" to "qmake-qt4" in configure, otherwise the PKGBUILD won't work.

About your pushd and popd: It works, sure, but it would be better to use cd like in the packaging standards. It's also better, because not everybody is used to what pushd and popd actually do.

Another hint: Use namcap (is in the repos) to see if your PKGBUILD is ok. I ran it for you, here's the output.

$ namcap fractalnow-0.8.1-1-x86_64.pkg.tar.xz
fractalnow E: LGPLv3 is not a common license (it's not in /usr/share/licenses/common/)
fractalnow W: Description should not contain the package name.
fractalnow E: Files in /usr/share/icons/hicolor but no call to gtk-update-icon-cache or xdg-icon-resource to update the icon cache
fractalnow E: Dependency libmpc detected and not included (libraries ['usr/lib/libmpc.so.3'] needed in files ['usr/bin/fractalnow', 'usr/bin/qfractalnow'])