Package Details: franz 1:5.0.1-2

Git Clone URL: https://aur.archlinux.org/franz.git (read-only)
Package Base: franz
Description: Free messaging app for services like WhatsApp, Slack, Messenger and many more.
Upstream URL: https://meetfranz.com
Licenses: Apache
Submitter: 314eter
Maintainer: ItachiSan
Last Packager: ItachiSan
Votes: 134
Popularity: 0.374773
First Submitted: 2017-10-26 11:34
Last Updated: 2019-04-04 21:30

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

Kuchiriel commented on 2018-06-01 13:13

Please put a --prod flag in yarn install.

yarn install \ --silent \ --pure-lockfile \ --ignore-optional \ --link-duplicates \ --skip-integrity-check

Would be ideal.

venturieffect commented on 2018-05-12 23:21

I have the same error as Bab , using aurman but i'm on Italian layout with winkeys

RoDeLoPo commented on 2018-05-09 02:16

I have the same error as Bab below. Installing with aurman. Since the error mentions keyboard layout, if it helps, my layout is U.S. international with dead keys.

Bab commented on 2018-05-06 10:47

I'm trying to install this using trizen, but I'm getting the following:

error /tmp/trizen-bab/franz/src/franz-5.0.0-beta.17/node_modules/keyboard-layout: Command failed.
Exit code: 1
Command: node-gyp rebuild
Arguments: 
Directory: /tmp/trizen-bab/franz/src/franz-5.0.0-beta.17/node_modules/keyboard-layout
Output:
gyp info it worked if it ends with ok
gyp info using node-gyp@3.6.2
gyp info using node@10.0.0 | linux | x64
gyp info spawn /usr/bin/python2
gyp info spawn args [ '/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py',
gyp info spawn args   'binding.gyp',
gyp info spawn args   '-f',
gyp info spawn args   'make',
gyp info spawn args   '-I',
gyp info spawn args   '/tmp/trizen-bab/franz/src/franz-5.0.0-beta.17/node_modules/keyboard-layout/build/config.gypi',
gyp info spawn args   '-I',
gyp info spawn args   '/usr/local/lib/node_modules/npm/node_modules/node-gyp/addon.gypi',
gyp info spawn args   '-I',
gyp info spawn args   '/home/bab/.node-gyp/10.0.0/include/node/common.gypi',
gyp info spawn args   '-Dlibrary=shared_library',
gyp info spawn args   '-Dvisibility=default',
gyp info spawn args   '-Dnode_root_dir=/home/bab/.node-gyp/10.0.0',
gyp info spawn args   '-Dnode_gyp_dir=/usr/local/lib/node_modules/npm/node_modules/node-gyp',
gyp info spawn args   '-Dnode_lib_file=/home/bab/.node-gyp/10.0.0/<(target_arch)/node.lib',
gyp info spawn args   '-Dmodule_root_dir=/tmp/trizen-bab/franz/src/franz-5.0.0-beta.17/node_modules/keyboard-layout',
gyp info spawn args   '-Dnode_engine=v8',
gyp info spawn args   '--depth=.',
gyp info spawn args   '--no-parallel',
gyp info spawn args   '--generator-output',
gyp info spawn args   'build',
gyp info spawn args   '-Goutput_dir=.' ]
gyp info spawn make
gyp info spawn args [ 'BUILDTYPE=Release', '-C', 'build' ]
make: Entering directory '/tmp/trizen-bab/franz/src/franz-5.0.0-beta.17/node_modules/keyboard-layout/build'
  CXX(target) Release/obj.target/keyboard-layout-manager/src/keyboard-layout-manager-linux.o
In file included from ../../nan/nan.h:192:0,
                 from ../src/keyboard-layout-manager.h:4,
                 from ../src/keyboard-layout-manager-linux.cc:1:
../../nan/nan_maybe_43_inl.h: In function ‘Nan::Maybe<bool> Nan::ForceSet(v8::Local<v8::Object>, v8::Local<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute)’:
../../nan/nan_maybe_43_inl.h:112:15: error: ‘class v8::Object’ has no member named ‘ForceSet’
   return obj->ForceSet(isolate->GetCurrentContext(), key, value, attribs);
               ^~~~~~~~
In file included from ../src/keyboard-layout-manager.h:4:0,
                 from ../src/keyboard-layout-manager-linux.cc:1:
../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’:
../../nan/nan.h:835:60: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
         v8::Isolate::GetCurrent(), target, func, argc, argv);
                                                            ^
In file included from ../../nan/nan.h:49:0,
                 from ../src/keyboard-layout-manager.h:4,
                 from ../src/keyboard-layout-manager-linux.cc:1:
/home/bab/.node-gyp/10.0.0/include/node/node.h:172:50: note: declared here
                 NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                  ^
/home/bab/.node-gyp/10.0.0/include/node/node.h:88:42: note: in definition of macro ‘NODE_DEPRECATED’
     __attribute__((deprecated(message))) declarator
                                          ^~~~~~~~~~
In file included from ../src/keyboard-layout-manager.h:4:0,
                 from ../src/keyboard-layout-manager-linux.cc:1:
../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::String>, int, v8::Local<v8::Value>*)’:
../../nan/nan.h:850:62: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Object>, v8::Local<v8::String>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
         v8::Isolate::GetCurrent(), target, symbol, argc, argv);
                                                              ^
In file included from ../../nan/nan.h:49:0,
                 from ../src/keyboard-layout-manager.h:4,
                 from ../src/keyboard-layout-manager-linux.cc:1:
/home/bab/.node-gyp/10.0.0/include/node/node.h:165:50: note: declared here
                 NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                  ^
/home/bab/.node-gyp/10.0.0/include/node/node.h:88:42: note: in definition of macro ‘NODE_DEPRECATED’
     __attribute__((deprecated(message))) declarator
                                          ^~~~~~~~~~
In file included from ../src/keyboard-layout-manager.h:4:0,
                 from ../src/keyboard-layout-manager-linux.cc:1:
../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, const char*, int, v8::Local<v8::Value>*)’:
../../nan/nan.h:865:62: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Object>, const char*, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
         v8::Isolate::GetCurrent(), target, method, argc, argv);
                                                              ^
In file included from ../../nan/nan.h:49:0,
                 from ../src/keyboard-layout-manager.h:4,
                 from ../src/keyboard-layout-manager-linux.cc:1:
/home/bab/.node-gyp/10.0.0/include/node/node.h:158:50: note: declared here
                 NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                  ^
/home/bab/.node-gyp/10.0.0/include/node/node.h:88:42: note: in definition of macro ‘NODE_DEPRECATED’
     __attribute__((deprecated(message))) declarator
                                          ^~~~~~~~~~
In file included from ../src/keyboard-layout-manager.h:4:0,
                 from ../src/keyboard-layout-manager-linux.cc:1:
../../nan/nan.h: In member function ‘v8::Local<v8::Value> Nan::Callback::Call_(v8::Isolate*, v8::Local<v8::Object>, int, v8::Local<v8::Value>*) const’:
../../nan/nan.h:1479:5: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
     ));
     ^
In file included from ../../nan/nan.h:49:0,
                 from ../src/keyboard-layout-manager.h:4,
                 from ../src/keyboard-layout-manager-linux.cc:1:
/home/bab/.node-gyp/10.0.0/include/node/node.h:172:50: note: declared here
                 NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                  ^
/home/bab/.node-gyp/10.0.0/include/node/node.h:88:42: note: in definition of macro ‘NODE_DEPRECATED’
     __attribute__((deprecated(message))) declarator
                                          ^~~~~~~~~~
make: *** [keyboard-layout-manager.target.mk:97: Release/obj.target/keyboard-layout-manager/src/keyboard-layout-manager-linux.o] Error 1
make: Leaving directory '/tmp/trizen-bab/franz/src/franz-5.0.0-beta.17/node_modules/keyboard-layout/build'
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:258:23)
gyp ERR! stack     at ChildProcess.emit (events.js:182:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:225:12)
gyp ERR! System Linux 4.16.6-1-ARCH
gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /tmp/trizen-bab/franz/src/franz-5.0.0-beta.17/node_modules/keyboard-layout

j0nas commented on 2018-04-09 14:43

Just go to /usr/lib/node_modules/npm and run sudo npm install node-gyp. Now you should be able to install it again.

fgk commented on 2018-04-05 22:13

I am getting an error when trying to install with yaourt:

==> Starting build()...
yarn install v1.5.1
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@1.1.2: The platform "linux" is incompatible with this module.
info "fsevents@1.1.2" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning " > eslint-config-airbnb@14.1.0" has incorrect peer dependency "eslint@^3.15.0".
warning " > eslint-plugin-jsx-a11y@3.0.2" has incorrect peer dependency "eslint@^2.10.2 || 3.x".
warning " > eslint-plugin-react@6.10.3" has incorrect peer dependency "eslint@^2.0.0 || ^3.0.0".
[4/4] Building fresh packages...
[1/6] ⠂ macos-notification-state
[2/6] ⠂ windows-notification-state
[3/6] ⠂ windows-quiet-hours
[4/6] ⠂ @paulcbetts/cld
error An unexpected error occurred: "/tmp/yaourt-tmp-xxx/aur-franz/src/franz-5.0.0-beta.17/node_modules/@paulcbetts/cld: Command failed.
Exit code: 1
Command: sh
Arguments: -c node-gyp rebuild
Directory: /tmp/yaourt-tmp-xxx/aur-franz/src/franz-5.0.0-beta.17/node_modules/@paulcbetts/cld
Output:
internal/modules/cjs/loader.js:550
    throw err;
    ^

Error: Cannot find module '/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:548:15)
    at Function.Module._load (internal/modules/cjs/loader.js:475:25)
    at Function.Module.runMain (internal/modules/cjs/loader.js:695:10)




==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build franz.

Edit: Seems to be a problem with npm: https://github.com/npm/npm/issues/20163

snack commented on 2018-03-22 10:59

I just tried this package, I think it's a great idea but it doesn't work on my system. Specifically, I added 4 services (WhatsApp, Telegram, Slack, Skype), and after switching some times between them they begin to show nothing on screen. It seems like the rendering of the web page fails. If I close and reopen franz then they work again but again after some switching the problem reappears. I'm using franz 5.0.0_beta.16-1 on a Plasma session with mesa drivers.

Ataraxy commented on 2018-03-13 11:01

I'm getting the error:

Error: Unresolved node modules: fbjs, loose-envify, create-react-class, object-assign, history, hoist-non-react-statics, invariant, warning
    at /home/var/ravi/.cache/pacaur/franz/src/franz-5.0.0-beta.16/node_modules/electron-builder-lib/src/util/packageDependencies.ts:109:19

Full transcript: https://pastebin.com/T98ur6Wp

mrwbsn commented on 2018-03-08 09:45

@flocke umm.. maybe you could try what i've done to solve it.

set npm to use python2 $ npm config set python /usr/bin/python2

install node-gyp $ sudo npm -g install node-gyp

rerun your yaourt/packer to build franz. I hope it'll help.

abdulhakeem commented on 2018-03-02 15:35

Can you please fix the app icon? It's just the generic "no icon" gear instead of the proper Franz logo icon that it's supposed to be