Package Details: freecad-git 0.19.r582.g0cfea3fee3-1

Git Clone URL: https://aur.archlinux.org/freecad-git.git (read-only, click to copy)
Package Base: freecad-git
Description: A general purpose 3D CAD modeler - git checkout
Upstream URL: https://www.freecadweb.org/
Licenses: LGPL
Conflicts: freecad, freecad-appimage, freecad-appimage-git
Provides: freecad
Submitter: gborzi
Maintainer: greyltc
Last Packager: greyltc
Votes: 96
Popularity: 0.53
First Submitted: 2012-03-03 13:46
Last Updated: 2021-05-09 15:39

Required by (3)

Sources (1)

Latest Comments

« First ‹ Previous ... 31 32 33 34 35 36 37 38 39 40 41 ... Next › Last »

Anonymous comment on 2011-08-18 08:43

@gborzi
Just compiled 4768-1 with !makeflags [ Arch32bit Atom330 ] on one core.
After 3 hours compilation done sucessfull.[ FreeCAD svn only of course :) ]
Thanks for your help.

gborzi commented on 2011-08-17 20:48

@spookyln
I've just finished compiling rev. 4768 with makeflags (-j9). Which revision have you tried to compile?

gborzi commented on 2011-08-17 20:47

@spookyln
I've just finished compiling rev. 4768. Which revision have you tried to compile?

gborzi commented on 2011-08-17 20:23

@spookyln
That is an error that keeps reappearing from time to time. To avoid it use !makeflags. I haven't used this option in the PKGBUILD because most of the time it compiles just fine, and it's much faster on my quad core.

Anonymous comment on 2011-08-17 18:42

hi, i tried to compile freecad from this pkgbuild.
every deps compiled sucessfully without any prob [eigen 3.0.1 needs new md5sum only], but
freecad-svn i cant compile [no testing repo].

here is log with err.
http://www.tbs-software.com/spookyln/err/freecad-svn.txt

can send me anyone working compiled package pls?
thanks.
Eh i forgot. compiled on 32bit Arch. Atom330 with makepkg -j5

gborzi commented on 2011-07-30 23:33

Updated to rev 4707. Now it uses eigen3 instead of eigen2. The former is available from AUR.

Anonymous comment on 2011-07-17 15:11

Hi,
I've got the error:
/usr/lib/libGL.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status

I use Arch x64 with an Nividia Driver. I know there is a connection between the error and the Driver.

How can I fix this issue?

gatonero commented on 2011-05-26 19:52

@gborzi Thank you! This worked perfectly! :D

gborzi commented on 2011-05-26 18:19

@gatonero
it's a yaourt problem. Uninstall freecad-svn, then update, then rebuild freecad-svn.

gatonero commented on 2011-05-26 18:05

What's that? Can't update my system?

yaourt -Syuf
:: Synchronisiere Paketdatenbanken...
core ist aktuell
extra ist aktuell
community ist aktuell
archlinuxfr ist aktuell
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
:: freecad-svn: requires boost-libs=1.46.0