Package Details: freecad-netgen-git 0.17pre.r1769.g40c79f1-3

Git Clone URL: https://aur.archlinux.org/freecad-netgen-git.git (read-only)
Package Base: freecad-netgen-git
Description: A general purpose 3D CAD modeler
Upstream URL: http://www.freecadweb.org/
Licenses: LGPL
Conflicts: freecad
Provides: freecad
Submitter: drhooves
Maintainer: drhooves
Last Packager: drhooves
Votes: 0
Popularity: 0.000000
First Submitted: 2016-07-10 09:59
Last Updated: 2017-03-04 16:25

Latest Comments

drhooves commented on 2017-03-04 16:29

Thanks for the info. Should work now. Unfortunately it was a build time issues so you have to rebuild the package. The problem was that freecad linked against the python3 version of PySide/Shiboken instead of the python2 version. Very strange that the issue didn't appear sooner...

nokian commented on 2017-03-04 15:44

Something changed. Needed some additional python packages.
Running freecad fails
"Fatal Python error: [libshiboken] Failed to initialise Shiboken.BaseWrapper type"

http://forum.freecadweb.org/viewtopic.php?t=13710&start=20

drhooves commented on 2016-09-18 20:42

The LD_LIBRARY_PATH prefix is no longer needed.
/opt/vtk-qt4 is now resolved via RPATH.

Also I decided to move the installation
to /opt/freecad after reading:
http://forum.freecadweb.org/viewtopic.php?f=4&t=12890

drhooves commented on 2016-09-14 18:44

Please perpend the FreeCAD command with LD_LIBRARY_PATH=/opt/vtk-qt4/lib till I figure out how to fix the rpaths at compile time.
e.g. LD_LIBRARY_PATH=/opt/vtk-qt4/lib FreeCAD

Sent from my phone so be aware of typos :D

nokian commented on 2016-09-14 17:58

@drhooves: It would be nice if you could fix the freecad-git package as you probably know some details needed.

drhooves commented on 2016-09-10 11:23

Thats an issue with the PKGBUILD. It happends when a dependency of FreeCAD has been built against Qt5 because FreeCAD uses/assumes Qt4. However, on my installation I don't have any problems with the FEM workbench. Which Qt and VTK related packages are installed on your system?

cox commented on 2016-09-10 10:46

Thanks, drhooves
It compiles now:-).
When switching to FEM workbench directly after starting FreeCAD i get segmentation fault, referring to qt5:

[GDB output]
Program received signal SIGSEGV, Segmentation fault.
0x00007fffabf4fa57 in QMetaObject::className() const () from /usr/lib/libQt5Core.so.5

Could this be a PKGBUILD issue or should i take it up in the FreeCAD forum?

drhooves commented on 2016-09-09 05:56

Should work now. It builds against opencascade from [community] instead of oce now. Don't forget to rebuild netgen-nogui before installation of freecad-netgen-git because it also links opencadcade now. Any feedback is appreciated.

drhooves commented on 2016-09-07 08:47

Thanks for reporting, it seems the code that detects netgen has been updated. I don't have time to investigate today, but I'm gona try to fix it tomorrow.

cox commented on 2016-09-06 20:26

I had problem installing, here is error message:
==> Starting prepare()...
patching file cMake/FindNETGEN.cmake
Hunk #1 FAILED at 57.
1 out of 1 hunk FAILED -- saving rejects to file cMake/FindNETGEN.cmake.rej
==> ERROR: A failure occurred in prepare().
Aborting...