Package Details: freecad-qt5-git 1:0.17pre.r4610.gd28bae3f5-1

Git Clone URL: https://aur.archlinux.org/freecad-qt5-git.git (read-only)
Package Base: freecad-qt5-git
Description: A general purpose 3D CAD modeler - git checkout
Upstream URL: http://www.freecadweb.org/
Licenses: LGPL
Submitter: drhooves
Maintainer: drhooves
Last Packager: drhooves
Votes: 2
Popularity: 0.236796
First Submitted: 2017-03-03 08:28
Last Updated: 2017-06-17 10:28

Latest Comments

drhooves commented on 2017-06-28 18:51

Yes, this is because makepkg removes debug infos by default, see https://wiki.archlinux.org/index.php/Debug_-_Getting_Traces

mriyah commented on 2017-06-28 18:30

Sorry drhooves, if i change the pkgbuild it can be compiled with RelWithDebInfo.
I could launch it from /tmp with deb infos. However after installation has finished the deb infos were gone. Thx.

drhooves commented on 2017-06-28 16:38

Do you mean it doesn't work or ask if I could change the pkgbuild?

mriyah commented on 2017-06-28 15:00

Hi, cannot be compiled with RelWithDebInfo. Thanks.

drhooves commented on 2017-06-17 10:02

Should work now with the official qt5.9 package ;)

drhooves commented on 2017-06-16 10:58

Nice, I also had to wait for arch to ship qt5.9 but it seems they do since a few days now. I'm going to try to move to 5.9 right away.

buovjaga commented on 2017-06-16 10:41

Check it out: https://wiki.qt.io/PySide2_GettingStarted
"Currently, Qt 5.6 and Qt 5.9 onwards are supported."
They post updates here: https://wiki.qt.io/PySide2#Pyside_Development_Progress_Notes

greenmanalishi commented on 2017-05-15 12:06

thank you!

drhooves commented on 2017-05-15 10:47

Hi, yes. freecad relies on pyside for python qt bindings and it (atm) doesn't work with qt5.8. I think they target qt5.9, don't know if it's finished yet but doesn't matter right now because arch uses 5.8. As soon as 5.9 hits the repos I'm going to look into it ;)

greenmanalishi commented on 2017-05-15 10:29

Hello, thanks for the package. Does it build only with qt5.6? Because of the
qt5.6-webkit dependency.

All comments