Package Details: freecad 0.18.16117-1

Git Clone URL: https://aur.archlinux.org/freecad.git (read-only)
Package Base: freecad
Description: A general purpose 3D CAD modeler
Upstream URL: https://www.freecadweb.org/
Licenses: LGPL
Submitter: bluewind
Maintainer: gbs
Last Packager: gbs
Votes: 162
Popularity: 14.080127
First Submitted: 2018-03-22 09:25
Last Updated: 2019-05-16 21:16

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

fujitsusiemens3 commented on 2019-02-09 09:33

I also have the same issue with compiling the source code.

I had an idea to force python3 in Shiboken2Config.cmake and PySide2Config.cmake.

It compiles until another issue occours. This time linker have problem with references:

[ 28%] Linking CXX executable ../../bin/FreeCAD
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_FromString`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyBytes_FromString`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyMemoryView_FromMemory`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_CompareWithASCIIString`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_AsUTF8`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libpyside2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyBytes_FromStringAndSize`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_FromFormat`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyType_GetSlot`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_FromFormatV`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyBytes_Concat`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyType_FromSpec`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_Concat`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyModule_Create2`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyMethodDescr_Type`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyType_FromSpecWithBases`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_AsUnicode`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_AsUTF8String`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_FindChar`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `_Py_FalseStruct`
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so: undefined reference to `PyUnicode_FromStringAndSize`

metcalfe commented on 2019-02-07 02:19

@hybrid: I am seeing the same build failure.

I also don't have a Shiboken2Config-python2.7.cmake file in /usr/lib/cmake/Shiboken2-5-12.1

I notice that there is no python2.7 cmake file in the 5-12.1 file list https://www.archlinux.org/packages/extra/x86_64/shiboken2/

I don't really understand cmake, but out of a desire to experiment I symlinked Shiboken2Config-python2.7.cmake to the Shiboken2Config.cpython-37m-x86_64-linux-gnu.cmake file that does come with 5-12.1

This got me past the Shiboken error, but I found more or less the same thing with PySide2

[..] CMake Error at /usr/lib64/cmake/PySide2-5.12.1/PySide2Config.cmake:5 (include): include could not find load file:

/usr/lib/cmake/PySide2-5.12.1/PySide2Config-python2.7.cmake

Call Stack (most recent call first): CMakeLists.txt:946 (find_package)

CMake Error at CMakeLists.txt:948 (MESSAGE): ==================

PySide2 not found.

================== [..]

hybrid commented on 2019-02-05 21:40

shiboken2 5.12.1-1 seems to have broken something here. Ever since I upgraded shiboken2 5.12.0-1 to 5.12.1-1 compilation of freecad aborts:

[..] CMake Error at /usr/lib64/cmake/Shiboken2-5.12.1/Shiboken2Config.cmake:5 (include): include could not find load file:

/usr/lib/cmake/Shiboken2-5.12.1/Shiboken2Config-python2.7.cmake

[...]

There is a /usr/lib/cmake/Shiboken2-5.12.0/Shiboken2Config-python2.7.cmake but not one in /usr/lib/cmake/Shiboken2-5.12.1/.

Can somebody verify that (just pacman -Syu to upgrade to Shiboken2-5.12.1-1 and then try to build freecad)?

razer commented on 2019-02-03 06:32

Please add FCStd files icon by adding : <icon name="freecad"/>

in freecad.xml mime file

jedeiht commented on 2019-01-31 16:17

@giostark : Check space available in your /tmp directory. Default tmp/ size could not be enough to compile free cad.

Ludde commented on 2019-01-30 20:32

gbs: It turned out I had forgot to update 'med', now it is working properly.

I suspect that bebR is having the same issue, since that is connected to meshing and have the openmpi dependency.

bebR commented on 2019-01-29 20:48

The mesh workbench needs openmpi to be able to create a mesh from a shape. Otherwise, the FreeCAD console will show: "libmpi.so.40 cannot open shared library". This lib should be added to the dependencies.

giostark commented on 2019-01-29 13:36

I dont know if is related at cmake but it want compile: It stop a 77% , then restarting it stop at 80% , then at 81% and didnt go further. [ 81%] Built target PartGui make: *** [Makefile:130: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build freecad.

Maverick commented on 2019-01-27 14:35

@heros21 You have probably updated via pacman in the meantime, so you have to recompile freecad to make it compatible against current libboost.

heros21 commented on 2019-01-26 12:53

Hello, when I open freecad I have the following error: error while loading shared libraries: libboost_filesystem.so.1.68.0: can not open shared object file: No such file or directory. Thank you for helping me.