Package Details: freediameter-hg 1288.389c26b904d7-1

Git Clone URL: https://aur.archlinux.org/freediameter-hg.git (read-only)
Package Base: freediameter-hg
Description: An open source implementation of the diameter protocol
Upstream URL: http://www.freediameter.net/
Licenses: BSD
Conflicts: freediameter
Provides: freediameter
Submitter: cookies
Maintainer: bidulock
Last Packager: bidulock
Votes: 1
Popularity: 0.000054
First Submitted: 2011-06-11 18:11
Last Updated: 2015-06-11 06:25

Dependencies (6)

Required by (0)

Sources (2)

Latest Comments

cookies commented on 2013-04-06 18:10

Update to v1008.d3d2a32320c4, added functionality for Pacman 4.1.

cookies commented on 2012-11-05 19:39

Update to v883-1, dropped sysvinit support -> added systemd support

cookies commented on 2012-09-09 09:09

Update to v818-1

cookies commented on 2012-09-01 09:59

The package works now without a patch. (v817-1)

cookies commented on 2012-08-22 18:12

I wrote a quick&dirty patch. The package works now, but the checking of the own certificate is disabled, so you should be sure that it's valid or you will maybe get absurd errors.

cookies commented on 2012-08-20 12:30

The package doesn't work at the moment, because upstream uses the GnuTLS functions gnutls_certificate_get_x509_crls and gnutls_certificate_get_x509_cas, which are deprecated and removed since 5th February 2011 (see http://git.savannah.gnu.org/cgit/gnutls.git/commit/?id=7a95c1f3ee290b07c9dfadfd280e2ba6cbc85baf).
When you try to build a package, you will get this error:
../libfdcore/libfdcore.so.1.1.2: undefined reference to `gnutls_certificate_get_x509_crls'
../libfdcore/libfdcore.so.1.1.2: undefined reference to `gnutls_certificate_get_x509_cas'

Maybe I'll write a patch, but at the moment I have no time.

seblu commented on 2012-03-07 12:21

please forget, i will keep the same name, as project use lksctp-tools.

seblu commented on 2012-03-07 10:53

lksctp-tools will be moved to community, please udpate your dependency to lksctp.