Package Details: freedm-git 1:0.14.0.alpha.r45.g8c335ccd-1

Git Clone URL: https://aur.archlinux.org/freedoom-git.git (read-only, click to copy)
Package Base: freedoom-git
Description: Free game data files for Doom gaming engines
Upstream URL: http://freedoom.github.io/
Keywords: Doom freedoom games wads
Licenses: BSD
Provides: freedm, freedoom
Submitter: FredBezies
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 5
Popularity: 0.001516
First Submitted: 2015-06-08 17:51 (UTC)
Last Updated: 2024-04-20 15:53 (UTC)

Required by (25)

Sources (1)

Latest Comments

xiota commented on 2024-02-07 04:13 (UTC) (edited on 2024-02-07 04:15 (UTC) by xiota)

Some changes would be nice:

  • Remove replaces directive. They don't work as expected on AUR.
  • Change url to https://github.com/freedoom/freedoom to make checking project status easier.
  • Update license string to BSD-3-Clause. (Arch is switching to SPDX identifiers.)
  • Guard path variables with quotes because they can contain spaces (eg, $srcdir, $pkgdir)
  • Avoid alpha/beta/etc tags for version string, and set hash length because some users have had problems with variable lengths in other packages.
git describe --long --tags --abbrev=8 --exclude='*[A-Za-z][A-Za-z]*' \
  | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'

FredBezies commented on 2023-07-11 05:58 (UTC) (edited on 2023-07-11 06:05 (UTC) by FredBezies)

@ElonSatoshi : issue reported -> https://github.com/freedoom/freedoom/issues/1015

ElonSatoshi commented on 2023-07-10 19:46 (UTC)

Anyone know how to fix this error?

Traceback (most recent call last):
  File "/home/user/.cache/paru/clone/freedoom-git/src/freedoom/graphics/text/./create_caption", line 21, in <module>
    txt1_size = draw.textsize(txt1, font=font)
                ^^^^^^^^^^^^^
AttributeError: 'ImageDraw' object has no attribute 'textsize'
make[1]: *** [Makefile:149: fd1title.png] Error 1
make[1]: Leaving directory '/home/user/.cache/paru/clone/freedoom-git/src/freedoom/graphics/text'
make: *** [Makefile:29: subdirs] Error 2

wertercatt commented on 2019-11-28 21:21 (UTC)

You need to add git as a makedep since this package uses a git source.

FredBezies commented on 2017-08-01 05:47 (UTC)

@chungy : fixed. Thanks for the info.

chungy commented on 2017-07-31 23:57 (UTC)

We've dropped ImageMagick as a dependency for building and replaced it with Pillow instead. Also, python2 isn't required, you can just use plain python.