Package Details: freefilesync-bin 11.10-1

Git Clone URL: https://aur.archlinux.org/freefilesync-bin.git (read-only, click to copy)
Package Base: freefilesync-bin
Description: Folder comparison and synchronization
Upstream URL: https://freefilesync.org
Keywords: backup mirroring synchronization
Licenses: GPL3
Conflicts: freefilesync
Provides: freefilesync
Submitter: archibald869
Maintainer: archibald869
Last Packager: archibald869
Votes: 25
Popularity: 1.01
First Submitted: 2018-11-14 22:04
Last Updated: 2021-05-11 20:43

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

archibald869 commented on 2021-03-24 20:34

Normally, if you have a 64-bit machine, the x86 dependencies should not be downloaded. Which tool do you use to install the package?

And what exactly does not work when using the unmodified dlagent?

rezad commented on 2021-03-24 20:11

when I use this aur package it tries to download lib32 packages even thought I am on x64 AND this program has x64 binary and does not need lib32 to work. I just downloaded the pkgbuild file and removed the

depends_i686=( lib32-atk lib32-fontconfig lib32-gdk-pixbuf2 lib32-libsm lib32-libx11 lib32-pango )

and also some parts for dlagent because that wouldnt work for makepkg command run. and it installed fine and it works (to the best of my knowledge)

maybe look into that.

cybertron commented on 2021-03-22 14:15

ah that's it, never needed before for freefilesync ;)

aminvakil commented on 2021-03-22 08:49

@cybertron Have you enabled multilib repository?

https://archlinux.org/packages/multilib/x86_64/lib32-json-c/

cybertron commented on 2021-03-21 20:35

@aminvakil no that's not the problem: Could not find all required packages:...

for example lib32-fontconfig-git needs lib32-json-c which is not available as package

aminvakil commented on 2021-03-21 18:02

@cybertron Yes, do sudo pacman -Syu and make sure base-devel has been installed as well.

cybertron commented on 2021-03-21 15:47

Hm I'm the only who gets the problem with deps? Something like that

lib32-expat (Wanted by: lib32-pango-minimal-git -> lib32-cairo-git -> lib32-fontconfig-git)
lib32-expat (Wanted by: lib32-pango-minimal-git -> lib32-cairo-git -> lib32-fontconfig-git -> lib32-freetype2-git -> lib32-harfbuzz-minimal-git -> lib32-glib2-git -> lib32- dbus-nosystemd-git)
lib32-e2fsprogs (Wanted by: lib32-pango-minimal-git -> lib32-cairo-git -> lib32-fontconfig-git -> lib32-freetype2-git -> lib32-harfbuzz-minimal-git -> lib32-glib2-git -> li b32-libelf-minimal-git -> lib32-curl-git -> lib32-krb5-minimal-git)
lib32-libpsl (Wanted by: lib32-pango-minimal-git -> lib32-cairo-git -> lib32-fontconfig-git -> lib32-freetype2-git -> lib32-harfbuzz-minimal-git -> lib32-glib2-git -> lib32 -dbus-nosystemd-git -> lib32-gcc-libs)

longstation commented on 2021-03-15 18:19

It works great now! Thank you!

archibald869 commented on 2021-03-15 17:59

As expected, the checksum changed once again. :)

kristianjgs commented on 2021-03-15 16:13

:: Downloaded PKGBUILD (1/1): freefilesync-bin :: (1/1) Parsing SRCINFO: freefilesync-bin ==> Making package: freefilesync-bin 11.8-2 (lun 15 mar 2021 11:10:44) ==> Retrieving sources... -> Found dlagent -> Downloading freefilesync-bin-11.8.tar.gz... Authenticating for download ... Downloading ... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 100 24.8M 100 24.8M 0 0 6115k 0 0:00:04 0:00:04 --:--:-- 7568k Checking ... -> Found FreeFileSync.desktop -> Found RealTimeSync.desktop -> Found freefilesync-mime.xml ==> Validating source files with sha256sums... dlagent ... Passed freefilesync-bin-11.8.tar.gz ... FAILED FreeFileSync.desktop ... Passed RealTimeSync.desktop ... Passed freefilesync-mime.xml ... Passed ==> ERROR: One or more files did not pass the validity check! error downloading sources: freefilesync-bin