Package Details: freerapid 0.9u4-1

Git Clone URL: https://aur.archlinux.org/freerapid.git (read-only)
Package Base: freerapid
Description: A Java-based download manager for Rapidshare and other file sharing archives
Upstream URL: http://wordrider.net/freerapid/
Licenses: GPL
Provides: frd
Submitter: None
Maintainer: kralyk
Last Packager: kralyk
Votes: 69
Popularity: 1.701861
First Submitted: 2008-10-23 12:00
Last Updated: 2015-06-23 13:46

Latest Comments

jose1711 commented on 2016-03-04 18:24

interesting. seems that upgrade to this package will never be detected by yaourt:

warning: downgrading package freerapid (0.86-1 => 0.9u4-1)

kralyk commented on 2014-05-19 10:43

Thanks, it's updated...

ignace72 commented on 2014-05-19 00:49

Hello,
FreeRapid Downloader 0.9u4 is out.

kralyk commented on 2013-09-17 00:38

Updated

adam777 commented on 2013-08-15 21:29

Perhaps gsettings-desktop-schemas should be added to dependencies?
On a clean installation, application fails to launch aside from the initial launch with the following error:

(process:1649): GLib-GIO-ERROR **: Settings schema 'org.gnome.system.proxy' is not installed

Trace/breakpoint trap (core dumped)

Installing gsettings-desktop-schemas solve the issue.

felixonmars commented on 2012-01-28 04:52

@kralyk oh sorry I did that by mistake...

kralyk commented on 2011-12-13 15:41

Why did someone (felixonmars) flag this? If there is some non-obvious reason, you gotta let me know in the comments.

kralyk commented on 2011-11-14 00:22

Updated.

Funkin-Stoopid commented on 2011-11-13 23:44

0.86u1 version is out. http://pastebin.com/pKdztTwx

Funkin-Stoopid commented on 2011-11-13 23:20

0.86u1 version is out.

kralyk commented on 2011-11-05 16:36

It's updated.

Funkin-Stoopid commented on 2011-11-05 15:21

Here is a PKGBUILD for 0.86 version. Please update it as soon as possible.
http://pastebin.com/yY0V6cb0

kralyk commented on 2011-03-14 12:03

@hsa2: ok, updated.

th0th commented on 2011-03-13 23:25

I think dependency should be java-runtime instead of jre, there other alternative packages providing java-runtime.

Anonymous comment on 2011-01-12 02:46

it works...thanks kralyk

kralyk commented on 2011-01-10 19:07

Ok, it's now fixed, dík...

stativ commented on 2011-01-10 17:41

You should use
mkdir -p "$fplugins"

otherwise you'll get "No such file or directory" error if ~/.FRD doesn't exist

kralyk commented on 2011-01-04 19:11

Good news ladies and gentlemen ;-)
Thanks to a mysterious command-line option I found in the source code, we can now set custom plugin dir path. It's done automatically by the launching sh.
So there should hopefully be no more problems with plugins updates.
Prior to update, pleaase remove old freerapid package from the systems,
whole ~/.FRD/app directory (not useful anymore) as well as any possible leftovers in /usr/share/freerapid/plugins

Enjoy or report any problems with the new pkg ;-)

kralyk commented on 2011-01-03 01:52

Oh. Well, thanks for noticing, I'll have to come up with some other solution, stay tuned...

Anonymous comment on 2011-01-01 19:21

still problems, I got a "invalid cross-device link" error when the script try to make the hardlink, i have a partition for / and another partition for /Home

kralyk commented on 2010-12-29 15:27

Ok, fixed, it's kind of ugly thoug. Theres a hardlink in ~/.FRD/app now. Symlink didnt do the trick.
Plugin updates finally work...
(I'll try talking to the authors...)

kralyk commented on 2010-12-29 12:58

Damnit, it still doesn't work. Working on it...

kralyk commented on 2010-12-28 01:49

Ok, took this and updated.
Plugins are now stored in ~/.FRD/app/plugins due to various problems caused by frd managing them on its own.
Hope everything works...

Anonymous comment on 2010-11-30 09:55

PKGBUILD for release 0.85 - it is needed to download FreeRapid-0.85-build555.zip manually. I didn't found direct link for it.

pkgname=freerapid
pkgver=0.85
pkgbld=build555
pkgrel=2
pkgdesc="A Java-based download manager for Rapidshare and other file sharing archives"
arch=('any')
url="http://wordrider.net/freerapid/"
license=('GPL')
depends=('jre')
provides=('frd')
source=(http://freerapid-downloader.sweb.cz/FreeRapid-${pkgver}-${pkgbld}.zip
$pkgname.sh
$pkgname.desktop)
md5sums=('f0976997bb76560f9f70abc1cae27999'
'f3af9e8ae81bf4c114b2475026fc0a0c'
'815a8b560580698d39361487d9710edb')

build() {
cd $srcdir/FreeRapid-$pkgver-$pkgbld

# Copy data and fix permissions
install -d $pkgdir/usr/share/$pkgname
cp -rf frd.jar lib/ lookandfeel/ plugins/ $pkgdir/usr/share/$pkgname/
find $pkgdir/usr/share/$pkgname -type f -exec chmod 644 {} +

# Install bin, icon and desktop file
install -Dm 755 $srcdir/$pkgname.sh $pkgdir/usr/bin/$pkgname
ln -sf $pkgname $pkgdir/usr/bin/frd
install -Dm 644 frd.png $pkgdir/usr/share/pixmaps/$pkgname.png
install -Dm 644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
}

Anonymous comment on 2010-11-19 07:07

0.85 released

Sadam commented on 2010-11-11 14:23

Plugin updates are broken cos user dont have premissions to write in /usr/share/freerapid/plugins/
(just set you account as owner of the folder to get plugin updates working under your account - Maintainer should find some better way how solve this problem)

stativ commented on 2010-10-12 06:48

Could you please use java-runtime instead of jre as a dependency? It seems to work fine except for the system tray icon.

Anyway, I think you could add a new group with write permissions to the plugins folder so the user can add himself into this group and have working plugin updates.

enedene commented on 2010-07-21 20:31

When using option help->check for new plugins, and opening details I get error: permission denied. When downloading from their site and running frd.sh I get no such problem.