Package Details: frequensea-git 3707384-1

Git Clone URL: https://aur.archlinux.org/frequensea-git.git (read-only)
Package Base: frequensea-git
Description: Visualizing the frequency spectrum
Upstream URL: https://github.com/fdb/frequensea/
Licenses: MIT
Provides: frequensea
Submitter: yuvadm
Maintainer: yuvadm
Last Packager: yuvadm
Votes: 0
Popularity: 0.000000
First Submitted: 2015-03-13 09:42
Last Updated: 2015-06-30 12:50

Latest Comments

drws commented on 2016-08-25 11:26

I have managed to build it by adding the export CFLAGS='-Wno-misleading-indentation' to the beginning of the build() function (line 22 in current PKGBUILD). However, there are still a few errors remaining:


1. This package installs only the frequensea binary, but not the other files required to run it (lua scripts and so on).

user@host: pacman -Qlq frequensea-git | grep -v '/$'
/usr/bin/frequensea


2. It segfaults upon running :(

user@host: frequensea
Usage: frequensea [--vr] FILE.lua
Options:
--vr Render to Oculus VR
user@host: frequensea ../lua/static.lua
OpenGL Renderer: Mesa DRI Intel(R) Ivybridge Mobile
OpenGL Version: 3.3 (Core Profile) Mesa 12.0.1
Segmentation fault (core dumped)

cokomoko commented on 2016-02-12 02:09

Compilation error

[100%] Linking CXX executable frequensea
externals/lua/liblua.a(loslib.c.o): In function `os_tmpname':
/tmp/yaourt-tmp-cokomoko/aur-frequensea-git/src/frequensea/externals/lua/src/loslib.c:140: warning: the use of `tmpnam' is dangerous, better use `mkstemp'
[100%] Built target frequensea
==> fakeroot ortamına giriliyor...
==> package() işlemine başlanıyor...
==> Kurulum düzenleniyor...
-> libtool dosyaları kaldırılıyor...
-> İstenmeyen dosyalar kaldırılıyor...
-> Statik kütüphane dosyaları kaldırılıyor...
-> İkilik dosyalardan ve kütüphanelerden gereksiz ayıklama sembolleri ayıklanıyor...
-> Kılavuz ve bilgi sayfaları sıkıştırılıyor...
==> Checking for packaging issue...
==> "frequensea-git" paketi oluşturuluyor...
-> .PKGINFO dosyası üretiliyor...
-> .BUILDINFO dosyası üretiliyor...
-> .MTREE dosyası oluşturuluyor...
-> Paket sıkıştırılıyor...
==> fakeroot ortamından çıkılıyor.
==> frequensea-git 7914862-1 (Cum Şub 12 03:45:32 UTC 2016) paketinin derlenmesi tamamlandı

==> frequensea-git yüklensin mi ? [E/h]


and run error?

frequensea static.lua
OpenGL Renderer: GeForce GT 230M/PCIe/SSE2
OpenGL Version: 3.2.0 NVIDIA 340.96
Parçalama arızası
┌─[cokomoko]──[cokomoko]:/media/sda13/de/aur-frequensea-git-copy2/src/frequensea/lua$
└──>>frequensea --vr static.lua
frequensea: /tmp/yaourt-tmp-cokomoko/aur-frequensea-git/src/frequensea/src/main.cpp:1265: int main(int, char**): Assertion `window' failed.
İptal edildi

yuvadm commented on 2015-04-04 09:40

Feel free to submit a PR, I manage all my packages on http://github.com/yuvadm/archlinux-packages

In any case, this project doesn't build properly on Linux just yet :/

altercation commented on 2015-04-04 07:04

I believe hackrf, from community, should be added to the dependencies.

However, in addition to this, I am not able to build this successfully on Arch. You?