Package Details: frogatto-git r1.8236da3-1

Git Clone URL: https://aur.archlinux.org/frogatto-git.git (read-only, click to copy)
Package Base: frogatto-git
Description: An action-adventure game, starring a certain quixotic frog.
Upstream URL: http://www.frogatto.com/
Licenses: custom
Submitter: hagabaka
Maintainer: Mr.Smith1974
Last Packager: Mr.Smith1974
Votes: 7
Popularity: 0.000464
First Submitted: 2011-06-29 22:45 (UTC)
Last Updated: 2023-10-20 10:12 (UTC)

Dependencies (2)

Required by (1)

Sources (3)

Latest Comments

1 2 Next › Last »

MarsSeed commented on 2023-06-19 17:20 (UTC)

Please make this depend on 'anura', not 'anura-git'.

Let the user choose which of the two anura packages they want to use.

Mojmir commented on 2022-09-17 20:10 (UTC)

today i thought 'i will fix frogatto', because i promised it to my kid. BUT it works already!

anura is working as of today, the only thing it needs to remove the branch specification (#branch=buildsystem-upgrade) from PKGBUILD, i.e. in diff form:


    @@ -10,7 +10,7 @@ depends=(libgl mesa glew cairo sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-
 optdepends=('frogatto-git: the default game module'
             'box2d: box2d physics')
 makedepends=(git boost)
-source=('git+https://github.com/anura-engine/anura.git#branch=buildsystem-upgrade'
+source=('git+https://github.com/anura-engine/anura.git'
         'git+https://github.com/sweetkristas/imgui.git'
         anura.sh)
 md5sums=('SKIP'

that way anura compiles, frogatto dtto and it does not crash anymore when leaving the house

Blazin commented on 2022-04-17 07:20 (UTC)

Assuming you can get anura-git and frogatto-git to compile, the game crashes. I am not sure, but it seems to be due to the game trying to assets from ~/.frogatto-git/data rather than /usr/share/anura-git/modules/frogatto/data. I've tried tweaking the AUR package files. Nothing seems to fix it.

Until this is fixed, anyone having this issue should just follow the Getting Frogatto guide. As long as you have installed the dependencies required for anura-git on the AUR, you should have everything required to manually compile it. (You don't actually need anura-git installed if you follow the guide, just the dependencies.)

The Anura git repository is currently broken, so you will need to manually checkout commit 627d08fb5254b5c66d315f1706089905c2704059 in the Anura repository after the cloning step in the guide I mentioned.

hvksmr1996 commented on 2017-07-24 07:19 (UTC)

Could you please set `Icon` of frogatto-git.desktop to just "frogatto"? (instead of full path to the icon)

hagabaka commented on 2013-05-27 20:24 (UTC)

The PKGBUILD has been updated to reflect the new structure of the repositories. This package now only contains the game data, and requires the anura-git package which contains the engine. The versioning scheme has been changed from date based to git-tag based, so epoch has been bumped. It now requires at least version 4.1 of pacman, which simplifies VCS PKGBUILDs.

Cravix commented on 2013-05-19 04:57 (UTC)

the git repo of frogatto has chaged a lot about 12 days ago: https://github.com/frogatto/frogatto/commit/8409b774c4c10b5386b133a80312cec33a1e33f6 now it only stores data files, and the engine part was moved to anura repo: https://github.com/anura-engine/anura maybe it's better to rewrite the PKGBUILD.

hagabaka commented on 2013-01-19 18:59 (UTC)

If you have used this package before 2013-01-19, please note that the user data directory has changed from ~/.frogatto to ~/.frogatto-git. Run "mv -T ~/.frogatto ~/.frogatto-git" to keep using your old saves and preferences. Also, the package now installs to /opt/frogatto-git, /usr/bin/frogatto-git, etc, so it can now coexist with the frogatto package in [community].

hagabaka commented on 2012-07-06 00:25 (UTC)

@Doc_Angelo: thanks for your report. It should be fixed now. Other changes: - disabled compiling of server because it fails for me: https://gist.github.com/3057200 However it might be a problem with my setup, someone else with similar versions of boost and gcc isn't having the problem - fixed license path to frogatto-git instead of -svn

<deleted-account> commented on 2012-07-05 22:26 (UTC)

Tried to build today, packaging stops because "music" and "sounds" was not found. These directories was moved to modules/frogatto.