Package Details: fs-uae-launcher-devel 2.9.7dev2-2

Git Clone URL: https://aur.archlinux.org/fs-uae-launcher-devel.git (read-only)
Package Base: fs-uae-launcher-devel
Description: Launcher and configuration program for FS-UAE (development version).
Upstream URL: http://fs-uae.net/download-devel
Keywords: amiga emulator uae
Licenses: GPL2
Conflicts: fs-uae-launcher
Provides: fs-uae-launcher
Submitter: grimi
Maintainer: grimi
Last Packager: grimi
Votes: 29
Popularity: 0.215974
First Submitted: 2012-07-02 14:07
Last Updated: 2018-08-19 20:20

Latest Comments

1 2 Next › Last »

fatmike commented on 2018-08-19 21:05

Thank you for the quick fix!

fatmike commented on 2018-08-19 18:33

On startup, i get the following error:

$ fs-uae-launcher 
Traceback (most recent call last):
  File "/usr/bin/fs-uae-launcher", line 84, in <module>
    main()
  File "/usr/bin/fs-uae-launcher", line 80, in main
    import launcher.apps
  File "/usr/share/fs-uae-launcher/launcher/apps/__init__.py", line 4, in <module>
    import fstd.typing
  File "/usr/share/fs-uae-launcher/fstd/typing.py", line 1250, in <module>
    class Callable(extra=collections_abc.Callable, metaclass = CallableMeta):
  File "/usr/share/fs-uae-launcher/fstd/typing.py", line 961, in __new__
    self._abc_registry = extra._abc_registry
AttributeError: type object 'Callable' has no attribute '_abc_registry'

grimi commented on 2014-05-25 12:34

@quite please check python-lhafile comment.

quite commented on 2014-05-25 10:56

I think the problem went away. But no instead with 2.5.5dev, it seems that fs-uae-launcher requires python3 (urllib.parse module not found with python2). But the /usr/bin/fs-uae-launcher is installed with #!/usr/bin/python2 ...

grimi commented on 2014-05-10 05:37

Hi @quite. I haven't got this kind of error. If you still have this problem with 2.5.3. Please notify author on eab forum.

quite commented on 2014-05-05 05:41

Is this just me or...?

Unhandled exception detected in thread MainThread:
SyntaxError:dialog.py:<module>:2

Traceback (most recent call last):
File "/usr/bin/fs-uae-launcher", line 71, in <module>
from fs_uae_launcher.FSUAELauncher import FSUAELauncher
File "/usr/share/fs-uae-launcher/fs_uae_launcher/FSUAELauncher.py", line 12, in <module>
from fs_uae_launcher.ui.download import DownloadGameWindow, DownloadTermsDialog
File "/usr/share/fs-uae-launcher/fs_uae_launcher/ui/download.py", line 10, in <module>
import fsui
File "/usr/share/fs-uae-launcher/fsui/__init__.py", line 21, in <module>
from .qt.dialog import Dialog
File "/usr/share/fs-uae-launcher/fsui/qt/dialog.py", line 2, in <module>
from .windowbase import WindowBase
File "/usr/share/fs-uae-launcher/fsui/qt/windowbase.py", line 17
def __init__(self, parent, *args, title="", **kwargs):
^
SyntaxError: invalid syntax

grimi commented on 2013-09-15 13:53

There is a python2-pyside package, python-pyside is splitted package: python-pyside-common, python2-pyside, python-pyside. You have to install only two first.
Problem is in this, that currently aur have not support a splitting packages.

electrified commented on 2013-09-15 13:02

python2-pyside no longer exists - python-pyside now builds for python 2 and 3

grimi commented on 2013-05-03 05:30

100% exists, check again, or don't use a wrapper to build.

Anonymous comment on 2013-05-02 19:29

install file (fs-uae-launcher-devel.install) does not exist.