Package Details: fs2-knossos 0.14.3-3

Git Clone URL: https://aur.archlinux.org/fs2-knossos.git (read-only, click to copy)
Package Base: fs2-knossos
Description: A simple mod manager for FreeSpace 2 Open
Upstream URL: https://github.com/ngld/knossos
Licenses: Apache
Submitter: ngld
Maintainer: ngld (themaddin)
Last Packager: themaddin
Votes: 7
Popularity: 0.002687
First Submitted: 2014-11-10 18:24
Last Updated: 2021-10-15 19:17

Pinned Comments

themaddin commented on 2021-09-20 21:59

@ Bloodaxe This seems to occur on some systems due to an incompatibility with the dependeny Qt WebKit introduced in qt5-base versions post 5.15.2+kde+r200.

I recommend unpacking this last known-good version (https://archive.archlinux.org/packages/q/qt5-base/qt5-base-5.15.2%2Bkde%2Br200-1-x86_64.pkg.tar.zst) to /opt/oldqt and launching knossos with LD_LIBRARY_PATH set to "/opt/oldqt/usr/lib".

I've brought this up on HLP's discord a while ago and it was deemed not worth fixing, as the new knossos implementation (currently under development by ngld) doesn't use the affected Qt features, and the bug seems hard to reproduce.

Latest Comments

« First ‹ Previous 1 2 3

HalJordan commented on 2018-08-26 08:08

Is this supposed to be for Darwin only?

==> Starting package()... npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

==> ERROR: A failure occurred in package(). Aborting..