Package Details: fs2_open 1:3.7.2-1

Git Clone URL: https://aur.archlinux.org/fs2_open.git (read-only)
Package Base: fs2_open
Description: An enhancement of the FreeSpace 2 engine
Upstream URL: http://scp.indiegames.us
Licenses: custom:fs2_open
Submitter: Lone_Wolf
Maintainer: chungy
Last Packager: chungy
Votes: 27
Popularity: 0.242713
First Submitted: 2007-07-08 18:31
Last Updated: 2015-06-08 12:35

Required by (3)

Sources (5)

Latest Comments

Reihar commented on 2015-04-29 16:58

You forgot to change the version in the /usr/bin script ;)

Schala commented on 2014-06-14 21:55

Please add `jansson` to dependencies

unlimitedbacon commented on 2014-06-10 00:19

PKGBUILD for 3.7.2 RC3: https://gist.github.com/unlimitedbacon/76f5796fbec36602b63f

roadnottaken commented on 2014-05-07 02:53

I'm disowning this because my interest in the game has become too sporadic to give it the attention it deserves.

roadnottaken commented on 2013-09-27 02:42

@1126 Unfortunately I'm out of ideas. Your best bet is probably the support forum on hard-light.net (http://www.hard-light.net/forums/index.php?board=151). You'll probably need to make a debug build, which you can do by adding --enable-debug to the end of the line in the PKGBUILD containing ./autogen.sh .

Anonymous comment on 2013-09-24 07:00

@roadnottaken Thanks for the hint! Alas, it does not seem to resolve the issue. I created a new player and it crashes nevertheless :(

roadnottaken commented on 2013-09-19 01:54

@1126 They rewrote the pilot code for the 3.7 branch, and it's possible the new code interacting with old player profiles are what's causing your crash. Try running the game as a new player and see if that works without crashing.

I believe the s3tc and libpng warnings are unrelated to the crash. I get those warnings on the console whenever I start the game up (I use wxLauncher as well), and they never seem to cause any problems for the game.

Anonymous comment on 2013-09-18 08:25

Thanks for adopting the package!

It ain't working for me (the former version didn't, too) and maybe someone knows why. I start it via wxlauncher and it crashes immediately after I selected a player. When I start wxlauncher via the console, I get the following output:


ATTENTION: default value of option force_s3tc_enable overridden by environment.
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile

Does anyone, by chance, know what to do? ;)

roadnottaken commented on 2013-09-17 16:24

I've adopted this to update to 3.7.0. It's been working well for me for a few days, so hopefully everything is set.

docwild commented on 2013-08-18 00:53

Sorry, I can't really commit to maintaining this but I have adopted to apply this patch. I'm pretty new to arch so I don't know if it is all ok, I know it works for me. Will disown again as I'm not likely to be contactable. If I actually get some time later I might take it again and get it syncing with trunk.

Wesley commented on 2013-08-17 13:42

wanted to patch and update it but the upload of the file fails with "Error - source tarball may not contain nested subdirectories."

first it was because of the file attributes the patch file i loaded had, then it gave me the same error when i made my own patch.

PKGBUILD
http://pastebin.com/raw.php?i=3UnnGwrA

red_alert.patch
http://pastebin.com/raw.php?i=Zayd3GVh

i try to solve this in the next hours but i will disown this package so that someone who understands the issue better then me can fix it.

docwild commented on 2013-08-17 01:07

There is a patch for a game breaking bug here:
http://scp.indiegames.us/mantis/view.php?id=2904

Adding this to the pkgbuild works fine

Wesley commented on 2013-07-30 01:21

update to RC2

Wesley commented on 2013-05-13 08:26

added glu to the dependencies, thanks

wookietreiber commented on 2013-05-12 20:46

namcap reports "glu" should be in depends:

fs2_open E: Dependency glu detected and not included (libraries ['usr/lib/libGLU.so.1'] needed in files ['opt/fs2_open/fs2_open_3.7.0_RC
1'])

Wesley commented on 2013-05-12 08:26

adopted, updated to 3.7.0_RC1

Samsagax commented on 2013-03-31 16:21

Ok. I'll see if i can adopt it. If none stands up for it.

ZekeSulastin commented on 2013-03-30 17:24

Orphaned - between events and equipment failure, no real drive to keep on it.

Have fun, you guys :)

Samsagax commented on 2013-03-29 16:42

Just changing 16->18 seems to work (and updating md5sums)

PKGBUILD: http://pastebin.com/eRs94K72

aricart commented on 2013-03-10 12:04

Newest version is now 3.6.18

ZekeSulastin commented on 2012-12-16 02:03

So yeah, I kinda didn't actually provision for someone making a debug build at all. Derp. Both types of build work here now, and I added a little comment. Also cleaned up conditionals/made the launcher sh/etc. I didn't bump pkgrel though, as it shouldn't affect people with a currently running fs2_open.

As an aside, they're starting to look at some of the wxLauncher bugs that make it not work so well for a pacman'd fs2_open (failure to detect executables - it actually doesn't recognize the Linux 3.6.14s at all >.> - and trying to write to the data dir instead of $HOME/.fs2_open). Yay \o/

wookietreiber commented on 2012-12-15 13:33

$ fs2_open
/usr/bin/fs2_open: line 5: 7025 Segmentation fault (core dumped) /opt/fs2_open/fs2_open_3.6.14 "$@" "$FS2OPTS"
/usr/bin/fs2_open: line 5: /opt/fs2_open/fs2_open_3.6.14_DEBUG: No such file or directory

$ uname -a
Linux mobster 3.6.10-1-ARCH #1 SMP PREEMPT Tue Dec 11 09:40:17 CET 2012 x86_64 GNU/Linux

ZekeSulastin commented on 2012-12-12 22:34

Now uses lua51.

ZekeSulastin commented on 2012-11-17 18:40

You're welcome :)

Inferno builds are now the default if no option is specified, so this is indeed an Inferno build. You can see this by examining the output of the configure script during the build - at the end of it there will be a segment that looks like this:

Configure options:

Text-to-speech enabled . : yes

Debug build ............ : no
Inferno build .......... : yes
GProf support .......... : no

Anonymous comment on 2012-11-17 11:29

hi
thanx for this package. i have question, is this the inferno version?
if not can we please get the inferno version?;)

ZekeSulastin commented on 2012-10-23 23:13

3.6.14 is official!

ZekeSulastin commented on 2012-10-15 05:57

RC9 pushed, will update later today

ZekeSulastin commented on 2012-10-07 23:07

RC9 is coming \o/

tea commented on 2012-08-20 20:30

Hey there, I've put a PKGBUILD up for wxlauncher; the fs2-open cross-platform launcher! It's here: https://aur.archlinux.org/packages.php?ID=62160

ZekeSulastin commented on 2012-06-04 02:11

Not that anyone uses this anymore, but this is good practice at least ;)

Fixed the source link, fixed the dependencies, made pkgver consistent with everything else, added guide links to the post_install script, added an LDFLAG to fix the missing libdl, and added the fix from trunk to make pngutils work with libpng15.

If I can, I'll drop the conflict with the svn version (since some mods want this, some mods want svn, some want the 3.6.14 RCs ...) - the main obstacle is The Babylon Project, as I really don't want to bump a 700 MiB download's pkgrel ...

vagyok commented on 2011-07-15 20:58

I had to change the line

cp -r $srcdir/${pkgname}_${pkgver}_src $srcdir/$pkgname-build

to:

cp -r $srcdir/${pkgname}_${pkgver}_src/* $srcdir/$pkgname-build

because otherwise the contents of the directory were copied into a ${pkgname}_${pkgver}_src directory inside $srcdir/$pkgname-build, which put autogen.sh and the other files and folders one directory-level deeper than expected. Adding /* (as above) fixed this for me.

Lone_Wolf commented on 2010-12-06 22:08

@ R. Daneel :
this pacakge was made by me in 2007, and at that time fs2_open linux version development was a bit chaotic,
upstream did not have files for menus in the package, so i created them.
Due to lack of time i orphaned this package not long after the last update.

Lone_Wolf commented on 2010-12-06 22:07

@ R. Daneel :
this pacakge was made by me in 2007, and at that time fs2_open linux version development was a bit chaotic,
upstream did not have files for menus in the package, so i created them.
Due to lack of time i orphaned this package.

Anonymous comment on 2010-12-06 04:53

I found some issues with your tarball. Binaries are usually frowned upon. This includes:
fs2_open/fs2_open.png
"Just an icon" you say, but maybe you should ask upstream to include it. Please fix this.

Anonymous comment on 2010-09-24 00:15

I'm interested in updating this to the latest version... I'll give it a shot and post results if it works.

Anonymous comment on 2010-07-13 20:23

Just a note, from now on this package will use the inf packages by default as that's what is recommended by the FSO devs.