Package Details: fsearch-git 0.1.r71.ge874642-1

Git Clone URL: https://aur.archlinux.org/fsearch-git.git (read-only, click to copy)
Package Base: fsearch-git
Description: A fast graphical file search utility. Development version.
Upstream URL: https://cboxdoerfer.github.io/fsearch
Keywords: search
Licenses: GPL2
Conflicts: fsearch
Submitter: wander
Maintainer: wander
Last Packager: wander
Votes: 56
Popularity: 2.32
First Submitted: 2016-05-31 16:28
Last Updated: 2022-01-14 18:31

Latest Comments

1 2 3 4 Next › Last »

kescherAUR commented on 2022-01-24 21:04

@mindstormer not happening here. Did you clean build?

mindstormer commented on 2022-01-24 20:56

EDIT: Never mind, my makepkg.conf was broken. No problems, built fine in chroot.

wander commented on 2022-01-14 18:32

@kescherAUR Thank you, fixed.

MarsSeed commented on 2022-01-14 16:13

@kescherAUR You are right. The TLDR version of it is: the PKGBUILD source line need to be changed to use https, like this:

source=('git+https://github.com/cboxdoerfer/fsearch.git')

And ofc the .SRCINFO need to be regenerated.

kescherAUR commented on 2022-01-11 12:31

Package needs modification to the source array in order to build again, please apply the following diff:

diff --git a/.SRCINFO b/.SRCINFO
index 8434683..df1df9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = fsearch-git
        pkgdesc = A fast graphical file search utility. Development version.
-       pkgver = 0.1.r6.g878232a
+       pkgver = 0.1.r71.ge874642
        pkgrel = 1
        url = https://cboxdoerfer.github.io/fsearch
        arch = i686
@@ -12,7 +12,7 @@ pkgbase = fsearch-git
        depends = icu
        depends = pcre
        conflicts = fsearch
-       source = git://github.com/cboxdoerfer/fsearch.git
+       source = git+https://github.com/cboxdoerfer/fsearch.git
        md5sums = SKIP

 pkgname = fsearch-git
diff --git a/PKGBUILD b/PKGBUILD
index 75dbfc7..1de8bfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Christian Boxdörfer <christian.boxdoerfer@posteo.de>
 pkgname=fsearch-git
 _gitname=fsearch
-pkgver=0.1.r6.g878232a
+pkgver=0.1.r71.ge874642
 pkgrel=1
 pkgdesc="A fast graphical file search utility. Development version."
 arch=('i686' 'x86_64')
@@ -10,7 +10,7 @@ license=('GPL2')
 depends=('gtk3' 'icu' 'pcre')
 makedepends=('git' 'meson')
 conflicts=('fsearch')
-source=('git://github.com/cboxdoerfer/fsearch.git')
+source=('git+https://github.com/cboxdoerfer/fsearch.git')
 md5sums=('SKIP')

 pkgver() {

hansbert commented on 2021-12-26 12:39

@wander that did it -- thank you!

wander commented on 2021-12-26 12:36

@hansbert, you need to reinstall/rebuild the fsearch-git AUR package. That's because icu in the main repos was updated in a non-backwards compatible way and hence all packages which depend on it need to be rebuild. From the AUR wiki:

The AUR is unsupported, so any packages you install are your responsibility to update, not pacman's. If packages in the official repositories are updated, you will need to rebuild any AUR packages that depend on those libraries.

hansbert commented on 2021-12-26 12:01

currently broken for me

fsearch: error while loading shared libraries: libicuuc.so.69: cannot open shared object file: No such file or directory

icu is installed though

wander commented on 2021-09-27 07:20

Done: https://aur.archlinux.org/packages/fsearch/

wander commented on 2021-09-27 06:46

@salvaju29ro, I'm going to add a new package for the stable releases.