Package Details: fsharp 4.5.0-3

Git Clone URL: https://aur.archlinux.org/fsharp.git (read-only)
Package Base: fsharp
Description: The F# Compiler, Core Library & Tools (F# Software Foundation Repository)
Upstream URL: http://fsharp.org/
Licenses: MIT
Submitter: arojas
Maintainer: brettgilio
Last Packager: brettgilio
Votes: 29
Popularity: 1.501151
First Submitted: 2017-10-24 07:26
Last Updated: 2018-09-09 21:00

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

NobbZ commented on 2018-09-07 12:54

Because of the pkgver function. It should only be provided when you do dev-builds from a branch, not when you build from a tag or directly from a source tar-ball.

Which brings me to the next, perhaps you should specify <https://github.com/fsharp/fsharp/releases/tag/4.5.0> as source and provide a checksum.

brettgilio commented on 2018-09-07 07:23

@catalin.hritcu

You are correct, it should be 4.5.0-1. I am aware of this issue of the pkgbuild changing its version identification during the build process. I am not sure why this is happening, or what to do about it.

catalin.hritcu commented on 2018-09-07 07:06

Many thanks for making this work again. One little thing I noticed is that the version number of the package I'm obtaining is messed up: "10.2.1-1". Shouldn't it be "4.5.0-1"?

brettgilio commented on 2018-09-06 01:37

Thank you @adsun. I just fixed that and updated the pkgbuild

adsun commented on 2018-09-06 01:31

The new fsharp version removes autogen.sh in favor of just using the provided Makefile.

doctorzeus commented on 2018-08-26 05:37

Thanks @mherzberg :)

mherzberg commented on 2018-08-23 08:49

@delta62 @doctorzeus this error seems related to https://github.com/mono/mono/issues/7805, a change in mono. It looks like it got fixed in fsharp master branch, but the fix didn't make it into a tag yet. Meanwhile, you can try https://aur.archlinux.org/packages/fsharp-git, which tracks the master branch and does not throw the error for me anymore.

delta62 commented on 2018-08-22 02:30

Same compile error as @doctorzeus for me.

$ mono --version
Mono JIT compiler version 5.14.0 (makepkg/f3a2216b65a Fri Aug 17 18:51:18 CEST 2018)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS:           __thread
    SIGSEGV:       altstack
    Notifications: epoll
    Architecture:  amd64
    Disabled:      none
    Misc:          softdebug 
    Interpreter:   yes
    LLVM:          supported, not enabled.
    GC:            sgen (concurrent by default)

$ msbuild /version
Microsoft (R) Build Engine version 15.6.0.0 ( Fri Apr  6 15:55:10 UTC 2018) for Mono
Copyright (C) Microsoft Corporation. All rights reserved.

15.6.0.0

$ dotnet --version
2.1.302

doctorzeus commented on 2018-08-19 06:54

I'm getting this with the latest version of msbuild-stable from the aur:

error FS0041: A unique overload for method 'StartsWith' could not be determined based on type information prior to this program point. A type annotation may be needed. Candidates: String.StartsWith(value: char) : bool, String.StartsWith(value: string) : bool

peteraba commented on 2018-08-09 09:47

@brettgilio thanks!