Package Details: ftl 1.5.13-1

Git Clone URL: https://aur.archlinux.org/ftl.git (read-only)
Package Base: ftl
Description: FTL: Faster Than Light, a spaceship simulation real-time roguelike-like (requires full copy of the game)
Upstream URL: http://www.ftlgame.com/
Licenses: custom:commercial
Submitter: derhamster
Maintainer: Tharre
Last Packager: Tharre
Votes: 33
Popularity: 0.182024
First Submitted: 2012-09-15 15:59
Last Updated: 2015-07-10 15:11

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

dcelasun commented on 2012-12-20 12:27

As I said, it doesn't use (or detect) those libraries. Installing them myself, however, works wonders.

Anyway, using system libs should always be the prefereed way, wouldn't you agree?

derhamster commented on 2012-12-20 12:03

It actually complains about missing libs? I assume you're talking about the ones you mentioned before.
Thats strange. Like I said they are already included in /opt/FTL/data/amd64/lib and /opt/FTL/data/FTL sets LD_LIBRARY_PATH accordingly.

After some previous discussions I decided to just use the prebuilt libraries and install everything in /opt/ because there is no way to recompile FTL itself, in case a dependency gets a so bump.

dcelasun commented on 2012-12-20 11:50

Sorry for the out-of-date, it was an accidental click (I was aiming for notifications).

But yes, those deps are definitely needed as the game complained about missing libs.

Finally, the problem with libstdc++ is not about swrast. It first tries your active driver (r600g in my case) and once it fails (due to the broken libstdc++) it tries swrast and fails again.

Removing the file and the deps I've mentioned should make all the issues go away :)

dcelasun commented on 2012-12-20 11:49

Sorry for the out-of-date, it was an accidental click (I was aiming for notifications).

But yes, those deps are definitely needed as the game complained about missing libs.

Finally, the problem with libstdc++ is not about swrast. It first tries your active driver (r600g in my case) and once it fails (due to the broken libstdc++) it tries swrast and fails again.

Remove the file and the deps I've mentioned should make all the issues go away :)

derhamster commented on 2012-12-20 11:37

Seems you right about libstdc++. There is a problem when using mesas software rasterization. I will upload a new version without libstdc++ sometime today.

derhamster commented on 2012-12-20 11:25

Do you have any problems running FTL the way it is currently packaged? Its still working fine for me. No incompatibilities here. Although, I can only test the x86_64 version.

The dependencies you listed are installed along FTL inside /opt/FTL, so there is no need to list them in the depends array.
And please don't flag this as out-of-date, when thats not really the case. The version available on my HIB account is still the same.

dcelasun commented on 2012-12-20 11:05

Also, the PKGBUILD needs to delete /data/amd64/lib/libstdc++.so.6 as it is compiled for Ubuntu and incompatible with Arch. Deleting it forces the game to use the system lib, which works fine.

dcelasun commented on 2012-12-20 10:52

This package depends on the following, please update the PKGBUILD:

- libbass
- libbassmix
- devil-ilut

derhamster commented on 2012-10-22 16:45

Updated to version 1.02.6

The new file from humblebundle.com has this number 1350405106 in it. I have no idea what it means. If its different for you, rename it to ftl-linux-1.02.6-1350405106.tar.gz

B_E commented on 2012-10-17 10:23

If anybody on amd64 should run into

X Error of failed request: BadAlloc (insufficient resources for operation)
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Serial number of failed request: 30
Current serial number in output stream: 31

or

libGL error: dlopen /usr/lib/xorg/modules/dri/swrast_dri.so failed (/opt/FTL/data/amd64/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/xorg/modules/dri/swrast_dri.so))

try renaming or removing the file /opt/FTL/data/amd64/lib/libstdc++.so.6.