Package Details: fuse-emulator 1.5.7-1

Git Clone URL: https://aur.archlinux.org/fuse-emulator.git (read-only)
Package Base: fuse-emulator
Description: ZX Spectrum emulator.
Upstream URL: http://fuse-emulator.sourceforge.net/fuse.php
Keywords: zx-spectrum
Licenses: GPL
Submitter: bender02
Maintainer: SanskritFritz
Last Packager: SanskritFritz
Votes: 58
Popularity: 0.956263
First Submitted: 2007-04-13 19:26
Last Updated: 2018-12-29 10:21

Latest Comments

« First ‹ Previous 1 2

bender02 commented on 2012-02-08 14:56

@SanskritFritz: Thanks. That's the new libpng. I added a small patch, with it it works for me.

SanskritFritz commented on 2012-02-06 19:32

screenshot.c: In function ‘screenshot_write’:
screenshot.c:176:47: error: ‘Z_BEST_COMPRESSION’ undeclared (first use in this function)
screenshot.c:176:47: note: each undeclared identifier is reported only once for each function it appears in
screenshot.c: In function ‘screenshot_write_fast’:
screenshot.c:182:47: error: ‘Z_BEST_SPEED’ undeclared (first use in this function)
screenshot.c:183:1: warning: control reaches end of non-void function [-Wreturn-type]
screenshot.c: In function ‘screenshot_write’:
screenshot.c:177:1: warning: control reaches end of non-void function [-Wreturn-type]
make[2]: *** [screenshot.o] Error 1
make[2]: *** Waiting for unfinished jobs....
mv -f .deps/settings.Tpo .deps/settings.Po
make[2]: Leaving directory `/Common/Builds/aur/fuse-emulator/src/fuse-1.0.0.1a'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/Common/Builds/aur/fuse-emulator/src/fuse-1.0.0.1a'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Anonymous comment on 2011-01-25 20:18

Thanks!! This is a great emulator!

bender02 commented on 2011-01-24 07:52

Added icon and .desktop file, thanks to Tom Wizetek.

bender02 commented on 2011-01-11 12:38

It's needed in depends, not makedepends, since the fuse binary links against libspectrum. But you have a point with the version.

Anonymous comment on 2011-01-07 16:58

libspectrum>=1.0.0 should be in makedepends.