Package Details: fuse-megasync-git v3.1.4.0.0.g11a7ede0-1

Git Clone URL: https://aur.archlinux.org/megasync-git.git (read-only)
Package Base: megasync-git
Description: MEGASync client based on FUSE (GIT Version)
Upstream URL: https://mega.co.nz/#sync
Licenses: custom:MEGA
Conflicts: fuse-megasync
Provides: fuse-megasync
Submitter: sl1pkn07
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 10
Popularity: 0.088143
First Submitted: 2016-03-12 18:32
Last Updated: 2017-07-18 20:39

Latest Comments

sl1pkn07 commented on 2017-08-12 13:09

builds ok here (today)

prometheus commented on 2017-08-12 11:56

Fails to build:

{standard input}: Assembler messages:
{standard input}:100500: Warning: end of file not at end of a line; newline inserted
{standard input}:102186: Error: unknown pseudo-op: `.l'
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.archlinux.org/> for instructions.
make: *** [Makefile:3643: megaclient.o] Error 4
==> ERROR: A failure occurred in build().
Aborting...

==> ERROR: the build failed
-> Status
failed (1): megasync-cli-git

sl1pkn07 commented on 2017-04-16 20:39

@kyb

try now

sl1pkn07 commented on 2017-04-16 19:27

with LC_ALL=C please

kyb commented on 2017-04-16 19:26

ошибка: не удалось завершить транзакцию (конфликтующие файлы)
/usr/bin/mega-cmd содержится и в 'fuse-megasync-git' и в 'megasync-cli-git'
/usr/bin/mega-exec содержится и в 'fuse-megasync-git' и в 'megasync-cli-git'
/usr/bin/mega-cmd содержится и в 'fuse-megasync-git' и в 'megasync-daemon-git'
/usr/bin/mega-exec содержится и в 'fuse-megasync-git' и в 'megasync-daemon-git'
/usr/bin/mega-cmd содержится и в 'megasync-cli-git' и в 'megasync-daemon-git'
/usr/bin/mega-exec содержится и в 'megasync-cli-git' и в 'megasync-daemon-git'
Обнаружены ошибки, пакеты не обновлены.
==> ВНИМАНИЕ: Ваши пакеты сохранены в /tmp/yaourt-tmp-kyb
==> ОШИБКА: невозможно обновить

sl1pkn07 commented on 2016-12-09 06:58

mega sdk needs a accient version of crypto++

./src/.libs/libmega.so: undefined reference to `non-virtual thunk to CryptoPP::Rijndael::Dec::AdvancedProcessBlocks(unsigned char const*, unsigned char const*, unsigned char*, unsigned long, unsigned int) const'
./src/.libs/libmega.so: undefined reference to `CryptoPP::Rijndael::Dec::AdvancedProcessBlocks(unsigned char const*, unsigned char const*, unsigned char*, unsigned long, unsigned int) const'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:1730: examples/linux/megafuse] Error 1
make[2]: *** Se espera a que terminen otras tareas....
./src/.libs/libmega.so: undefined reference to `non-virtual thunk to CryptoPP::Rijndael::Dec::AdvancedProcessBlocks(unsigned char const*, unsigned char const*, unsigned char*, unsigned long, unsigned int) const'
./src/.libs/libmega.so: undefined reference to `CryptoPP::Rijndael::Dec::AdvancedProcessBlocks(unsigned char const*, unsigned char const*, unsigned char*, unsigned long, unsigned int) const'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:1748: examples/megasimplesync] Error 1
examples/examples_megacli-megacli.o:(.data.rel.ro._ZTVN8CryptoPP16BlockCipherFinalILNS_9CipherDirE1ENS_8Rijndael3DecEEE[_ZTVN8CryptoPP16BlockCipherFinalILNS_9CipherDirE1ENS_8Rijndael3DecEEE]+0xa8): undefined reference to `CryptoPP::Rijndael::Dec::AdvancedProcessBlocks(unsigned char const*, unsigned char const*, unsigned char*, unsigned long, unsigned int) const'
examples/examples_megacli-megacli.o:(.data.rel.ro._ZTVN8CryptoPP16BlockCipherFinalILNS_9CipherDirE1ENS_8Rijndael3DecEEE[_ZTVN8CryptoPP16BlockCipherFinalILNS_9CipherDirE1ENS_8Rijndael3DecEEE]+0x120): undefined reference to `non-virtual thunk to CryptoPP::Rijndael::Dec::AdvancedProcessBlocks(unsigned char const*, unsigned char const*, unsigned char*, unsigned long, unsigned int) const'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:1742: examples/megacli] Error 1
make[2]: se sale del directorio '/tmp/makepkg/megasync-git/src/megasync/src/MEGASync/mega'
make[1]: *** [Makefile:2585: all-recursive] Error 1
make[1]: se sale del directorio '/tmp/makepkg/megasync-git/src/megasync/src/MEGASync/mega'
make: *** [Makefile:1273: all] Error 2


i can't add megacli/megasimplesync in the package right now

fabioca commented on 2016-12-07 12:18

Hi asked Mega for a package which could run on a headless system. They suggested the below.
Any chance the maintainer of this would consider packaging it? Thanks

1) get the latest sources from our GitHub repository: git clone https://github.com/meganz/sdk.git
2) install all required dependencies lib, please refer “Platform Dependencies” section of Readme file
3) configure and compile SDK project: ./configure && make
4) install into your system: sudo make install (by the default executables will be placed in /usr/local/bin)
5) two executables will be installed:
*) megacli - advanced console MEGA client, to get information about available commands please start the application in the Terminal and type “h” to get commands description.
*) megasimplesync – a simple synchronization client, it gets username / password values from corresponding environment variables.

enercen commented on 2016-05-05 08:30

MEGA is now offering a megasync package for ArchLinux. You can download it from: https://mega.nz/#sync. It will also configure their official repo, so that updates will work and you can install nautilus extension.

sl1pkn07 commented on 2016-04-16 13:16

@ghabrielv is a git-basedpackage, just reinstall

oliver_aur commented on 2016-04-08 14:15

The post-install script calls files that are part of xdg-utils and desktop-file-utils. If you don't have them installed you get an error message. Rather than add them as dependencies I think the post-install part should be modified to something like:
[[ -f /usr/bin/update-desktop-database ]] && update-desktop-database -q

All comments