Package Details: fuse-zip 0.7.0-1

Git Clone URL: https://aur.archlinux.org/fuse-zip.git (read-only, click to copy)
Package Base: fuse-zip
Description: FUSE file system to navigate, extract, create and modify ZIP and ZIP64 archives
Upstream URL: https://bitbucket.org/agalanin/fuse-zip
Keywords: utility zip
Licenses: GPL
Submitter: oslik
Maintainer: None
Last Packager: ozderi
Votes: 7
Popularity: 0.38
First Submitted: 2016-02-14 15:38
Last Updated: 2019-12-22 11:31

Latest Comments

1 2 Next › Last »

ozderi commented on 2020-06-27 22:51

Hi xyproto, Not at all ! Good idea :) thank you.

xyproto commented on 2020-06-26 09:11

@ozderi Hi, would you mind if I adopted this package and moved it to [community]?

ozderi commented on 2019-12-22 11:32

Sorry for the delay, I forgot the package :/ I updated to 0.7.0, and I used the command "makepkg --printsrcinfo > .SRCINFO" to generate the SRCINFO file so I hope it will be correct this time. It installs well with trizen at least.

hutou commented on 2019-11-05 22:19

Current version (0.6.0) cannot open zip files created by Dropbox for downloading.

Error messages for each file in archive are :

ls: cannot access '/tmp/ziparchive/2017-07-30 18.30.21.jpg': I/O Error
...
?????????? ? ? ? ?              ? 2017-01-09 18.30.21.jpg
...

Yet, these zip files show no error when tested with zip -T and correctly open in File manager Nautilus.

Zip files created locally by the zip utility are correctly mounted by fuse-zip.

Is this a known issue ?

Morganamilo commented on 2019-07-06 18:39

Also an explanation on why this is invalid and not yay being picky.

Everything after pkgname = is specific to that pkgname and not the pkgbase as a whole. So your srcinfo effectively says:

pkgname=fuze-zip

package() {
    pkgver=0.6.0
}

Which is invalid, as a split package can not override pkgver. Only the fields documented in PKGBUILD (5) can be overridden.`

padv commented on 2019-07-06 16:41

Package fails to install with yay:

$ yay -S fuse-zip

failed to parse fuse-zip: Line 4: key "pkgver" can not occur after pkgname: pkgver = 0.6.0

Occurs since commit https://aur.archlinux.org/cgit/aur.git/commit/?h=fuse-zip&id=c26b994c81b4, pkgname line in .SRCINFO should be at the end as before to avoid this:

 pkgbase = fuse-zip
-       pkgname = fuse-zip
        pkgdesc = FUSE file system to navigate, extract, create and modify ZIP and ZIP64 archives
        pkgver = 0.6.0
        pkgrel = 1
        ...
+
+pkgname = fuse-zip

ozderi commented on 2019-02-08 09:08

Thanks for the flag - the package is updated :)

I keep the Makefile.patch as is, because I consider it's the developer task to maintain his code (especially when he puts so many -warn flags in his Makefile). He'll eventually fix it when he updates his gcc =)

amatwkgs commented on 2018-06-21 11:12

@ozderi I believe that the warnings are due to the use of GCC 8. It can be patched like the following way to make the warnings go away:

-        catch (std::bad_alloc) {
+        catch (std::bad_alloc&) {
-        catch (std::exception) {
+        catch (std::exception&) {

ozderi commented on 2018-06-21 07:53

Package updated. I had to patch the Makefile a little more, because the provided Makefile turn warnings into errors and the code has warnings...

ozderi commented on 2017-12-11 20:03

Oops, sorry. It's updated with correct md5sums now.