Package Details: gajim-git 1:r19005.68eb14225-1

Git Clone URL: (read-only, click to copy)
Package Base: gajim-git
Description: Jabber/XMPP instant messenger client written in Python with GTK+
Upstream URL:
Licenses: GPL3
Conflicts: gajim, gajim-hg, gajim-svn
Provides: gajim
Replaces: gajim-hg, gajim-svn
Submitter: linkmauve
Maintainer: linkmauve (Ppjet6)
Last Packager: linkmauve
Votes: 69
Popularity: 0.000000
First Submitted: 2017-01-04 17:50 (UTC)
Last Updated: 2021-12-27 09:18 (UTC)

Latest Comments

MarsSeed commented on 2022-06-27 19:24 (UTC) (edited on 2022-07-10 18:52 (UTC) by MarsSeed)


I strongly recommend that this should not optdepend on python-crypto. That name is deprecated.

The proper and safe way is to use python-pycryptodome, which is the continuation fork.

Someone has created a wrong package in AUR providing "python-crypto".

That's why it's much better if you declare python-pycryptodome, to ensure this will use the proper dependency.


Edu4rdSHL commented on 2022-05-24 13:26 (UTC)

karolyi, please read, VCS packages doesn't need to bump the pkgrel to match the latest commits, only build issues needs to be addressed.

Do not flag this package for no reasons.

karolyi commented on 2022-05-24 13:23 (UTC)

68eb14225 is an old commit from last December. since then, Gajim 1.4.1 is out already, and as such, this package is outdated as well.

Edu4rdSHL commented on 2022-04-15 22:25 (UTC)

Manifest0 and how's that related to the package? Please, next time go and ask in the Gajim support chat.

Btw, go to the Gajim ACE and set use_libappindicator to Deactivated.

Manifest0 commented on 2022-04-15 22:21 (UTC)

just installed this and the tray icon is not appearing. I just have a blank spot instead. Does anybody know how to fix it? is this a file or link missing?

Farzat commented on 2021-12-27 07:42 (UTC)

Fails with the following message on my machine:

Missing dependency: Namespace GtkSource not available

Installing gtksourceview4 fixed it.

Spheerys commented on 2018-10-08 08:24 (UTC)

The dev version is 1.1 The repo is here :

stevenroose commented on 2018-08-27 19:11 (UTC)

Did you mark the package's version wrong? It says 1.0.0.beta1.r482, shouldn't it be 1.1.0.beta1? Currently it fails to be installed next to gajim-omemo-plugin since that requires gajim >= 1.0.0..

linkmauve commented on 2018-02-23 10:57 (UTC) (edited on 2018-02-23 11:08 (UTC) by linkmauve)

The pkgver is automatically updated in -git packages, they require no bump when the dependencies didn’t change, see

Also this package doesn’t track the 1.0 branch but master, so don’t expect to get beta releases here.

abouvier commented on 2018-01-27 01:27 (UTC)

gajim-git should provide gajim>=1.0.0 and depends on non git python-nbxmpp. It's up to the user to replace python-nbxmpp for python-nbxmpp-git.

JuniorJPDJ commented on 2018-01-17 07:46 (UTC)

Ok, upstream fixed issue.

JuniorJPDJ commented on 2018-01-16 07:34 (UTC) (edited on 2018-01-16 07:35 (UTC) by JuniorJPDJ)

sorry for link, If pasting to comment it's getting into one line


Nothing4You commented on 2017-09-30 20:03 (UTC)

diff -u a/PKGBUILD b/PKGBUILD --- a/PKGBUILD 2017-09-30 22:02:00.598055384 +0200 +++ b/PKGBUILD 2017-09-30 22:02:49.946444442 +0200 @@ -40,13 +40,7 @@ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" } -build() { - cd "$srcdir/$_name" - ./ --prefix=/usr --enable-site-packages - make -} - package() { cd "$srcdir/$_name" - make DESTDIR="$pkgdir/" install + python install --root=$pkgdir --prefix=/usr --optimize=1 }

TrialnError commented on 2017-02-05 23:23 (UTC)

Since a few months, they moved from their own included python-gnupg version to external. (From the 0.16.7 release notes: * Gajim now depends on python-gnupg for PGP encryption) So maybe python2-gnupg could be added as an optdepend?

RavuAlHemio commented on 2016-11-06 16:00 (UTC)

The nbxmpp team has moved to git; please change the dependency from python2-nbxmpp-hg to python2-nbxmpp-git.

DevotedFollower commented on 2016-04-01 20:55 (UTC)

If you are getting the the following error: ImportError: could not import gst gajim Please check here:

azrdev commented on 2015-01-11 19:39 (UTC)

@SamWhited - python2-nbxmpp has been updated to 0.5.2, gajim-hg can again depend on it.

SamWhited commented on 2015-01-01 22:48 (UTC)

Gajim fails to launch as it needs nbxmpp >=0.5.2 (currently the package is 0.5.1). Please change back to python2-nbxmpp-hg

azrdev commented on 2014-11-26 21:04 (UTC)

You may also change the dependency: python2-nbxmpp-hg -> python2-nbxmpp to pull the lib from the normal repos instead of the AUR.

Atterratio commented on 2014-04-01 20:45 (UTC)

Change farstream to farstream-0.1 for call support.

bjo commented on 2014-03-17 21:13 (UTC)

@younish Erm, it's in the dep-list.

younishd commented on 2014-03-17 21:10 (UTC)

Maybe you should add python2-nbxmpp-hg to the dependencies list in PKGBUILD. (You're welcome.)

bjo commented on 2014-02-09 22:27 (UTC)

Does it crash gajim also, if it's not enabled?

Maranda commented on 2014-02-09 22:24 (UTC)

I'd like to suggest the following change to PKGBUILD: package() { cd "${srcdir}/${pkgname}" rm -rf ./plugins/acronyms_expander make DESTDIR="${pkgdir}/" install } That plugin is only useful to developers and subtly causes Gajim crash when you launch the App, if not properly configured

bjo commented on 2013-12-30 18:50 (UTC)

No, the branch needs to be set in the source-array.

schrodinger72 commented on 2013-12-30 17:47 (UTC)

Beta 2 is on branch gajim_0.16 So, change pkgver= to 15203.8f86332529fd and in pkgver() function, above the hg identify -ni add this to change branch: hg up gajim_0.16 Done.

schrodinger72 commented on 2013-12-30 06:37 (UTC)

Hi. Could update to 15192:9931beb5eec2 (corresponds to beta 2 which is out)

bjo commented on 2013-10-03 05:21 (UTC)

Sorry, fixed.

lastmikoi commented on 2013-10-03 04:38 (UTC)

Flagging as «outdated» since it won't build. You just have to remove the duplicate 'd' in {srcddir} in PKGBUILD at line 42 to fix it

lybin commented on 2013-01-27 17:01 (UTC)

mohsen69, fixed.

commented on 2013-01-26 10:45 (UTC)

in optional dependencies: python-gnomekeyring --> python2-gnomekeyring? pycrypto --> python2-crypto?

lybin commented on 2013-01-08 04:05 (UTC)

Added, bjo, thank you.

bjo commented on 2013-01-02 01:56 (UTC)

Please add python2-nbxmpp-hg to the deps, otherwise it won't start.

eworm commented on 2012-07-31 10:16 (UTC)

Starting gajim I get: 12:14:26 (W) gajim.c.check_X509 Import of PyOpenSSL or pyasn1 failed. Cannot correctly check SSL certificate Can you please add python2-pyasn1 to the dependency list? Gajim in [extra] has it as well.

qwertzdenek commented on 2012-05-22 19:30 (UTC)

I spent some time with the lack of sound support and the only thing I needed was the gstreamer0.10-python. It would be good to recommend it. I know that it is obvious, but...

krevedko commented on 2011-08-13 17:38 (UTC)

have problem with python2-bsddb: import error. By now python2-bsddb implements bsddb3, not bsddb as gajim wants. I've used "ln -s /usr/lib/python2.7/site-packages/bsddb3/ /usr/lib/python2.7/lib-dynload/" fat-crunch to make $subj working...

bardo commented on 2011-07-11 11:44 (UTC)

You should build this with the --enable-site-packages option on, otherwise it won't work with the latest python, causing an import error on bsddb. The python2-bsddb dependency should also be added.

lybin commented on 2011-06-13 19:04 (UTC)

Fixed, thx ;)

rwd2 commented on 2011-05-31 06:26 (UTC)

shouldn't 'XMMP' be 'XMPP' ?

lybin commented on 2010-10-21 11:28 (UTC)

Fixed, thx

Changaco commented on 2010-10-21 11:19 (UTC)

I think the "python>=2.5" dependency should be replaced by "python2".

lybin commented on 2010-10-07 21:57 (UTC) Warning: Packages in the AUR assume "base-devel" is installed, and will not list members of this group as dependencies even if the package cannot be built without them. Please ensure this group is installed before complaining about failed builds.

commented on 2010-09-24 11:28 (UTC)

@scippio: yes. that are the dependencies for almost _every_ package built from source. that’s why there is a group base-devel so that dependency lists stay simple. it’s just like base. almost all packages internally depend on glibc but it’s in base so it doesn’t show up in their dependency lists. that’s just how it works.

scippio commented on 2010-09-24 06:57 (UTC)

I installing this package on my new arch installation and I find this dependicies: pkg-config, aclocal(package automake), autoconf, libtool ... I know it's "base-devel" ... but I think that shoud be here.. :/

commented on 2010-06-08 18:10 (UTC)

According to the wiki at "the group 'base-devel' is assumed to be installed when building with makepkg." As automake is in base-devel, there is no need to explicitly mention it.

commented on 2010-06-08 14:06 (UTC)

add "automake" as buildtime-depencie