Package Details: gajim-git r14929.94893191e-1

Git Clone URL: https://aur.archlinux.org/gajim-git.git (read-only)
Package Base: gajim-git
Description: Jabber/XMPP instant messenger client written in Python with GTK+
Upstream URL: https://gajim.org/
Licenses: GPL3
Conflicts: gajim, gajim-hg, gajim-svn
Provides: gajim=0.17
Replaces: gajim-hg, gajim-svn
Submitter: linkmauve
Maintainer: linkmauve
Last Packager: linkmauve
Votes: 67
Popularity: 0.061314
First Submitted: 2017-01-04 17:50
Last Updated: 2017-12-07 11:35

Dependencies (23)

Required by (7)

Sources (1)

Latest Comments

Nothing4You commented on 2017-09-30 20:03

diff -u a/PKGBUILD b/PKGBUILD
--- a/PKGBUILD 2017-09-30 22:02:00.598055384 +0200
+++ b/PKGBUILD 2017-09-30 22:02:49.946444442 +0200
@@ -40,13 +40,7 @@
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

-build() {
- cd "$srcdir/$_name"
- ./autogen.sh --prefix=/usr --enable-site-packages
- make
-}
-
package() {
cd "$srcdir/$_name"
- make DESTDIR="$pkgdir/" install
+ python setup.py install --root=$pkgdir --prefix=/usr --optimize=1
}

TrialnError commented on 2017-02-05 23:23

Since a few months, they moved from their own included python-gnupg version to external.
(From the 0.16.7 release notes: * Gajim now depends on python-gnupg for PGP encryption)
So maybe python2-gnupg could be added as an optdepend?

RavuAlHemio commented on 2016-11-06 16:00

The nbxmpp team has moved to git; please change the dependency from python2-nbxmpp-hg to python2-nbxmpp-git.

DevotedFollower commented on 2016-04-01 20:55

If you are getting the the following error:
ImportError: could not import gst gajim

Please check here:
https://trac.gajim.org/ticket/7836

azrdev commented on 2015-01-11 19:39

@SamWhited - python2-nbxmpp has been updated to 0.5.2, gajim-hg can again depend on it.

SamWhited commented on 2015-01-01 22:48

Gajim fails to launch as it needs nbxmpp >=0.5.2 (currently the package is 0.5.1). Please change back to python2-nbxmpp-hg

azrdev commented on 2014-11-26 21:04

You may also change the dependency:
python2-nbxmpp-hg -> python2-nbxmpp

to pull the lib from the normal repos instead of the AUR.

Atterratio commented on 2014-04-01 20:45

Change farstream to farstream-0.1 for call support.

bjo commented on 2014-03-17 21:13

@younish
Erm, it's in the dep-list.

younishd commented on 2014-03-17 21:10

Maybe you should add python2-nbxmpp-hg to the dependencies list in PKGBUILD. (You're welcome.)

All comments