Package Details: gajim-hg 15618.2dc6bce0eddc-1

Git Clone URL: https://aur.archlinux.org/gajim-hg.git (read-only)
Package Base: gajim-hg
Description: Jabber/XMPP instant messenger client written in PyGTK
Upstream URL: http://hg.gajim.org/gajim
Licenses: GPL3
Conflicts: gajim, gajim-svn
Provides: gajim
Replaces: gajim-svn
Submitter: None
Maintainer: bjo
Last Packager: bjo
Votes: 63
Popularity: 0.034085
First Submitted: 2009-06-10 18:58
Last Updated: 2015-06-08 19:02

Dependencies (19)

Required by (6)

Sources (1)

Latest Comments

DevotedFollower commented on 2016-04-01 20:55

If you are getting the the following error:
ImportError: could not import gst gajim

Please check here:
https://trac.gajim.org/ticket/7836

azrdev commented on 2015-01-11 19:39

@SamWhited - python2-nbxmpp has been updated to 0.5.2, gajim-hg can again depend on it.

SamWhited commented on 2015-01-01 22:48

Gajim fails to launch as it needs nbxmpp >=0.5.2 (currently the package is 0.5.1). Please change back to python2-nbxmpp-hg

azrdev commented on 2014-11-26 21:04

You may also change the dependency:
python2-nbxmpp-hg -> python2-nbxmpp

to pull the lib from the normal repos instead of the AUR.

Atterratio commented on 2014-04-01 20:45

Change farstream to farstream-0.1 for call support.

bjo commented on 2014-03-17 21:13

@younish
Erm, it's in the dep-list.

younishd commented on 2014-03-17 21:10

Maybe you should add python2-nbxmpp-hg to the dependencies list in PKGBUILD. (You're welcome.)

bjo commented on 2014-02-09 22:27

Does it crash gajim also, if it's not enabled?

Maranda commented on 2014-02-09 22:24

I'd like to suggest the following change to PKGBUILD:

package() {
cd "${srcdir}/${pkgname}"
rm -rf ./plugins/acronyms_expander
make DESTDIR="${pkgdir}/" install
}

That plugin is only useful to developers and subtly causes Gajim crash when you launch the App, if not properly configured

bjo commented on 2013-12-30 18:50

No, the branch needs to be set in the source-array.

fabienwang commented on 2013-12-30 17:47

Beta 2 is on branch gajim_0.16
So, change pkgver= to 15203.8f86332529fd
and in pkgver() function, above the hg identify -ni
add this to change branch: hg up gajim_0.16

Done.

fabienwang commented on 2013-12-30 06:37

Hi. Could update to 15192:9931beb5eec2 (corresponds to beta 2 which is out)

bjo commented on 2013-10-03 05:21

Sorry, fixed.

lastmikoi commented on 2013-10-03 04:38

Flagging as «outdated» since it won't build.

You just have to remove the duplicate 'd' in {srcddir} in PKGBUILD at line 42 to fix it

lybin commented on 2013-01-27 17:01

mohsen69, fixed.

Anonymous comment on 2013-01-26 10:45

in optional dependencies:
python-gnomekeyring --> python2-gnomekeyring?
pycrypto --> python2-crypto?

lybin commented on 2013-01-08 04:05

Added, bjo, thank you.

bjo commented on 2013-01-02 01:56

Please add python2-nbxmpp-hg to the deps, otherwise it won't start.

RavuAlHemio commented on 2012-11-27 16:10

The current PKGBUILD only works if the repository has already been cloned at least once. Please fix to perform the initial clone too. (See also /usr/share/pacman/PKGBUILD-hg.proto in the package "abs".)

eworm commented on 2012-07-31 10:16

Starting gajim I get:

12:14:26 (W) gajim.c.check_X509 Import of PyOpenSSL or pyasn1 failed. Cannot correctly check SSL certificate

Can you please add python2-pyasn1 to the dependency list? Gajim in [extra] has it as well.

qwertzdenek commented on 2012-05-22 19:30

I spent some time with the lack of sound support and the only thing I needed was the gstreamer0.10-python. It would be good to recommend it. I know that it is obvious, but...

krevedko commented on 2011-08-13 17:38

have problem with python2-bsddb: import error. By now python2-bsddb implements bsddb3, not bsddb as gajim wants. I've used "ln -s /usr/lib/python2.7/site-packages/bsddb3/_pybsddb.so /usr/lib/python2.7/lib-dynload/_bsddb.so" fat-crunch to make $subj working...

bardo commented on 2011-07-11 11:44

You should build this with the --enable-site-packages option on autogen.sh, otherwise it won't work with the latest python, causing an import error on bsddb. The python2-bsddb dependency should also be added.

bardo commented on 2011-07-11 11:44

You should build this with the --enable-site-packages option, otherwise it won't work with the latest python, causing an import error on bsddb. The python2-bsddb dependency should also be added.

lybin commented on 2011-06-13 19:04

Fixed, thx ;)

rwd2 commented on 2011-05-31 06:26

shouldn't 'XMMP' be 'XMPP' ?

lybin commented on 2010-10-21 11:28

Fixed, thx

Changaco commented on 2010-10-21 11:19

I think the "python>=2.5" dependency should be replaced by "python2".

lybin commented on 2010-10-07 22:13

http://hg.gajim.org/gajim/raw-file/tip/README.html
Runtime Requirements

python2.5 or higher
pygtk2.16 or higher
pysqlite2 (if you have python 2.5, you already have this)

Changaco commented on 2010-10-07 22:07

This PKGBUILD needs an update because of transition to python3.

lybin commented on 2010-10-07 21:57

http://wiki.archlinux.org/index.php/AUR_User_Guidelines
Warning: Packages in the AUR assume "base-devel" is installed, and will not list members of this group as dependencies even if the package cannot be built without them. Please ensure this group is installed before complaining about failed builds.

Anonymous comment on 2010-09-24 11:28

@scippio: yes. that are the dependencies for almost _every_ package built from source. that’s why there is a group base-devel so that dependency lists stay simple.
it’s just like base. almost all packages internally depend on glibc but it’s in base so it doesn’t show up in their dependency lists.
that’s just how it works.

scippio commented on 2010-09-24 06:57

I installing this package on my new arch installation and I find this dependicies: pkg-config, aclocal(package automake), autoconf, libtool ... I know it's "base-devel" ... but I think that shoud be here.. :/

scippio commented on 2010-09-24 06:55

I installing this package on my new arch installation and I find this dependicies: pkg-config, aclocal(package automake), autoconf, libtool ...

scippio commented on 2010-09-24 06:55

I installing this package on my new arch installation and I find this dependicies: pkg-config, aclocal(package automake), autoconf, libtool ...

Anonymous comment on 2010-06-08 18:10

According to the wiki at http://wiki.archlinux.org/index.php/Makepkg "the group 'base-devel' is assumed to be installed when building with makepkg."

As automake is in base-devel, there is no need to explicitly mention it.

Anonymous comment on 2010-06-08 14:06

add "automake" as buildtime-depencie