Package Details: gajim-plugin-omemo 2.9.0-1

Git Clone URL: (read-only, click to copy)
Package Base: gajim-plugin-omemo
Description: Gajim plugin for OMEMO Multi-End Message and Object Encryption.
Upstream URL:
Licenses: GPL
Conflicts: gajim-plugin-omemo-git
Provides: gajim-plugin-omemo
Submitter: cippaciong
Maintainer: bjo
Last Packager: bjo
Votes: 49
Popularity: 0.65
First Submitted: 2016-01-08 01:17 (UTC)
Last Updated: 2023-01-07 19:36 (UTC)

Pinned Comments

cippaciong commented on 2020-07-02 21:01 (UTC) (edited on 2020-07-02 21:02 (UTC) by cippaciong)

Read this before flagging the package as out-of-date

Hello everyone, please be aware that the versioning system used by the omemo plugin can be a little misleading and it might appear that this package is out-of-date while it is not. The versioning convention of the plugin uses different releases for different gajim versions. As an example, at the time of writing the latest version of the plugin compatible with gajim master branch is 2.7.7 but the latest version compatible with gajim 1.1, the one currently present in the repositories, is 2.6.30.

Before flagging this package as out-of-date, please make sure that you are looking at the right changelog for the current stable release shipped in the official arch repositories. In other words, make sure that you are looking at the changelog on the right branch on gajim's gitlab.

For gajim 1.1 the correct changelog is this one:

Thanks :)

Latest Comments

1 2 3 4 5 6 7 Next › Last »

bjo commented on 2023-01-07 19:35 (UTC)

The version is not compatible, I will update to 2.9.0 soon.

TrialnError commented on 2023-01-07 15:32 (UTC)

As gajim 1.6 got released. Is this version compatible or do they need to cut a new release?

blueman commented on 2022-06-02 17:30 (UTC)

@bjo: Thank you very much :)

bjo commented on 2022-06-01 21:03 (UTC)

@blueman: The releases of the plugins went somewhere else, 2.8.15 works now.

bjo commented on 2022-06-01 19:27 (UTC)

@blueman: Yes, I have the same issue, but don't know yet why.

blueman commented on 2022-06-01 18:51 (UTC)

Somehow the plugin is not detected anymore as "installed" in latest gajim? Both gajim and gajim-plugin-omemo are on latest version...

blueman commented on 2021-12-17 13:33 (UTC)

Please update for Python 3.10.

Porkepix commented on 2021-04-10 15:48 (UTC)

Is it possible to improve the version restrictions of dependencies? The way it's currently done, there's a deadlock and user have to uninstall plugin to be able to upgrade Gajim:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing gajim (1.3.1-1) breaks dependency 'gajim<=1.2.90' required by gajim-plugin-omemo

But as plugin requires 1.2.91, we can't upgrade plugin either first.

cippaciong commented on 2021-03-21 10:51 (UTC)

Hi everyone, since I have not been using Gajim for quite a long time now, I'm going abandon this package so that someone else can adopt it and keep up with the maintenance.

Cheers :)

cippaciong commented on 2020-12-05 22:48 (UTC)

@blueman: Sorry, I was in a rush yesterday when I updated the package and I didn't pay enough attention. It should be fixed now by the way. Let me know if you have any other issue and thanks for reporting.