Package Details: gajim-plugin-omemo-git omemo_2.5.8.r498.ge3d75d8-1

Git Clone URL: https://aur.archlinux.org/gajim-plugin-omemo-git.git (read-only, click to copy)
Package Base: gajim-plugin-omemo-git
Description: Gajim plugin for OMEMO Multi-End Message and Object Encryption.
Upstream URL: https://dev.gajim.org/gajim/gajim-plugins/wikis/OmemoGajimPlugin
Licenses: GPL
Conflicts: gajim-plugin-omemo
Provides: gajim-plugin-omemo
Submitter: cippaciong
Maintainer: cippaciong
Last Packager: cippaciong
Votes: 2
Popularity: 0.000000
First Submitted: 2016-06-10 09:58
Last Updated: 2020-01-25 16:48

Latest Comments

Edu4rdSHL commented on 2020-01-23 12:02

@cippaciong:yes, when using gajim-git.

The point is that the package doesn't need to depends of a versioned Gajim release when there's gajim-git, just depends of gajim that's basically what the patch does + some style fixes.

gajim-git and gajim provides gajim so there doesn't matter what you have installed to install the plugin (as should be).

Edit: I know that gajim-git can add gajim>=1.0.0 but sincerely that isn't the right solution.

Thanks.

wurstsalat commented on 2020-01-23 07:44

@cippaciong: My situation was as follows: I installed gajim-git + python-nbxmpp-git. Then I tried to install gajim-plugin-omemo-git, which wants to install gajim 1.1.3 (which is in conflict with gajim-git).

cippaciong commented on 2020-01-22 21:08

@wurstsalat: Hi, when you install the package it will automatically fetch the latest code from git. -git packages on AUR don't need to be updated as their "regular" counterparts when a new release comes out. Regarding your request to depend on gajim-git, doing this would prevent people that are not using gajim-git to install this plugin. Using just gajim as a dependency will satisfy both requirements because gajim-git already provides gajim.

@Edu4rdSHL: Do you have any error building the package?

Edu4rdSHL commented on 2020-01-21 23:40

Hello, please can you apply https://paste.rs/2Xm to fix the current package. Thanks.

wurstsalat commented on 2020-01-19 13:40

@cippaciong: Would you mind updating the plugin to the current master branch (and also to depend on gajim-git)?

cippaciong commented on 2019-01-11 21:32

@peippo: I pushed a new PKGBUILD to detect site-packages path dynamically. Let me know if you have any problem.

peippo commented on 2019-01-09 09:14

Could you make the installation path depend on the current Python version? Python from extra is now at 3.7, but this PKGBUILD has 3.6 hardcoded

Thanks!

cippaciong commented on 2018-04-26 19:18

The -git version is not for faster updates, but for people who want the development version, for whatever reason (testing for example).

zuglufttier commented on 2018-04-26 14:14

Do you think this is needed anymore? The plugin from https://ftp.gajim.org/plugins_releases/ gets updated very frequently.