Package Details: galileo 0.5.1-3

Git Clone URL: https://aur.archlinux.org/galileo.git (read-only)
Package Base: galileo
Description: Utility to securely synchronize a Fitbit tracker with the Fitbit server
Upstream URL: https://bitbucket.org/benallard/galileo
Keywords: fitbit health tracker
Licenses: LGPL3
Submitter: milouse
Maintainer: milouse
Last Packager: milouse
Votes: 12
Popularity: 0.008674
First Submitted: 2014-09-13 00:46
Last Updated: 2017-01-09 16:43

Latest Comments

milouse commented on 2016-11-02 12:37

@justinus, it looks like you have python-requests already installed by another mean than pacman (or other arch package manager). Please remove first this installation before installing the python-request package or remove the python-request dependance in the galileo pkgbuild.

justinus commented on 2016-11-02 11:38

(4/4) checking keys in keyring [######################] 100%
downloading required keys...
:: Import PGP key 4096R/97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161, "N <mail@nicohood.de>", created: 2015-06-18? [Y/n]
(4/4) checking package integrity [######################] 100%
(4/4) loading package files [######################] 100%
(4/4) checking for file conflicts [######################] 100%
error: failed to commit transaction (conflicting files)
python-requests: /usr/lib/python3.5/site-packages/requests/__init__.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/__init__.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/adapters.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/api.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/auth.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/certs.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/compat.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/cookies.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/exceptions.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/hooks.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/models.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/sessions.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/status_codes.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/structures.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/__pycache__/utils.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/adapters.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/api.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/auth.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/certs.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/compat.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/cookies.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/exceptions.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/hooks.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/models.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/packages/__init__.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/packages/__pycache__/__init__.cpython-35.pyc exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/sessions.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/status_codes.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/structures.py exists in filesystem
python-requests: /usr/lib/python3.5/site-packages/requests/utils.py exists in filesystem
Errors occurred, no packages were upgraded.
==> Restart building galileo ? [y/N]

milouse commented on 2016-09-19 07:49

Done. I'm very sorry for the delay, I was not available this week-end.

Sorry again rpodgorny, your comment somehow disapears in my post-holiday mailbox cleanup :s

zoe commented on 2016-09-18 19:29

0.5.1 is available, and works with python 3.
0.5 crashes for me (see : http://pastebin.com/NHwcet4C ).

I made a PKGBUILD which worked for me :
http://pastebin.com/TtY9YZpz
and this very new version (0.5.1 of 18-09-2016) does not crash.

rpodgorny commented on 2016-08-08 18:26

version 0.5 added support for python3. see the updated pkgbuild at http://pastebin.com/8GD1mAhA (updated ebuild for python-pyusb-beta at http://pastebin.com/w8v7w3Gr).

i've just tested it and it works. yay for ditching python2! ;-)

milouse commented on 2015-02-08 14:26

Done @justin8. Sorry for the delay.

justin8 commented on 2015-01-29 09:01

Thanks for maintaining this package. Just 2 quick things. Would it be possible to add a service file like this one to the package? http://hastebin.com/ezikemabig.ini Just to allow it to sync automatically all the time.

And the udev rules should be going in the /usr folder not /etc, since they are package specific not machine specific. (keeping in line with the file-hierarchy man page).

milouse commented on 2014-10-15 23:08

New upstream version. Package now use bitbucket tag as a source, what permit to embed man pages for galileo itself and galileorc file. The global config file is set to some default values in /etc/galileo/config.

milouse commented on 2014-10-12 19:58

Quick fix as a workaround for pyusb incompatibility. Waiting for upstream version 0.4.2 to be out.

milouse commented on 2014-09-13 00:48

Do not forget that this script will only works for an already claimed fitbit tracker. So you must use at least once the windows or mac os x software in order to finish the install of your new device. After it, you can use this scritp for your day to day sync work.