Package Details: game-dev-tycoon 1.4.5-1

Git Clone URL: https://aur.archlinux.org/game-dev-tycoon.git (read-only)
Package Base: game-dev-tycoon
Description: a business simulation game where you start a video game development company
Upstream URL: http://www.greenheartgames.com/app/game-dev-tycoon/
Licenses: Commercial
Conflicts: game-dev-tycoon-demo
Submitter: Jonhoo
Maintainer: Gryffyn
Last Packager: Jonhoo
Votes: 11
Popularity: 0.000000
First Submitted: 2013-04-30 17:12
Last Updated: 2015-06-08 15:33

Required by (0)

Sources (2)

  • game-dev-tycoon
  • game-dev-tycoon.desktop

Latest Comments

Joe084 commented on 2015-06-14 14:19

Hello!
In your PKGBUILD, at line 53, if you replace : "unzip -f" by "tar xzf" and recalculate checkum for new version, then it run fine.

I applied it to install gamedevtycoon-1.5.11.i386-x64 but stuck at screen : "Please wait. Synchronizing Steam Workshop subscriptions"

Any idea ?
Cdt, joe.

Joe084 commented on 2015-06-14 14:17

Hello!
In your PKGBUILD, at line 53, if you replace : "unzip -f" by "tar xzf" and recalcultate checkum for new version, then it run fine.

I applied it to install gamedevtycoon-1.5.11.i386-x64 but stuck at screen : "Please wait. Synchronizing Steam Workshop subscriptions"

Any idea ?
Cdt, joe.

Joe084 commented on 2015-06-14 14:12

Hello!
In your PKGBUILD, at line 53, if you replace : "unzip -f" by "tar xzf" and recalcultate checkum for new version, then it run fine.

I applied it to install the 1.5.11 but stuck at screen "Please wait. Synchronizing Steam Workshop subscriptions"

Jonhoo commented on 2014-03-21 17:03

That's very strange... Could you build in a local directory with `yaourt -G game-dev-tycoon; cd game-dev-tycoon; makepkg` and give me the output of `ls -R src`? Also, please post the output of `md5sum gamedevtycoon-1.4.5.i386-x64.tar.gz`.

RaphAstronome commented on 2014-03-15 21:11

I have some trouble when upgrading game-dev-tycoon using yaourt :

[quote]
==> Lancer la compilation de game-dev-tycoon ? [O/n]
==> ------------------------------------------------
==>
==> Construction et installation du paquet
==> Création du paquet game-dev-tycoon 1.4.5-1 (sam. mars 15 22:06:20 CET 2014)
==> Vérification des dépendances pour l’exécution...
==> Vérification des dépendances pour la compilation...
==> Récupération des sources...
-> game-dev-tycoon trouvé
-> game-dev-tycoon.desktop trouvé
==> Validation des fichiers sources avec md5sums...
game-dev-tycoon ... Réussite
game-dev-tycoon.desktop ... Réussite
==> Extraction des sources...
==> Lancement de build()...
==> You need a full copy of this game in order to install it
==> Download the .tar.gz version of the game and give its path below
==> Searching for "gamedevtycoon-1.4.5.i386-x64.tar.gz" in dir: /tmp/yaourt-tmp-raphastronome/aur-game-dev-tycoon
==> ERREUR : Game file not found, please type path to game setup package:
/home/***/Bureau/gamedevtycoon-1.4.5.i386-x64.tar.gz
==> Found game file, installing...
-> Extracting archive
Archive: gamedevtycoon-1.4.5.i386-x64.tar.gz
-> Fishing out x86_64 version
tar (child): gamedevtycoon-1.4.5-1-x64.tar.gz : open impossible: Aucun fichier ou dossier de ce type
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
==> ERREUR : Une erreur s’est produite dans build().
Abandon...
==> ERREUR: Makepkg n'a pas pu construire game-dev-tycoon.
[/quote]

gamedevtycoon-1.4.5.i386-x64.tar.gz seems to be ok but I can't extract the x64 file. Note gamedevtycoon-1.4.5.i386-x64.tar.gz contents the gamedevtycoon-1.4.5-1-x64.tar.gz file.

Jonhoo commented on 2014-01-08 16:25

Updated.
Please use the "flag package out-of-date" link next time =)

adam777 commented on 2014-01-08 14:14

The game isn't even installed in here this days, but 1.4.5 is out in download zone.

Jonhoo commented on 2013-09-25 09:28

So it is. Updated.

adam777 commented on 2013-09-25 08:16

Changelog says 1.3.13 for linux, but private download link has 1.4.4 for linux.

Jonhoo commented on 2013-09-22 20:38

Not out of date, see changelog at http://www.greenheartgames.com/game-dev-tycoon-changelog/
Newer versions are (currently) for Mac and Windows only.

UnsolvedCypher commented on 2013-07-05 14:57

Thank you everyone!

meridius commented on 2013-07-05 10:10

@adam777, @UnsolvedCypher: Demo version is available here https://aur.archlinux.org/packages/game-dev-tycoon-demo/

@Jonhoo: Thank you for the update!

adam777 commented on 2013-07-05 07:41

First, 1.3.13 is out, as noted here - http://forum.greenheartgames.com/t/game-dev-tycoon-1-3-13-is-rolling-out/5701/22
Second, a demo version is available here - http://www.greenheartgames.com/game-dev-tycoon-downloads/
Perhaps it's possible to make the PKGBUILD handle both the demo and the full version by asking the user what he would like.

UnsolvedCypher commented on 2013-06-26 16:09

Is there a demo version of this on the AUR?

Jonhoo commented on 2013-05-12 20:21

@meridius: Glad to hear it :)

Jonhoo commented on 2013-05-12 20:18

@meridius: Glad to hear it :)

meridius commented on 2013-05-12 20:16

@Jonhoo: OK, seems that pkgrel 3 is a working one from both Guake and Gnome Shell, even with internet connected. I'm not sure how this could be, but I'm glad anyway. I'd let it be for now and see if anyone else is having the white screen issue.

Thank you for your effort.

Jonhoo commented on 2013-05-12 20:07

@meridius: I've removed the proxy stuff now - see how a plain install works for you. I didn't change anything else that should be relevant :/

meridius commented on 2013-05-12 20:00

@Jonhoo: It is not perfect (1 white to 10 normal), but better then ever. I tried to run it directly from Guake; with custom launcher containing the same command from Shell; and original launcher from Shell; it all had the same odds as above.

I suppose you changed something else in this release than the run script, otherwise it just wouldn't make any sense.

Jonhoo commented on 2013-05-12 19:40

@meridius: This is quite weird. What about if you remove all the proxy things, and just run:
nw /opt/greenheartgames/game-dev-tycoon/app.nw/

More or less frequent?

Jonhoo commented on 2013-05-12 19:38

@meridius: But if you change it to

#!/bin/sh
export no_proxy="localhost,127.0.0.1,$no_proxy"
export NO_PROXY="localhost,127.0.0.1,$NO_PROXY"
nw /opt/greenheartgames/game-dev-tycoon/app.nw/

Then it is white every time?!
And the old one:
no_proxy="localhost,127.0.0.1" NO_PROXY="$no_proxy" nw /opt/greenheartgames/game-dev-tycoon/app.nw/

Still works every time?

meridius commented on 2013-05-12 19:32

@Jonhoo: No, both are random. Even the old one was, but it had "better odds".

Jonhoo commented on 2013-05-12 19:26

@meridius: But if you change it to

#!/bin/sh
export no_proxy="localhost,127.0.0.1,$no_proxy"
export NO_PROXY="localhost,127.0.0.1,$NO_PROXY"
nw /opt/greenheartgames/game-dev-tycoon/app.nw/

Then it is white every time?!
And the old one:
no_proxy="localhost,127.0.0.1" NO_PROXY="$no_proxy" nw /opt/greenheartgames/game-dev-tycoon/app.nw/

Still works every time?

meridius commented on 2013-05-12 19:21

@Jonhoo: Both are OK for 3 from 5 times on both Guake and Shell. I'm starting to think that this is some kind of random behavior and I'm getting tired with it.

Jonhoo commented on 2013-05-12 18:45

@meridius: Wow, this is weird... Could you try using this:
#!/bin/sh
export no_proxy="localhost,127.0.0.1"
export NO_PROXY="localhost,127.0.0.1"
nw /opt/greenheartgames/game-dev-tycoon/app.nw/

and if that doesn't work, then this:

#!/bin/sh
no_proxy="localhost,127.0.0.1" NO_PROXY="localhost,127.0.0.1" nw /opt/greenheartgames/game-dev-tycoon/app.nw/

Jonhoo commented on 2013-05-12 18:43

@meridius: Wow, this is weird... Could you try using this:
#!/bin/sh
export no_proxy="localhost,127.0.0.1"
export NO_PROXY="localhost,127.0.0.1"
nw /opt/greenheartgames/game-dev-tycoon/app.nw/

and if that doesn't work, then this:

#!/bin/sh
no_proxy="localhost,127.0.0.1" NO_PROXY="localhost,127.0.0.1" nw /opt/greenheartgames/game-dev-tycoon/app.nw/

meridius commented on 2013-05-12 18:35

@Jonhoo: Man, this is quirky! It seems that changing /usr/bin/game-dev-tycoon to previously working version does help after all.

meridius commented on 2013-05-12 18:32

@Jonhoo: I don't know what you did, but you should take it back. I have white screen from both Gnome Shell and Guake with internet connected and changing /usr/bin/game-dev-tycoon to previously working version doesn't help. The game can run only with internet disconnected.

adam777 commented on 2013-05-12 18:21

I have the audio problems as well, running with ALSA.
If I remember correctly, the same thing happened when initially upgrading from Chromium 25 to 26 with ALSA, so I suspected it might be more related to the game itself.
Anyway, I posted the issue in the developer forum - http://forum.greenheartgames.com/t/audio-problems-with-native-linux-version/3604

Jonhoo commented on 2013-05-12 18:01

@meridius: Remove the changes you made to /usr/bin/game-dev-tycoon and try the updated package I just uploaded. Hopefully that should fix the issue for both Guake and Gnome Shell :)

meridius commented on 2013-05-12 17:52

@Jonhoo: Great! Now I can run it from Guake just fine. The white screen is only when I run it from Gnome Shell (3.6.3.1-3, because I don't want to update yet).

Jonhoo commented on 2013-05-12 17:44

@meridius: And:
no_proxy="localhost,127.0.0.1" NO_PROXY="$no_proxy" nw /opt/greenheartgames/game-dev-tycoon/app.nw/

meridius commented on 2013-05-12 17:42

@Jonhoo: About the same.

Jonhoo commented on 2013-05-12 17:35

@meridius: How about:
no_proxy="localhost,127.0.0.1,$no_proxy" nw /opt/greenheartgames/game-dev-tycoon/app.nw/

meridius commented on 2013-05-12 17:20

@Jonhoo: I run node-webkit 0.5.1-1 (installed today).
After modifying /usr/bin/game-dev-tycoon I get white screen only 2 of 10 times with internet connected.

Jonhoo commented on 2013-05-12 17:12

@meridius: What version of node-webkit are you running? Apparently there should have been a fix in 0.5.1...

Jonhoo commented on 2013-05-12 17:11

@meridius: Hmm.. Could you try modifying /usr/bin/game-dev-tycoon to this:

#!/bin/sh
http_proxy="" nw /opt/greenheartgames/game-dev-tycoon/app.nw/

And then see if it'll run normally with the internet connected?

meridius commented on 2013-05-12 17:02

@Jonhoo: I can confirm that with disconnected internet the white screen isn't showing. While I enable it again the problem is back.

Jonhoo commented on 2013-05-12 16:46

@meridius: It seems there is a know issue with node-webkit and proxy settings (http://forum.greenheartgames.com/t/win-game-doesn-t-load-white-screen/430/70?u=jon). Could you try disconnecting your internet and try again?

Jonhoo commented on 2013-05-12 16:44

@meridius: yes, those messages are to be expected. I think the IO loop errors may be what is causing the occasional choppiness, but I'm not sure about that.

Are you sure you've downloaded 1.3.9 and are pointing the installer to that? It was only released earlier today, but I believe they've addressed quite a few bugs... Could you try running it from xterm or another terminal? And could you try running it from the application shortcut (through a launcher or the applications menu)?

meridius commented on 2013-05-12 16:23

@Jonhoo: So I updated alsa-lib from alsa-lib-1.0.27-1 to alsa-lib-1.0.27-2 and the game WAS playable for the first try with just a few sound and video chops now and then. Also I get these errors now, which I think are the ones you are having:
[965:0512/180513:ERROR:zygote_host_impl_linux.cc(146)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[985:0512/180513:ERROR:renderer_main.cc(203)] Running without renderer sandbox
[985:0100/000000:ERROR:audio_output_device.cc(247)] IO loop going away before the audio device has been stopped
[985:0100/000000:ERROR:audio_output_device.cc(247)] IO loop going away before the audio device has been stopped

I tried to run it again repeatedly but 5 of 10 times I got good sound BUT completely white screen where only mouse was changing cursor while hovering above buttons. I figured this problem might be linked to Guake terminal from which I run the game, for if I minimize the Guake window quickly enough, the game is running fine. I might add that other fullscreen programs I run from Guake are running just fine.

Jonhoo commented on 2013-05-12 15:40

@meridius: Could you try installing alsa-lib and see if that helps?

The SUID sandbox error is to be expected because node-webkit disables the sandbox on purpose. The IO loop message I get too, and the sound is occasionally a bit choppy, but it's usually fine.

Could you perhaps also try running the game with ALSA instead of PulseAudio, just as an experiment?

meridius commented on 2013-05-12 15:27

When I run the game I get the following messages with jerky both sound and game:
[31274:0512/171249:ERROR:zygote_host_impl_linux.cc(146)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[31294:0512/171249:ERROR:renderer_main.cc(203)] Running without renderer sandbox
ALSA lib pcm_pulse.c:752:(pulse_prepare) PulseAudio: Unable to create stream: Spojení přerušeno
ALSA lib pcm.c:7823:(snd_pcm_recover) cannot recovery from underrun, prepare failed: Chyba vstupu/výstupu
[31274:0512/171308:ERROR:alsa_output.cc(624)] Failed querying available frames. Assuming 0: Chyba vstupu/výstupu
[31274:0512/171308:ERROR:alsa_output.cc(438)] Failed to write to pcm device: Chyba vstupu/výstupu
[31294:0100/000000:ERROR:audio_output_device.cc(247)] IO loop going away before the audio device has been stopped
[31294:0100/000000:ERROR:audio_output_device.cc(247)] IO loop going away before the audio device has been stopped


Sometimes I manage to (by accident) run the game OK(ish) with a lot less choppy sound and video, but still with these errors:
[31467:0512/171416:ERROR:zygote_host_impl_linux.cc(146)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[31487:0512/171416:ERROR:renderer_main.cc(203)] Running without renderer sandbox
[31487:0100/000000:ERROR:audio_output_device.cc(247)] IO loop going away before the audio device has been stopped
[31487:0100/000000:ERROR:audio_output_device.cc(247)] IO loop going away before the audio device has been stopped

I played my copy on Windows before just fine and can't wait to play it on Arch.
Thanks in advance.

Jonhoo commented on 2013-05-07 11:23

makepkg does not install dependencies by default. Usually, you can use the -s flag to also install dependencies, but because node-webkit is in the AUR it cannot be installed by pacman. If you use an AUR package manager like yaourt, it will look for dependencies in the AUR as well and install them correctly, but if you don't you'll have to install node-webkit manually.

Anonymous comment on 2013-05-07 10:04

The build failed at first:

==> Making package: game-dev-tycoon 1.3.8-1 (Tue May 7 11:59:29 CEST 2013)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: node-webkit
==> ERROR: 'pacman' failed to install missing dependencies.

After installing the node-webkit manually it worked!

However thanks for the package!

Jonhoo commented on 2013-05-02 00:19

Same file, just different filename. I've updated the PKGBUILD to search for the right filename now.

Jonhoo commented on 2013-05-01 23:16

Same file, just different filename. I've updated the PKGBUILD to search for the right filename now.

d4m4s74 commented on 2013-05-01 20:49

Before I forget. There's a new version, I think, or at least a new md5 checksum:
ec2dd3534744545f54689e8611c13e1a gamedevtycoon-1.3.1.tar.gz

d4m4s74 commented on 2013-05-01 20:27

Thanks man, it kind of sucked buying it and not being able to play it because of libgconf not being compatible