Package Details: games_nebula 20180605-2

Git Clone URL: https://aur.archlinux.org/games_nebula.git (read-only)
Package Base: games_nebula
Description: Unofficial Linux client for GOG
Upstream URL: https://github.com/yancharkin/games_nebula
Licenses: GPL
Conflicts: games_nebula
Provides: games_nebula
Submitter: xilent
Maintainer: xilent
Last Packager: xilent
Votes: 4
Popularity: 0.579681
First Submitted: 2017-12-08 09:50
Last Updated: 2018-10-04 08:01

Latest Comments

yochananmarqos commented on 2019-01-16 23:12

I updated the PKGBUILD to not require running the setup.sh after: https://github.com/yochananmarqos/pkgbuilds/blob/master/games_nebula/PKGBUILD

I created a git version as well: https://github.com/yochananmarqos/pkgbuilds/blob/master/games_nebula-git/PKGBUILD

Before you install via my PKGBUILD:

If you have the AUR package installed and have run the setup.sh, uninstall it first and delete /opt/games_nebula as there will be leftover, untracked files.

yangtsesu commented on 2018-10-03 01:57

Feature Request: use python instead of python2.

xilent commented on 2018-07-04 10:23

Thanks @NeodarZ for the suggestions.

I did not use the last code part, since it would introduce unnecessary folders. Also included a echo message, that instructs to run the setup.sh before first start.

@sgsaenger Thanks. I added the packages to dependencies and restructured opt-depends and depends.

NeodarZ commented on 2018-06-10 13:00

Hi, looks like it's depends on python-gobject for version 20180605

And please update your PKGBUILD with this:

pkgver=20180605
source=(${pkgname}_${pkgver}.tar.gz::"https://github.com/yancharkin/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('4803b3e19e2ed7725dc16feeb69a7a96d14a53d521f8c90c154b1dd21ce3902c')
echo '#!/bin/bash
    python2 "/opt/games_nebula/games_nebula-${pkgname}/games_nebula.py"' > "${pkgdir}/usr/bin/${pkgname}"

sgsaenger commented on 2018-04-30 21:21

Hi, looks like this now depends on python2-pytz and python2-requests.

xilent commented on 2017-12-22 13:58

Hi @jathanasiou. I added xrandr to the dependencies. Thanks for reporting.

jathanasiou commented on 2017-12-22 00:31

Hey there @xilent. It appears that xrandr might be needed as well as per this issues: https://github.com/yancharkin/games_nebula/issues/15 . Perhaps it should be added to the dependencies?

xilent commented on 2017-12-08 14:04

Please note: Login is currently broken on lgogdownloader > 3.2. So if you wan't a working login please download the lgogdownloader snapshot from the aur and replace pkgver with 3.2.

See: https://github.com/yancharkin/games_nebula/issues/12