Package Details: gandi.cli 1.4-3

Git Clone URL: (read-only)
Package Base: gandi.cli
Description: Gandi command line interface
Upstream URL:
Licenses: GPL3
Submitter: rdoursenaud
Maintainer: rdoursenaud
Last Packager: rdoursenaud
Votes: 5
Popularity: 0.125027
First Submitted: 2014-09-20 12:27
Last Updated: 2019-02-22 15:14

Latest Comments

1 2 Next › Last »

ganymede commented on 2019-01-12 19:58

Thank you for the last update. There are 2 lines for makedepends, one would be better : makedepends=('python-setuptools' 'python-docutils')

rdoursenaud commented on 2017-01-16 10:02

@Spheerys yes, these are checks that rely on Gandi services that they shut down.
Upstream has patches that will come with 0.20 release.
Until then, you can comment the checks and hope for the best ;)

Spheerys commented on 2017-01-15 18:54

I have a lots of error during installation of the unit test :

What's going wrong ?

rdoursenaud commented on 2016-08-22 11:49

@zorun Thanks. I've just updated the package to v0.19 without that useless dependency.

zorun commented on 2016-08-22 10:31

There is a dependency on python-httpretty, but it does not seem to be used:

==> Starting build()...
==> Starting check()...

Searching for httpretty==0.8.6
Best match: httpretty 0.8.6
Processing httpretty-0.8.6.tar.gz

It seems that gandi-cli really wants httpretty 0.8.6, while arch has 0.8.14 currently.

rdoursenaud commented on 2015-12-14 17:43

The package is not working at the moment because I'm too lazy to package and maintain a special python-click version.
The bug has been reported upstream:
My apologies for any inconvenience.

FMB commented on 2015-11-06 18:16

rdoursenaud: thanks for your help.

rdoursenaud commented on 2015-11-06 07:52

@FMB The bug is fixed upstream at
Let's wait for a new release.
In the meantime, you can edit the PKGBUILD and comment the test, knowing that the contact command won't work…

FMB commented on 2015-11-05 10:49

Now I can install python-click, but gandi.cli won't install because tests fail. Some of these errors look like incompatibilities between Python 2 and Python 3.

FMB commented on 2015-11-04 15:35

Some kind of cache, I guess. I'll report the issue if it still can't be installed by tomorrow.